Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bell Canada video taking almost all my memory. Not sure if it's the website or firefox. Did memory measurement.

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 3 views
  • Freagra is déanaí ó Avner

more options

Strange problem. My provider, Bell Canada, has an option via their website for me to view anything from live Bell TV or even my PVR on any device with a browser (in my case latest Firefox on win10). The problem is it is taking up most of my ram, and as I'm sure many will attest to, when Win10 has less than a couple of GB of ram, it just grinds to a halt (30-40 seconds to open a tiny 10kB spreadsheet, etc.).

I did a memory measurement from the about: thing. Perhaps one of you wizards can tell me if it's a firefox issue or a problem with the Bell website/scripts/whatever? I just cannot believe that it takes 8 GB to watch a video stream. That's more than an entire DVD movie - with all the alternate-language soundtracks and special features!

10,369.05 MB (100.0%) -- explicit ├───8,475.00 MB (81.73%) -- window-objects │ ├──8,473.59 MB (81.72%) -- top(https://tv.bell.ca/watch/recording- (deleted info) │ │ ├──8,257.39 MB (79.63%) -- active │ │ │ ├──8,254.29 MB (79.61%) -- window(https://tv.bell.ca/watch/recording (deleted info) │ │ │ │ ├──7,967.99 MB (76.84%) -- js-realm(https://tv.bell.ca/guide) │ │ │ │ │ ├──7,932.14 MB (76.50%) -- classes │ │ │ │ │ │ ├──6,769.33 MB (65.28%) -- class(ArrayBuffer)/objects │ │ │ │ │ │ │ ├──6,767.27 MB (65.26%) ── malloc-heap/elements/normal │ │ │ │ │ │ │ └──────2.05 MB (00.02%) ── gc-heap

  (deleted info, small memory elements)

├───1,703.55 MB (16.43%) ── heap-unclassified

Ouch. I mean, ouch. Good to find out if there's some way to fix this. Thanks ahead of time! Avner

Réiteach roghnaithe

Okay, after no reply here for about a week, I finally sat on the phone waiting for Bell.ca tech support. I had a lot of difficulty convincing the level 1 support agent to escalate my problem (since technically the tv playback *was* working), but eventually she asked her colleagues.

You know what she replied with? Watch in a private browsing window. I was extremely skeptical at first, but for some bizarre reason, it did the trick! I was sitting at around 7/16 GB ram used, and after starting their web viewer, the memory use barely budged!

No clue why, doesn't make sense to me, but here's hoping some other poor sod with the same problem finds my post.

Cheers, Avner

Read this answer in context 👍 0

All Replies (3)

more options

Réiteach Roghnaithe

Okay, after no reply here for about a week, I finally sat on the phone waiting for Bell.ca tech support. I had a lot of difficulty convincing the level 1 support agent to escalate my problem (since technically the tv playback *was* working), but eventually she asked her colleagues.

You know what she replied with? Watch in a private browsing window. I was extremely skeptical at first, but for some bizarre reason, it did the trick! I was sitting at around 7/16 GB ram used, and after starting their web viewer, the memory use barely budged!

No clue why, doesn't make sense to me, but here's hoping some other poor sod with the same problem finds my post.

Cheers, Avner

Helpful?

more options

That was very good work. Well Done.


Some add-ons are not active when using Private Windows.

It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Helpful?

more options

Wow, it seems there's a memory leak even with no addons enabled (and Firefox restarted).

The leak is typically about 1 GB/hour (very roughly, as it varies if pause is pressed, or a show is ended and another one selected, etc.).

I did not play with hardware acceleration, but for some reason unchecked "Use recommended performance settings" leaving hardware acceleration checked. But this would have been the case for the private window test, where the same website didn't use all my memory.

I can try again tomorrow with hardware acceleration off, and all add-ons still disabled, to see if it helps.

Thanks, Avner

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.