Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Latest update forces dark context menus and bookmark menus.

more options

How do I get rid of this crap? I either select a crappy system theme and everything turns a blinding white, or go back to the theme I usually use where everything suddenly is dark. How do I remove darkmode while retaining my favorite theme? I don't want dark mode and I certainly do not want to be blinded either. There must be a useless setting added to the about:config that I can disable.

Thank you.

Réiteach roghnaithe

I thought came to mind after perusing some of the other threads. A contributor Jscher provided a helpful tip that you could also try out:

type about:config into the address bar to open up the configurator (as i call it). except the warming message that will pop up.

next search for: browser.proton.enabled

then double click over the term "true" and change it to false. then close and relaunch FF.


WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed.

If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue.

do you find some improvements that result from the above tweak?

Read this answer in context 👍 1

All Replies (20)

more options

·´¯`·...¸>-)))º> ~dbben said

hmm? but it was white on yesterday !  :-) after looking around on my pc, i notice that it stayed white on v88 but is rosey on v89. how about your bookmarks on menu bar? when it drops down, is a black with white letters or white with black letters?

The bookmarks/context menus are back to normal, thank you. ^^ It's just the rosey/red bits I'd like altered and this issue is more or less solved!

more options

there are some elements of the browser i cannot modify - yet.

but lets see if this little trick (that i forgot to mention) will work for you.

it entails converting the browser to white theme in order to wash out some of the elements.

and then apply the roseyblue theme will compensate for the other elements.

1) so right click on the toolbar and select "customize toolbe"

2) at the bottom whree the theme selector is, enable the "white theme"

3) after the browser turns white, next select roseyblue

4) click done button, close tab and see if you find some improvement

more options

·´¯`·...¸>-)))º> ~dbben said

there are some elements of the browser i cannot modify - yet. but lets see if this little trick (that i forgot to mention) will work for you. it entails converting the browser to white theme in order to wash out some of the elements. and then apply the roseyblue theme will compensate for the other elements. 1) so right click on the toolbar and select "customize toolbe" 2) at the bottom whree the theme selector is, enable the "white theme" 3) after the browser turns white, next select roseyblue 4) click done button, close tab and see if you find some improvement

Hmmm no, still looks the same to me...

more options

I've attached one of v89 on my system. i believe your system is not looking like in the pic. Can you take a screen shot for me?

more options

LOL! FF is trying to be difficult for you.  :-)

(just kidding)

So there has to be a trick at hand to use.

What i think you could try is:

Go to the add-on website again at:

https://addons.mozilla.org/en-US/firefox/addon/dbbenroseysky/

while there, turn your browser into ghost white via the "customize toolbar" methodology. then press "done" button and close tab.

next, re-apply the theme from the add-on page above.

Then let us see if this triggered those fields to remain white.

if not, then i will have to see why the color "white" for those fields are being overwritten by the rosey color.

Athraithe ag ·´¯`·...¸>-)))º> ~dbben ar

more options

·´¯`·...¸>-)))º> ~dbben said

LOL! FF is trying to be difficult for you.  :-) (just kidding) So there has to be a trick at hand to use. What i think you could try is: Go to the add-on website again at: https://addons.mozilla.org/en-US/firefox/addon/dbbenroseysky/ while there, turn your browser into ghost white via the "customize toolbar" methodology. then press "done" button and close tab. next, re-apply the theme from the add-on page above. Then let us see if this triggered those fields to remain white. if not, then i will have to see why the color "white" for those fields are being overwritten by the rosey color.

I tried, it still turns rosey with red outlines around tabs. :( So strange...

more options

This was added as a "feature" in the last Firefox update, I have a laptop which I haven't done the update and they are still white backgrounds. Now the background on my right sidebar bookmarks is black and so are some drop down boxes on websites. If I wanted this to look like Chrome I could just use Chrome.

Anyway to roll back this latest update of be able to change these back ground colors?

more options

The theme i created may not be 100% perfect. But it was made to colorize the surface of the browser with sky blue. And the menu options and drop downs are soft white with darken text. In some case, the text is rosey and other its dark blue.

Try it out. Its a very simply theme. And if it doesnt work out, then you can disable it via the Toolbar Customize feature Theme select.

I believe i read someone else created a new theme too. If i find it, i will post here for you to try out as well.

more options

·´¯`·...¸>-)))º> ~dbben said

The theme i created may not be 100% perfect. But it was made to colorize the surface of the browser with sky blue. And the menu options and drop downs are soft white with darken text. In some case, the text is rosey and other its dark blue. Try it out. Its a very simply theme. And if it doesnt work out, then you can disable it via the Toolbar Customize feature Theme select. I believe i read someone else created a new theme too. If i find it, i will post here for you to try out as well.

Thank you, but... I am not sure how to find it! :(

more options

I did find a new theme designed for FF89. but it was too dark and also unpredictable.

more options

In any case, you can finds themes on your system either via add-ons/extensions/themes section under options.

also via customize toolbar. just right click near the address or search bar and select "customize".

the pic attached show you where some of the themes can be selected

more options

·´¯`·...¸>-)))º> ~dbben said

In any case, you can finds themes on your system either via add-ons/extensions/themes section under options. also via customize toolbar. just right click near the address or search bar and select "customize". the pic attached show you where some of the themes can be selected

Yes I know how to find them, but not how to find yours specifically. :) I already have yours installed and no idea how to find more by you.

Athraithe ag fifawof274 ar

more options
more options

·´¯`·...¸>-)))º> ~dbben said

oh i see. here is the link: https://addons.mozilla.org/en-US/firefox/addon/dbbenroseysky/

Then I was doing it right, it just appeared the same as before. Rosey url bar and red tab outlines. What am I doing wrong then?

more options

You are not doing anything wrong. For some users of FF89, the themes colors are all in the right places. But for other FF89 users, they are slightly off. I think it could be due to add-on and or extensions that have some control as part of their services you needed from them.

additionally, the theme i created is very simple. its kind of like lipstick on the surface. so i would really have to do some fancy programming in order to compensate for all the variables involved.

however, it 100% does not prevent you from searching around for other themes. For example, i know that basic white theme in FF seems to override other themes. So perhaps, someone capitalize on this white theme and added pleasant accents to it via a theme.

incidentally, you do have the option to install FF88.

more options

·´¯`·...¸>-)))º> ~dbben said

You are not doing anything wrong. For some users of FF89, the themes colors are all in the right places. But for other FF89 users, they are slightly off. I think it could be due to add-on and or extensions that have some control as part of their services you needed from them. additionally, the theme i created is very simple. its kind of like lipstick on the surface. so i would really have to do some fancy programming in order to compensate for all the variables involved. however, it 100% does not prevent you from searching around for other themes. For example, i know that basic white theme in FF seems to override other themes. So perhaps, someone capitalize on this white theme and added pleasant accents to it via a theme. incidentally, you do have the option to install FF88.

Yeah. Thanks. Seems a bit too much work to downgrade so I'll have to stick with firefox's crappy update, which they probably won't even bother fixing. It's all too common for... well almost every developer really, to just throw in stuff nobody asked for and call it a day.

I'll just have to live with not being able to use my favorite theme ever again.

Thanks for your help.

more options

you're welcome.  :-)

more options

Réiteach Roghnaithe

I thought came to mind after perusing some of the other threads. A contributor Jscher provided a helpful tip that you could also try out:

type about:config into the address bar to open up the configurator (as i call it). except the warming message that will pop up.

next search for: browser.proton.enabled

then double click over the term "true" and change it to false. then close and relaunch FF.


WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed.

If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue.

do you find some improvements that result from the above tweak?

Athraithe ag Chris Ilias ar

more options

·´¯`·...¸>-)))º> ~dbben said

I thought came to mind after perusing some of the other threads. A contributor Jscher provided a helpful tip that you could also try out: type about:config into the address bar to open up the configurator (as i call it). except the warming message that will pop up. next search for: browser.proton.enabled then double click over the term "true" and change it to false. then close and relaunch FF. WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed. If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue. do you find some improvements that result from the above tweak?

Disabling the proton setting and restarting the browser had no effect, unfortunately. :(

Thanks though.

EDIT: Oh it worked now, thank you! A million times thank you.

I really hope I get to keep this now...

Athraithe ag fifawof274 ar

  1. 1
  2. 2
  3. 3