Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox 89 says compact mode is "not supported" FF89 takes up too much screen space!

  • 12 freagra
  • 5 leis an bhfadhb seo
  • 79 views
  • Freagra is déanaí ó jscher2000

more options

First of all: I tried to "give feedback" first, by going to that crowdicity website. I had to create an account, then I created an "idea" but it wasn't even allowed by the mods.

The 89 design is not user friendly, it takes away too much of my screen. I want to see the website, not some bloated tabs. And what on earth is meant by unsupported in the customize menu when I try to select compact? I always recommendet Firefox, among my friends and family as well as among my customers. Since day 1 I was with you, but this is just the absolute opposite of user friendliness. Even Microsoft Edge shows more of the actual website, I'm trying to look at. No "unsupported" compact mode needed, it is already even less obstrusive than that.

There were so many users who begged you not to do this. But you didn't listen. I want to be nice and kind but you gotta listen to your users, not just rely on your telemetry data. If someone chooses to install Firefox, a lot of people have the ability and knowledge to turn off that stuff. Those are your most loyal users. Listen to them.

Attached screenshots

All Replies (12)

more options

Hi,

Compact mode is not currently supported starting from Firefox 89. If you've been using compact mode before Firefox 89, you should be able to retain the feature. However, for the recommended and supported experience, we encourage you to keep the normal density setting.

If you are an advanced user, it's still possible to activate it in the Configuration Editor (about:config page).

  1. Type about:config in the address bar and press Return. A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
  2. Find the browser.compactmode.show preference.
  3. Switch the toggle to true and then close the tab.
  4. Click on the menu button fx89menu to open the menu panel.
  5. Click More Tools menu.
  6. Choose Customize Toolbar.
  7. At the bottom of the panel, click the Density button.
  8. Choose Compact (not supported) from the menu options.
  9. Click Done.

More about that: Compact mode workaround in Firefox

more options

Seburo schrieb

Hi, Compact mode is not currently supported starting from Firefox 89. If you've been using compact mode before Firefox 89, you should be able to retain the feature. However, for the recommended and supported experience, we encourage you to keep the normal density setting. If you are an advanced user, it's still possible to activate it in the Configuration Editor (about:config page).
  1. Type about:config in the address bar and press Return. A warning page may appear. Click Accept the Risk and Continue to go to the about:config page.
  2. Find the browser.compactmode.show preference.
  3. Switch the toggle to true and then close the tab.
  4. Click on the menu button fx89menu to open the menu panel.
  5. Click More Tools menu.
  6. Choose Customize Toolbar.
  7. At the bottom of the panel, click the Density button.
  8. Choose Compact (not supported) from the menu options.
  9. Click Done.
More about that: Compact mode workaround in Firefox

That's just a bot-answer. I KNOW HOW to use it. And I KNOW that it isn't supported all of a sudden. I don't need someone to explain that to me, I already stated that in my initial post. I am complaining that it isn't supported anymore AND that it is now even more necessary than before AND that it is bigger than before. This is just further proof that you do not care. At all.

You know what would've been helpful? NOT implementing proton at all. At least I can revert back to the previous design by going to about:config "browser.proton.enabled" and setting that to false. But that's just a bandaid workaround. Mozilla needs to fully support compact mode and make it way more compact!

Athraithe ag geraldvm ar

more options

Thanks for info about how to disable proton (browser.proton.enabled).

Compact mode was not visible for me and enabling it via hidden setting does not help because my bookmarks and menus are still too big. It only affects address bar. So I simply disabled proton and will wait for future updates with more customisation options.

Mozilla has lately been pushing multiple UI changes which are hated by community (for example removal of "close tabs to the right") and something with bookmarks too. They are becoming more and more separated from community and people needs - in my opinion. Only good thing is improving security, separating cookies between tabs etc. but UI changes in last year or two were pointless.

I am really sad that I cannot even send my opinion properly because it redirects to some weird webpage/forum where your voice disappears in crowd.

Athraithe ag Piterk ar

more options

@Piterk No problem, buddy. It's sad though, that we as a community have to reach for such "hacks" in order to make the browser usable. Mozilla needs to fix this ASAP! Otherwise people will just go to other browsers, where they don't have to put up with such sort of nuisance. Not everybody is willing to go through all this, some don't even look at the forums / help sites and just say "whatever" and move to another browser.

more options

I have hyperopia in both of my eyes and I cannot see clearly large text and logos.

I am using my Mac in the highest resolution and with the most compact mode. Current design is too big to see for me, a temporary solution is provided but we'd love to see true support for compact mode again. What Firefox is doing is nonsense. I don't care how many billions of clicks did you analyze, I just cannot see the browser.

I am long time user and supporter of Firefox and Mozilla. I was promoting Firefox to colleagues, sharing Internet Health Reports on social media, and donating to Mozilla. However, without real support for compact mode, I will be left with no choice but to switch to a privacy-monster browser. As I said, I CANNOT SEE.

more options

Do not give up to ch***e, try brave instead.

more options

Cero said

I have hyperopia in both of my eyes and I cannot see clearly large text and logos. I am using my Mac in the highest resolution and with the most compact mode. Current design is too big to see for me, a temporary solution is provided but we'd love to see true support for compact mode again.

I'm trying to understand what is too big for your needs: the text, or the space around the text, or both?

The other users in this thread are trying to reduce the extra spacing added in Firefox 89. If you need to make the text smaller, I can give you suggestions specifically for that.

more options

Now with Firef... 91 the "about:config browser.proton.enabled false" doesn't work anymore.

In case you intentionally wanted to give chromium a monopoly, you are on your best way to achieve this goal. I don't know how much Alphabet / Google paid you but please reconsider your decision.

more options

If you want to address the developers, you will have to file a bug report (which, from memory, can include an enhancement request). I suspect your comments would fall on deaf ears but the link, if you want to try, is https://bugzilla.mozilla.org/

You can address the issues with a file userChrome.css. I'll post links separately because they will have to be moderated.

more options
more options

geraldvm powiedział

Now with Firef... 91 the "about:config browser.proton.enabled false" doesn't work anymore. In case you intentionally wanted to give chromium a monopoly, you are on your best way to achieve this goal. I don't know how much Alphabet / Google paid you but please reconsider your decision.

Unfortunately you are right. I was hoping that leaving this setting in about:config means planning to add normal switch with buttons in settings menu but they simply removed every possibility to change option. They still did not restore compacted mode in view settings too. I disabled updates for now and will stay on FF90. I am wondering if there is any way to disable update pop-up with every ff launch...

more options

Piterk said

They still did not restore compacted mode in view settings too.

I think this is still applicable: Compact mode workaround in Firefox.

That does not change the appearance of the toolbars very much, just makes them a bit shorter.