Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Youtube Restricted Mode keeps becoming reenabled after becoming disabled

more options

Asking a question before this, I've seen Restricted Mode become removed on Firefox for a few days, then be turned back on for whatever reason. Help, please?

All Replies (4)

more options

Hi Lance, does it make any difference whether you are logged in to your Google/YouTube account when using YouTube? Or can the problem occur either way, logged in, logged out, private window, etc.?

Do you browse on a home network or mobile hotspot, or does your connection run through a business network of some kind?

more options

It doesn't seem to make any difference. Safe Mode, Private Mode, being logged out or deleting my account entirely, nothing seems to change.

I have a personal laptop with no connections to my school/organization. This problem seems to only come up when I browse Youtube using my home network.

more options

There is a way that "parental control" software may modify requests to signal YouTube that you should get a restricted experience. One involves your DNS service -- this may be configured in your router -- and another involves modifying requests, which usually requires a proxy server or allowing a filter to operate as a "man in the middle."

Here's a Google page with more info on those two ways your requests can be modified: https://support.google.com/a/answer/6214622

With that in mind, here are two things you might try:

(1) Set Firefox to use DNS over HTTPS

The idea here is that instead of asking Windows to figure out the IP address for YouTube, Firefox will ask Cloudflare. More info in this article: Firefox DNS-over-HTTPS

You may also need to clear Firefox's DNS cache -- the results of previous address lookups. There is a button for that on an internal page. Type or paste the following into the address bar and press Enter to load it:

about:networking#dns

There you should find a Clear DNS Cache button

(2) Set Firefox to No proxy

You can do that here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. Try "No proxy".

Any difference?

more options

Hello I have this same problem with YouTube. Forgive me but those above instructions are just way too complex for me. Is it possible to break this down further or arrange to talk me through this on the phone please? I prefer contact that way. It is how my brain works best with all things IT. Please advise as this has been an ongoing problem and is a continual pain. I can only watch certain vids on my phone and even completely innocuous ones are restricted. Thank you.