Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox auto update to version 88 under windows 7!

  • 2 fhreagra
  • 1 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó jscher2000

more options

OS: Windows 7 on notebook

Firefox automatically updated to version 88 After restarting the computer it says that FF88 is not compatible with the current version of OS. = Why did the update start under Win7 if it is not compatible with Win7? = How can I downgrade to a Win7 compatible version without losing any logins?

with unhappy regards

Chris Hostettler [email]

Athraithe ag Andrew ar

Réiteach roghnaithe

Hi Chris, have you tried doing another system restart in case there is some odd transient glitch?

Although I don't know why it would suddenly turn on, could you check to make sure Firefox is not executing in backwards compatibility mode? Right-click your Firefox desktop icon, or right-click your pinned Firefox Taskbar icon and then click Mozilla Firefox. Switch to the Compatibility tab and make sure Firefox can run in Windows 7 mode, and isn't forced to run in Vista or XP mode (which definitely do not work). Basically, make sure nothing is selected on the Compatibility tab.

Read this answer in context 👍 0

All Replies (2)

more options

Firefox 88 is compatible with Windows 7.

What makes you think it is not compatible ?


It is possible that your firewall or other security software blocks or restricts Firefox without informing you, possibly after detecting changes (update) to the Firefox application. Remove all rules for Firefox from the permissions list in the firewall and let your firewall ask again for permission to get full, unrestricted, access for Firefox and the plugin-container process and the updater process.

See:

Helpful?

more options

Réiteach Roghnaithe

Hi Chris, have you tried doing another system restart in case there is some odd transient glitch?

Although I don't know why it would suddenly turn on, could you check to make sure Firefox is not executing in backwards compatibility mode? Right-click your Firefox desktop icon, or right-click your pinned Firefox Taskbar icon and then click Mozilla Firefox. Switch to the Compatibility tab and make sure Firefox can run in Windows 7 mode, and isn't forced to run in Vista or XP mode (which definitely do not work). Basically, make sure nothing is selected on the Compatibility tab.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.