Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Screenshot isn't work properly since updateing to Firefox 88

more options

When I try to screenshot and download an image it screenshots multiple images instead. My OS is Windows 10 and I'm having this problem when trying to screenshot and download an image from Instagram. I right click on the image as I always have and it screenshots and saves multiple images instead. I never had this problem before updating to Firefox 88 and I've been using the screenshot feature for well over two years. I tried uninstalling and reinstalling Firefox and I'm still having the same problem. The image I'm trying to save is the one on the upper right.

Attached screenshots

Réiteach roghnaithe

I've been using the Screenshot feature for a long time and never had a problem. I went back to Firefox 86 and that solved my problem. There's a problem with the Screenshot feature in Firefox 88.

Read this answer in context 👍 1

All Replies (13)

more options

You right-click and choose "Take Screenshot" -- correct so far? And then Firefox shows the dark overlay and you either grab the whole screen or make a selection?

Helpful?

more options

Réiteach Roghnaithe

I've been using the Screenshot feature for a long time and never had a problem. I went back to Firefox 86 and that solved my problem. There's a problem with the Screenshot feature in Firefox 88.

Athraithe ag brianheckert ar

Helpful?

more options

Yes

Ever since I "updated" my Firefox to Version 88.0.1 - from the previous version - with the three dots' - it has been really problematic.

With Version 88.0.1 i have tried the "scissors"icon, but that always only gives me PART of the screenshot.

It is driving me mad!

Taking a screenshot on the web is really important.

(I have tried to follow the "Apple" method, but it is really complicated and unworkable.)

'BRING BACK the THREE "DOTS" PLEASE!

Why "fix" something that is not broken?

Helpful?

more options

Brian looks as if he does not use a MAC, whereas I do.

I do not have to "right click" to get a screenshot, for example.

I am considering "going back" to Firefox version 86, as recommended by one of the replies, but do not want to make a mess of things because I am using a different Operating System!

Helpful?

more options

zoro.axa said

With Version 88.0.1 i have tried the "scissors"icon, but that always only gives me PART of the screenshot.

Hi zoro.axa, are you using the "Save full page" button? Which parts are cut off?

zoro.axa said

I do not have to "right click" to get a screenshot, for example.

You should have that option if you want to use it.

I am considering "going back" to Firefox version 86, as recommended by one of the replies, but do not want to make a mess of things because I am using a different Operating System!

Firefox won't use your Firefox 88 profile (settings folder) with an older version due to downward incompatibility concerns. So there may be quite a bit of re-setting-up to do if you install an older version.

Helpful?

more options

Thanks "jscher200-". This proramme we are on is difficult to use - another nasty "little box!".

I am Australian, and we date by Day/Month/Year, so even THAT throws me off - a North American thing that is confusing! . (Even "9/11" is actually in Oz-speak, "11/9" "Down Under")

Anyway, i am NOT attempting to use he "Full Screen" thingy.

I have been using the "Three dot" screenshot for YEARS and it was GREAT - never had a problem!

Then SUDDENLY the "Three Dot" system changed RADICALLY.

Changing to the "scissors" icon has resulted in very bad part-pictures - these are now regularly hacked to pieces - which has NEVER happened before!. This is using the "point and drag" method with the cross inside a circle, which was always reliable on the "Three Dot"system.

It is driving me crazy!

Helpful?

more options

zoro.axa said

Changing to the "scissors" icon has resulted in very bad part-pictures - these are now regularly hacked to pieces - which has NEVER happened before!. This is using the "point and drag" method with the cross inside a circle, which was always reliable on the "Three Dot"system.

I haven't noticed that problem. Are you having the problem on Instagram as well, or on multiple sites?

I know there are issues at certain scaling levels not capturing the whole area selected. That should be fixed in Firefox 90.

Helpful?

more options

Maybe consider to switch to the en-GB Firefox version if you currently use en-US to see whether that fixes the date issue in some cases.


Are you selecting the area with the mouse or does this also happen when Firefox auto selects an element (image) if you hover this element ?

Helpful?

more options

Hi... I´m having the same trouble. Also I prefer the old version, not the actual right click (wich doesn't work in some situations). When I choose to capture a sector, and paste in an editor, copied image wasn't the selection, capture some other thing. At least this is happening in Twitter when you open a tweet and site display in background. The capture is from the background, not the foreground tweet :-S. Selection doesn't change anything, captures the size of the selection but the background! (FF. v89.0.1)

Helpful?

more options

Hi chicopomelo, the original example is a problem on Instagram, but it's possible that there is a similar issue on Twitter. I'm not sure what you mean by this part:

At least this is happening in Twitter when you open a tweet and site display in background. The capture is from the background, not the foreground tweet :-S. Selection doesn't change anything, captures the size of the selection but the background! (FF. v89.0.1)

When I'm looking at Twitter and I click a tweet, the page changes to show the tweet instead of overlaying on the same page. Not sure why. I'm not logged in?

Helpful?

more options

I have this similar issue. Before updating to 89.0.1 (which I just updated to 89.0.2), screenshot captured the "overlay" and it's not. It's capturing what's UNDER the overlay. The same with websites that have sticky navs. I'm a web developer. When doing the screenshots when the sticky name is in place when you scroll, it doesn't capture the sticky nav at all anymore. It only captures what's under it. It worked fine before the updates. So now I am at a point of downgrading to the version that works properly. You can even see it in my image. It didn't capture the Mozilla navigation and search bar across the top.

Helpful?

more options

thecre8tivediva said

I have this similar issue. Before updating to 89.0.1 (which I just updated to 89.0.2), screenshot captured the "overlay" and it's not. It's capturing what's UNDER the overlay.

Hmm, I think this is related to a change that rolled out in Firefox 88 judging by Brian's reports (this thread and https://support.mozilla.org/questions/1333782 )

The same with websites that have sticky navs. I'm a web developer. When doing the screenshots when the sticky name is in place when you scroll, it doesn't capture the sticky nav at all anymore. It only captures what's under it.

I see what you mean. If I draw a selection or click "Save visible" instead of "Save full page" then Firefox Screenshot captures that position of the page, but somehow it captures it without the fixed position navigation bar.

I think this is related to a change a few versions ago when Firefox Screenshot switched from using the old school method of an in-page script to capture an image of the screen to using a global method. I have not studied exactly what the global method does, but it seems not to account for changes you see on screen when you scroll the page and for certain interactions.

There is a bug on file related to this and I'll add a link to this thread so they are aware it is coming up here.

Meanwhile, to capture these partial page screenshots, you could use features of your system -- such as:

-- or consider using an add-on.

Helpful?

more options

Thank you @jscher2000. I've been using Snipping or Snagit. But my issue started on the last version prior to this one - 89.0.1. Once I updated to 89.0.1, it stopped working. I hope it they resolve this soon because I really like that better and it's much easier to execute, i.e., I don't need to have another program opened on my computer.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.