Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

widevinecdm error on mozilla firefox

  • 12 freagra
  • 3 leis an bhfadhb seo
  • 194 views
  • Freagra is déanaí ó cor-el

more options

Hi Everyone,

I keep getting a widevinecdm error when trying to play hulu, netflix or amazon videos on my mac. This just started yesterday and I'm not sure why.

I'm running mozilla firefox version 78.10.0esr (64-bit) on a macbook pro running OS X version 10.9.5

Anyone have any fixes?

All Replies (12)

more options

Hi, upgrade your firefox to the latest version (is 88).

Helpful?

more options

For netflix, i think you need a VPN for acces to him.

Helpful?

more options

Btw for your mac, you really need the latest version, at least 70, but can find bugs !

Helpful?

more options

I'm having the same issue even though Firefox says they support 10.9.5

Helpful?

more options

We have recently seen quite a few reports about Widevine issues on Mac OS X 10.9.5 . It looks that users get updated to Widevine 4.10.2209.1 and this version isn't compatible with Mac OS X 10.9 and causes crashes. You can try to reinstall the 4.10.1582.2 version


  • 1706507 - widevine on every stream website who need DRM
  • 1706393 - widevine HBO MAX
  • 1706393#c9 - widevine on every stream website who need DRM
I've confirmed that Widevine are no longer supporting older MacOS versions (10.11 is the oldest they currently support). Sadly, this means we can't do anything on the Mozilla side as the issue is in software we don't control.

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Athraithe ag cor-el ar

Helpful?

more options

hello thanks for the info cor-el but the link from redirector.........x64.zip only allows download of the dmg. for me and others, where do we install what we downloaded and unzipped?

Helpful?

more options

why does my reply and additional question not show up

Helpful?

more options

to help clarify i am running OS 10.9.5 and Firefox 78.10.0esr 64-bit much obliged Cor-el for the help but if i download the earlier version using: https://redirector.gvt1.… the link from redirector.........x64.zip only allows download of the dmg. for me and others, where do we install what we downloaded? i tried putting it into the folder where the updated file is, closed Firefox and then relaunched, but same issue it either does not load or it crashes

Helpful?

more options

why does my actual post have to be approved by a moderator and how long should that take makes firefox totally unusable for my purposes

Helpful?

more options

You can find the instruction in this subreddit thread.

You can edit this pref on the about:config page and set its value to the Widevine version.

  • media.gmp-widevinecdm.version = 4.10.1582.2

You can open the about:config page via the location/address bar. You can click the button to "Accept the Risk and Continue".

Copy the Widevine plugin file to the gmp-widevinecdm folder in the Firefox profile folder and in this folder create a folder with the name of the Widevine version (4.10.1582.2).

  • gmp-widevinecdm/4.10.1582.2

You can remove folders with other Widevine versions (or copy them to a safe place).

You may have to disable GMP update to prevent re-installing Widevine CDM 4.10.2209.1 by setting the update pref to an empty string.

  • about:config => media.gmp-manager.url (leave empty)

Athraithe ag cor-el ar

Helpful?

more options

Today at 1:05 PM

SUMOsJR said

   Hi there. Just an update here on the above conversation. 
   It looks like a fix for this is going into a dot release 88.0.1 which is set to release on the 5th. Give that a try once it is live and see if it resolves the issue for you.

Thank you sir. We will pass the word!

Helpful?

more options

The fix that 88.0.1 and 78.10.1 will get is about playing DRM protected content in HD when HDCPv1 is enforced. There is no fix possible for Mac OS X 10.9.5 users because Widevine no longer supports this OS.

See comment 14:

I've seen some folks discussing this bug in the context of Widevine no longer working on MacOS 10.9 due to the CDM not supporting that OS version. To avoid ambiguity, I want to highlight that the MacOS compat issue is a separate issue from this and is tracked in bug 1706393.

The DRM knowledge base article has been updated.

Note: The current version of Google Widevine is no longer compatible with older macOS versions such as OS X 10.9 and 10.10. Only macOS versions 10.11 and above are supported.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.