On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox Downloads menu "Open Containing Folder" opens the file instead :(

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 653 views
  • Freagra is déanaí ó Adam H.

more options

When I download a file and click on the downloads button to bring up the Downloads menu, I often just want to open the Linux Mint file manager in the right folder so I can move the file to a more appropriate place.

In the menu, there's the little button to the right of the listed downloaded file with "Open containing folder", but if I click on that, FF opens the downloaded file, not the file manager.

Obviously this wasn't always like this, but I don't recall doing anything that might have caused the issue. How can I set FF back to the default action of opening the Linux Mint file manager?

Thanks!

When I download a file and click on the downloads button to bring up the Downloads menu, I often just want to open the Linux Mint file manager in the right folder so I can move the file to a more appropriate place. In the menu, there's the little button to the right of the listed downloaded file with "Open containing folder", but if I click on that, FF opens the downloaded file, not the file manager. Obviously this wasn't always like this, but I don't recall doing anything that might have caused the issue. How can I set FF back to the default action of opening the Linux Mint file manager? Thanks!

Réiteach roghnaithe

I changed the file manager in Linux Mint from PCmanFM to Nemo and it now works, so, problem is something to do with Linux Mint and the file manager.

Read this answer in context 👍 0

All Replies (6)

more options

That could be a Mint thing; I still open the "containing folder". I have to right-click the file to get a menu containing that option. EDIT: i.e. right-click the file name in the downloads list.

Athraithe ag Terry ar

more options

Thanks! Didn't occur to me to try a right-click.

more options

I must be hallucinating - sorry but this doesn't solve the problem.

Right-clicking on the FF download dropdown right-hand column with the folder icons does produce a pop-up menu with one option "Open Containing Folder" however selecting this doesn't cause the folder to open, it just opens the image in the image viewer.

Is that still Firefox defining what to do with opening folders or applications or whatever?

more options

An Arch user had the same issue almost a year ago: https://support.mozilla.org/el/questions/1298089

It's still working on my system.

more options

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
more options

Réiteach Roghnaithe

I changed the file manager in Linux Mint from PCmanFM to Nemo and it now works, so, problem is something to do with Linux Mint and the file manager.