Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to get rid of extension text in toolbar.

  • 16 freagra
  • 1 leis an bhfadhb seo
  • 38 views
  • Freagra is déanaí ó jscher2000

more options

To explain visually, this is what I want removed:

[img]https://i.vgy.me/mG32hM.png/img

I found another thread on that with a solution:

https://support.mozilla.org/en-US/questions/1280633

However that solution doesn't work for me. Did something change?

I would ask in that thread but it's closed (pretty ridiculous) so here's a new thread to add to the clutter.

I have a portable installation of Firefox. Might that be the problem?

All Replies (16)

more options

So apparently images can't be posted here either. That's pretty medieval. You should still be able to click that link to see the image though. I can't seem to edit the post anymore.

Helpful?

more options

Hi, you can use the Browse button below a reply to attach them to a post.

So... it's a little complicated because there's no built-in way to do it, and add-ons aren't allowed to alter that area.

You can suppress the extension name in the Site Identity area using custom style rules in a userChrome.css file. I'll give a link to a similar request from the past that has the steps:

https://support.mozilla.org/questions/1280633

If you try it, let us know how it goes.

Helpful?

more options

Obviously I have reading comprehension challenges this afternoon. Let me look at those rules again.

Helpful?

more options

Yeah, that userChrome.css file does nothing for me.

I also tried that to get a multirow tab going in Firefox using this same feature but no dice.

I have the setting in config set to true and the .css file is under Firefox/Data/Profile/chrome but it simply does nothing at all.

Helpful?

more options

The id="identity-icon-labels" is singular now -- id="identity-icon-label" -- so:

/* Hide Extension Name Unless Site Identity Area is Hovered */
#identity-box.extensionPage:not(:hover) #identity-icon-label {
  display: none !important;
}
#identity-box.extensionPage:hover #identity-icon-label {
  max-width: 300px !important;
}

Helpful?

more options

That actually worked. Thank you!

So, is there something similar going on with the code for getting multi-rows?

I have this code for that:


/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/multi-row_bookmarks.css made available under Mozilla Public License v. 2.0 See the above repository for updates as well as full license text. */

/* Makes bookmarks toolbar span multiple rows */

  1. PersonalToolbar{
 --multirow-bmb-n-rows: 3; /* Control how many rows are shown before scrolling */
 --multirow-bmb-row-margin: 2px; /* Control how much spacing is between rows */
 max-height: none !important;

}

  1. PlacesToolbar > hbox{
 display: block;
 width: 100vw;

}

  1. PlacesToolbarItems{
 display: flex;
 flex-wrap: wrap;
 /* --uc-bm-padding is defined in autohide_bookmarks_toolbar.css */
 max-height: calc(var(--multirow-bmb-n-rows) * (5px + 1em + (2 * (var(--multirow-bmb-row-margin) + var(--uc-bm-padding,2px))))) !important;
 overflow-y:auto;
 scrollbar-color: var(--lwt-accent-color) var(--toolbar-bgcolor) ;
 scrollbar-width: thin;

}

/* Hide the all-bookmarks button */

  1. PlacesChevron{ display: none }

/* Add some spacing between rows */

  1. PlacesToolbarItems > .bookmark-item{ margin: var(--multirow-bmb-row-margin) 3px !important; }

I got this from here: https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css

Helpful?

more options

Oh, there's a filter for non-Mozilla URLs that sends replies to a spam link moderation queue. Your post should appear eventually.

Helpful?

more options

I am trying to reply to you but it doesn't show up.

Helpful?

more options

Okay, so that showed up but I wrote a longer post that didn't. This forum seems really buggy. :(

Helpful?

more options

Okay small parts work, so I'm doing this in parts.

You solution worked. Thnx.

Helpful?

more options

Do you know if there is also something similar wrong with the code for multirow tabs?

Helpful?

more options

I have this code:

/* Source file https://github.com/MrOtherGuy/firefox-csshacks/tree/master/chrome/multi-row_bookmarks.css made available under Mozilla Public License v. 2.0 See the above repository for updates as well as full license text. */

/* Makes bookmarks toolbar span multiple rows */

  1. PersonalToolbar{
 --multirow-bmb-n-rows: 3; /* Control how many rows are shown before scrolling */
 --multirow-bmb-row-margin: 2px; /* Control how much spacing is between rows */
 max-height: none !important;

}

  1. PlacesToolbar > hbox{
 display: block;
 width: 100vw;

}

  1. PlacesToolbarItems{
 display: flex;
 flex-wrap: wrap;
 /* --uc-bm-padding is defined in autohide_bookmarks_toolbar.css */
 max-height: calc(var(--multirow-bmb-n-rows) * (5px + 1em + (2 * (var(--multirow-bmb-row-margin) + var(--uc-bm-padding,2px))))) !important;
 overflow-y:auto;
 scrollbar-color: var(--lwt-accent-color) var(--toolbar-bgcolor) ;
 scrollbar-width: thin;

}

/* Hide the all-bookmarks button */

  1. PlacesChevron{ display: none }

/* Add some spacing between rows */

  1. PlacesToolbarItems > .bookmark-item{ margin: var(--multirow-bmb-row-margin) 3px !important; }

Helpful?

more options

Okay so it's the code that doesn't post then, I just found out.

To circumvent that here's the link to the code I use:

https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css

Helpful?

more options

Okay can't post code or links

Helpful?

more options

Please wait for a moderator to approve your earlier replies.

Helpful?

more options

iluvatar1979 said

...here's the link to the code I use: https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css

Hmm, second and third rows blank (except for Other Bookmarks)? You can force the hidden bookmarks to display, but Firefox doesn't generate the site icons with this override, so it's not pretty:

/* Force visibility for overflowing bookmarks */
#PlacesToolbarItems .bookmark-item {
  visibility: visible !important;
}

The author hangs out on https://www.reddit.com/r/FirefoxCSS so you could check for discussion about this problem over there.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.