On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Hide tab bar when only one tab open.

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 6529 views
  • Freagra is déanaí ó Gregory-F

more options

Hello,

I am looking for a way to hide my tab bar when there is only one tab open. I almost found the solution there: https://support.mozilla.org/en-US/questions/1297983 But it is not exactly what i am looking for. This solution hides the tab but not the tab bar it self. I mean it leaves some black empty space because i use dark theme.

I kept looking for a solution to hide the container. I found this one: https://support.mozilla.org/en-US/questions/1271391 The problem is: this solution hides all the time the tab bar. No maters how many tabs opened.

I experimented mixing these two solution. I have try:

  1. tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + #mainwindow:not([tabsintitlebar="true"]) #TabsToolbar {
 visibility: collapse;

}

I tried the other way around, with "#mainwindow" first. I tried without the "+" sign. But none worked out.

Hello, I am looking for a way to hide my tab bar when there is only one tab open. I almost found the solution there: https://support.mozilla.org/en-US/questions/1297983 But it is not exactly what i am looking for. This solution hides the tab but not the tab bar it self. I mean it leaves some black empty space because i use dark theme. I kept looking for a solution to hide the container. I found this one: https://support.mozilla.org/en-US/questions/1271391 The problem is: this solution hides all the time the tab bar. No maters how many tabs opened. I experimented mixing these two solution. I have try: #tabbrowser-tabs tab[first-visible-tab="true"][last-visible-tab="true"] + #mainwindow:not([tabsintitlebar="true"]) #TabsToolbar { visibility: collapse; } I tried the other way around, with "#mainwindow" first. I tried without the "+" sign. But none worked out.

Réiteach roghnaithe

I run Windows. I mention that just in case I say things that are nonsensical when applied to Linux.

Do you normally show the title bar (i.e., the full width page title), or do you let your tabs slide up into the title bar space? At least for me, the following works pretty well with the Title bar displayed, but isn't as nice without it:

https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/hide_tabs_with_one_tab.css

Screenshots:

Read this answer in context 👍 1

All Replies (3)

more options

Réiteach Roghnaithe

I run Windows. I mention that just in case I say things that are nonsensical when applied to Linux.

Do you normally show the title bar (i.e., the full width page title), or do you let your tabs slide up into the title bar space? At least for me, the following works pretty well with the Title bar displayed, but isn't as nice without it:

https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/hide_tabs_with_one_tab.css

Screenshots:

more options
more options

It Worked like a charm. Thank you.