Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cursor blink problem in Firefox 84

  • 7 bhfreagra
  • 1 leis an bhfadhb seo
  • 61 views
  • Freagra is déanaí ó Vultan

more options

I'm having a new problem with Firefox, which I think appeared with Firefox 84 (but I'm not 100% sure). When I type in some text boxes, the cursor gets very slow and unresponsive to move around by the keyboard _if_ the text in the box is long enough so that a scrollbar appears on the right hand side. Sometimes. It doesn't happen at all sites -- it's not duplicating in this textbox that I'm typing in right now -- but it happens all of the time in the message boxes at playdiplomacy.com, and sometimes on GitHub.com when posting issues. Sporadically and unreliably.

As far as I can tell, the cursor is still moving quickly and responsively, but the blink itself isn't happening so I can't see it. If I hold down the left cursor key, it looks like the cursor isn't going anywhere, but if I hit a letter key that letter appears instantly at the location where the cursor has apparently moved to, with no delay.

The problem does not occur when I hold down shift (to highlight) while moving the cursor via the arrow keys, which further suggests that it is somehow related to the cursor blinking.

Restarting in safe mode makes the problem go away instantly. Disabling all add-ons myself does not. Starting with a brand new profile does _not_ make the problem go away either. So there's something safe mode is doing that a new profile doesn't.

Any idea what might be causing this?

(Ubuntu 20.04, Firefox 84.0).

Thanks!

Réiteach roghnaithe

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Read this answer in context 👍 1

All Replies (7)

more options

KDE or Gnome?

Operating System: openSUSE Tumbleweed 20201231 KDE Plasma Version: 5.20.4 KDE Frameworks Version: 5.77.0 Qt Version: 5.15.2 Kernel Version: 5.10.3-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Helpful?

more options

Gnome.

Helpful?

more options

Réiteach Roghnaithe

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

Helpful?

more options

Disabling hardware acceleration solved it. Thank you.

Helpful?

more options

Ok, followup question: I can also solve the problem by leaving hardware acceleration on, but by disabling webrender via setting gfx.webrender.force-disabled to false. This explains why the problem appeared in Firefox 84; webrender was recently changed to enabled by default.

So, my question: am I better off leaving webrender on and disabling hardware acceleration, or the opposite?

Helpful?

more options

If it works with only WebRender disabled then you can use that and leave hardware acceleration enabled to benefit from this feature.

You can check the "Help -> Troubleshooting Information" (about:support) page to see if there are (WebRender) issues reported under the graphics section.

Helpful?

more options

Ok, thanks. Much appreciated.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.