Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I remove the new "search engine suggestion" from the adress bar?

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 20 views
  • Freagra is déanaí ó frafrifru

more options

I just updated and this showed up (see image). I couldnt find an option to remove it in about:preferences#search.

Attached screenshots

Réiteach roghnaithe

Found a solution: https://support.mozilla.org/en-US/questions/1311003

You need to set browser.urlbar.update2 to false in about:config.

According to this reddit thread the option will at some point be removed, but the linked CSS didn't work for me. Anyway, I've got a solution for now.

Read this answer in context 👍 0

All Replies (6)

more options

If disabling search suggestions in the location bar in "Options/Preferences -> Search" doesn't work then disable or remove all the search engines in "Options/Preferences -> Search -> Search Shortcuts".

Helpful?

more options

Thank you for your suggestions! Search suggestions were already disabled, and while disabling or removing search engines might fix the problem, this is not something I want to do. I use search shortcuts quite extensively - that's why the new feature is of no use to me and only takes up valuable space.

I restarted the browser and now it's gotten even bigger and more obnoxious (see image)

Athraithe ag frafrifru ar

Helpful?

more options

Looks like someone found a solution using CSS, but it's not working for me. It just hides the first line, but not the search suggestion :(

Source: https://www.reddit.com/r/FirefoxCSS/comments/jwfmvd/remove_ff83s_extremely_annoying_search_suggestions/

Helpful?

more options

Réiteach Roghnaithe

Found a solution: https://support.mozilla.org/en-US/questions/1311003

You need to set browser.urlbar.update2 to false in about:config.

According to this reddit thread the option will at some point be removed, but the linked CSS didn't work for me. Anyway, I've got a solution for now.

Helpful?

more options

The update2 pref is gone in Firefox 86 (bug 1665049).

Helpful?

more options

Good to know! I guess I will look for a new solution when it becomes relevant again

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.