Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot Turn off bookmark alphasort

  • 14 freagra
  • 1 leis an bhfadhb seo
  • 65 views
  • Freagra is déanaí ó bloodline1

more options

Since a recent Firefox update, Firefox has alpha-sorted my bookmarks automatically and I cannot turn this new feature off - this is annoying!

I want to custom organise the order of my bookmarks - NOT by alpha-sorting.

The 'sort by name' menu option does not have a counter option - ie 'DO NOT sort bookmarks'

So how do I turn off book mark sorting ???

Réiteach roghnaithe

Note that the Views menu in the Library merely shows a sorted view, but doesn't make changes to the order (i.e. it is only for viewing purposes similar to clicking the column header).

I'm not aware of an auto-sort feature in Beta/DE, so if this happens then you may have an extension that causes this.

Read this answer in context 👍 1

All Replies (14)

more options

If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


[v57+] Places Maintenance is built into Firefox.

Type about:support<enter> in the address bar.

You will find Places Database near the bottom. Press the Verify Integrity button.

When done, copy and post the results here.

https://support.mozilla.org/en-US/kb/fix-bookmarks-and-history-will-not-be-functional

Helpful?

more options

> Task: checkIntegrity + The places.sqlite database is sane + The favicons.sqlite database is sane > Task: invalidateCaches + The caches have been invalidated > Task: checkCoherence + The database is coherent > Task: expire + Database cleaned up > Task: originFrecencyStats + Recalculated origin frecency stats > Task: vacuum + Initial database size is 5120KiB + The database has been vacuumed + Final database size is 5120KiB > Task: stats + Places.sqlite size is 5120KiB + Favicons.sqlite size is 2688KiB + pragma_user_version is 54 + pragma_page_size is 32768 + pragma_cache_size is -2048 + pragma_journal_mode is wal + pragma_synchronous is 1 + History can store a maximum of 112348 unique pages + Table moz_places has 1102 records + Table moz_historyvisits has 862 records + Table moz_inputhistory has 0 records + Table moz_hosts has 0 records + Table moz_bookmarks has 741 records + Table moz_bookmarks_deleted has 8 records + Table moz_keywords has 0 records + Table sqlite_sequence has 0 records + Table moz_anno_attributes has 3 records + Table moz_annos has 234 records + Table moz_items_annos has 0 records + Table sqlite_stat1 has 15 records + Table moz_meta has 4 records + Table moz_origins has 508 records + Index sqlite_autoindex_moz_inputhistory_1 + Index sqlite_autoindex_moz_hosts_1 + Index sqlite_autoindex_moz_bookmarks_deleted_1 + Index sqlite_autoindex_moz_keywords_1 + Index sqlite_autoindex_moz_anno_attributes_1 + Index sqlite_autoindex_moz_origins_1 + Index moz_places_url_hashindex + Index moz_places_hostindex + Index moz_places_visitcount + Index moz_places_frecencyindex + Index moz_places_lastvisitdateindex + Index moz_places_guid_uniqueindex + Index moz_historyvisits_placedateindex + Index moz_historyvisits_fromindex + Index moz_historyvisits_dateindex + Index moz_bookmarks_itemindex + Index moz_bookmarks_parentindex + Index moz_bookmarks_itemlastmodifiedindex + Index moz_bookmarks_dateaddedindex + Index moz_bookmarks_guid_uniqueindex + Index moz_keywords_placepostdata_uniqueindex + Index moz_annos_placeattributeindex + Index moz_items_annos_itemattributeindex + Index moz_places_originidindex > Task: _refreshUI

Helpful?

more options

Is the problem still there?

Helpful?

more options

No. Amazing!

I don't know how you did it but now manual arrangement of bookmarks seems to stay how I want them - no annoying autosort!

Many thanks!

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

more options

I spoke too soon!

Just woke the Thinkpad from a sleep and the bookmarks have auto-alphasorted again!

What to try next?

Helpful?

more options

I called for more help.

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

Helpful?

more options

OK, I've now undone the solved flag.

The manual sorting remained for one session (which it hadn't done before). But when I woke the ThinkPad from a sleep the problem returned....and the browser auto-alpha-sorted my bookmarks again.

I've tried organising bookmarks from the bookmark menu direct by drag and drop, and also by opening 'Show all Bookmarks" window and making sure the 'Unsorted' option is flagged in the Views /Sort submenu, then dragged and dropped the order I want. ... the order remains for a period and then suddenly it auto-sorts for no apparent reason!

Thanks for your patience with this issue.

Helpful?

more options

Open the Bookmarks Manager. At the upper-right, select View > Sort.

Helpful?

more options

Already done this.

ie I found that the View>Sort >UnSorted option does not STICK! It will hold for a session but then something overrides these settings (without changing the Unsorted option visually. Ie the unsorted option remains selected BUT the actual behavior changes to alphasort!

It seems there is a bug in this latest update where DESPITE the selection of the Unsorted option (in View>sort) the browser decides to re-sort the bookmarks into alphabetical order (evn though the unsorted option remains flagged/selected).

BTW I'm subscribed to Firefox beta updates ... could there be a bug in the last update?

Helpful?

more options

Réiteach Roghnaithe

Note that the Views menu in the Library merely shows a sorted view, but doesn't make changes to the order (i.e. it is only for viewing purposes similar to clicking the column header).

I'm not aware of an auto-sort feature in Beta/DE, so if this happens then you may have an extension that causes this.

Helpful?

more options

Aha! I've just looked at my extensions and unbeknown to me an iCloud bookmark extension has found its way into my browser (I did not put it there ..honest!).

I will remove the icloud bookmark extension and see if that solves the issue (not until tomorrow mind you...time for bed on this side of the pond).

Helpful?

more options

It’s very sad, but many software downloaders/ installers will trick you into installing not only their program, but other programs as well.

You have heard of the fine print in shady contracts, right? Well, some installers you need to look at the itsy bitsy teeny weeny fine print.

You are thinking you are giving the installer permission to install the program you want by using the recommended option. But if you use the Manual Option Instead, you discover all kinds of stuff that you do not even know what it is or what it does.

From now on, everyone needs to Use The Manual Option to put a stop to this.

Note that these programs can also change browser/computer settings.

Helpful?

more options

Definitely have now solved the random bookmark autosort problem by removing the iCloud Bookmark extension!

Thanks everyone for your help!

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.