Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox takes 10+ times longer to load websites than Edge or Chrome

  • 17 freagra
  • 1 leis an bhfadhb seo
  • 77 views
  • Freagra is déanaí ó Olliesshop

more options

I'm at my wits end. I've tried every fix I could find and Firefox is dramatically slower then Edge or Chrome. This happens with loading sites, like Amazon. Also, it often locks up/stops when typing (like right now) and it takes about 15 seconds for it to repond again.

First, I doubt it's a hardware or network issue, since it's happened on both my old archaic PC and now on my new PC (i9 CPU, Nvidia 2070 graphics card, 64gb RAM).

Here's some highlights of what I've tried so far: • Refreshing multiple times • Rebooting the PC • Doing all the Quick Tips on this website • Eliminating all extensions • Clearing all cookies and cash • ...

Also, I don't get any error codes. The tab icon just spins for a long time.

I'm hoping I'm missing something obvious, since I love Firefox.

Thanks and any help!

All Replies (17)

more options

Olliesshop Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

Thank you for the suggestions FredMcD.

Based on your input I; - Cleared all history (this was interesting, since I had cleared everything before, but it must have been re-synced, since all the history was there) - Deleted all cache and cookies and changed preferences to delete cache, cookies and history when it closes - Disabled performance setting

Then I restarted in Safe Mode, and now it's much slower than before and locks up frequently. It mostly locks up when I'm typing something, while I'm in Firefox, and doesn't allow me to start typing again for 10-60 seconds. In fact, I quit trying to type this reply in Firefox and am using Notepad and pasting it in, since I couldn't get more than 5 words in before it locked up.

So I'm wondering if the locking up while typing is related to the slowness.

Helpful?

more options

Olliesshop said

. . . . but it must have been re-synced, since all the history was there)

If you have sync, and there is a problem anywhere, Shut Down Sync Immediately On All Devices to prevent the problem from spreading. Once the problem is fixed, perform the same repair on all computers/profiles before using sync again.


Use these links to create a new profile. Use this new profile as is. Is the problem still there?

https://support.mozilla.org/en-US/kb/how-run-firefox-when-profile-missing-inaccessible

http://kb.mozillazine.org/Profile_folder_-_Firefox#Navigating_to_the_profile_folder

https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles

https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles


Type about:profiles<enter> in the address bar.

Helpful?

more options

Thanks again.

First, I Shut down sync with my Android phone.

Then I created a new profile and set it up. I did not import or sync anything to try to keep it pure. It helps a little, I think, but it's still slow compared to Chrome/Edge. For example, Chrome/Edge bring up my test sites in about a second or less. On Amazon.com, Firefox took about 85 seconds to stop "thinking" in the tab icon, whereas Chrome was under a second.

I did not delete my old profile, since I need to save my bookmarks. I hope that's OK.

Also, it still locked up multiple times while writing this reply.

Helpful?

more options

Good news ... I just ran another test with the graphics hardware acceleration disabled. Firefox now loads Amazon.com in 3-7 seconds.

I'll run this profile for a while and see how fast it is and whether it locks up.

Is there anything else I should change in the options before I get going?

Helpful?

more options

Helpful?

more options

FredMcD,

I've done an in-depth review of all the links you provided and have implemented all the relevant recommendations to the best of my ability. Although, it's still noticeably slower that Chrome/Edge and locks up typing frequently when I'm typing. My conclusion is I'm just have to live with it. :(

The only suggestion I wasn't able to figure out was if my Norton Security firewall was causing the issues. I tried to follow the steps suggested and the Enum process said the following. Is that OK? Windows Firewall is on 2 Service(s) from Norton/Symantec (Norton) detected antispy process from Microsoft Windows Defender detected

Hopefully there's something I'm still missing or it's bug that will be fixed. I'm going to leave the issue open for now, with the hope it might get resolved.

Thanks for all the help!

Helpful?

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

I've been running Firefox in Safe Mode most of the day yesterday and this morning. So far it's working the same as before. The time to load websites and pages is adequate to slow. Also, it still locks up when I'm typing. It locked up twice while writing this relatively short reply.

FYI, I haven't added any extensions or anything. So I'm still puzzeled on what I can do to make it better.

Thanks

Helpful?

more options

BTW, I tried sites like my email and credit card. Are those what you mean by Secure?

Also I haven't tried running the PC in Safe Mode yet. Would that be appropriate next step?

Helpful?

more options

That would be the next step.

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

I just finished testing with my PC in Safe Mode. Wow is it ever fast!

Based on this test, is there a procedure or process that might help identify the problem?

Would Norton Security and/or Windows Security cause issues? Right now, I have both of them running internet security. Maybe I should turn one of them off somehow.

I'm hoping the problem is relatively easy to find and fix now, but don't have any high hopes.

Helpful?

more options

Good work. You have narrowed the problem to something outside Firefox.

As a test, disable your protection programs.

Helpful?

more options

Thank you! I'll give that a try.

Helpful?

more options

I thought I should give an update on my experience with Firefox and Chrome.

As background, I've been using Firefox for years and loved it and have a been a ardent supporter. Although, I've finally decided it's time to cut bait on Firefox. I just can't afford to waste so much time waiting for sites and pages to load and having it lock up frequently.

Every day I start off using Firefox, hoping it will work today, but then it becomes torturously slow. So I switch over to chrome, accessing the same websites as Firefox and it just screams. I've been doing this for months.

I've spent countless hours lately trying to get Firefox to work. I just don't understand wy on the same PC, at the same time, with the same websites, that Chrome is orders of magnitude faster than Firefox.

I'm going to move to Chrome or Edge, but haven't decided yet.

I wish Firefox all the best and I hope I can come back someday.

Thank you all for the help you've provided.

Helpful?

more options

A post was flagged as Solved Problem. If the problem is not solved, please remove that flag. If you don’t, others that can help may not read this post.

Go to that message, and use the Undo link to its right.

Helpful?

more options

Thanks!

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.