Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Pictures showing in MS Edge but won't show in Firefox

  • 6 fhreagra
  • 2 leis an bhfadhb seo
  • 17 views
  • Freagra is déanaí ó Gliss

more options

While viewing news stories on MSN.com and clicking a link to a story with several pictures attached, the pictures will not display using Firefox but does display when using MS Edge browser. This started happening just recently. This happens with Win10 and Win7. Firefox is updated to 82.0.3 64 bit. . FYI Chase bank will not allow you to log in anymore using Firefox. Possibly related to the above problem ?

All Replies (6)

more options

Can you provide a screenshot showing the images missing? Did you try viewing the site with Firefox in Safe Mode?

Helpful?

more options

Hi, on the Chase bank issue, in case you use Kaspersky security software, there is a known issue with Kaspersky blocking certain Chase servers.

Helpful?

more options

I did not try this in safe mode. I have been using the same browser (Firefox 64bit) and homepage (MSN.com) for years without any problems. This started 2 to 3 weeks ago. Firefox is on auto update as is Win10. I have noticed a new banner along the top of the web page (see attached screenshot). This may have something to do with the images not showing.

I do not use Kaspersky security software. I have always been able to log into Chase using Firefox for years. The Chase homepage shows a message that I need to update my browser. Among others, there is a link to update Firefox. Firefox was already updated, but I tried to update anyway. Still could not log into Chase.

Helpful?

more options

Looks that you aren't loading icon fonts that are used to display small images.

If you use uBlock Origin make sure not to "block remote fonts".

You can check the Web Console for messages about fonts.

Helpful?

more options

I use uBlock Origin. Turned it off and the pictures appeared. I went to the Web_Console and found this..

downloadable font: download failed (font-family: "Segoe UI" style:normal weight:400 stretch:100 src index:1): bad URI or cross-site access not allowed source: https://static-entertainment-wus-s-msn-com.akamaized.net/sc/57/566d09.woff2

This was the only mention about fonts that I found. Never saw anything about "remote fonts". I am guessing that one of the recent Firefox updates changed something in the browser. I have used the same browser (Firefox), the same homepage (msn.com) for a few years with no problems. Of course it could also be msn.com that changed.

Helpful?

more options

I had the same problem loading Chase Bank in Firefox desktop. It worked fine on phone app and in Firefox on phone also. I use Kaspersky Anti-Virus also on Desktop, Windows 10.I started Firefox in safe mode, in Bookmarks chose Chase.com, it loaded, I signed in and Chase Homepage loaded. I closed Firefox, reopened in Regular Firefox went to bookmarks chose Chase.com and now it opens and I can log in. Why have no idea ? Its worth a shot. I disabled Kaspersky, disabled enhanced tracking in Firefox, disabled No Script, all with no results.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.