Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

YouTube Not Working Correctly

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 76 views
  • Freagra is déanaí ó Hawkeye

more options

I started having problems with YouTube recently and I think it is a Firefox issue.

I am running version 82.0.3 (64-bit) and when I log into YouTube, the Home page is not displaying all the content.

I have attached severl screenshots and you can see the problem as follows:

Image Sign In 1 shows the YouTube home page before signing in. Image Sign In 2 shows the YouTube home page after I have signed in using my Google account and you can see at the top right of the screen that my Google Account avatar (Darth) is showing. However, a lot of the content, e.g. Watch Later, Classics and My Subscriptions which are user related are all missing and if you compare this image to Image Sign In Chrome you can see that Chrome is showing everything and works correctly.

I tried this on Edge as well and it works all okay, the same as Chrome, so that is why I think there is an issue with Firefox.

Also, on the left side in the middle in Image Sign In 1 and Image Sign In 2 you can see a blue Sign In box with the words "Sign in to like videos, comment and subscribe." If you select this option you get an error which is in Image YouTube Sign In Error so I don't know if this is related to my problem but I thought it may help highlight what the problem is.

Any confirmation that it's a Firefox issue or any solutions to what is causing it would be appreciated.

Thanks.

Attached screenshots

Réiteach roghnaithe

Updated KIS 2021 to version 21.2.16.590 and my YouTube sign in is all working correctly again.

Problem solved!

Read this answer in context 👍 1

All Replies (4)

more options

Due to this problem and a couple of others that prevent me using Firefox, I have started using Edge and Chrome!

Sad days as I have been using Firefox for so long but find there are more and more bugs appearing everytime there is an update!

Helpful?

more options

Having looked into this I found a post on the Kaspersky community forum which suggests that this is a Kaspersky bug which affects Firefox, not Edge or Chrome, and will be fixed in their next big update.

So I will mark this as solved and if the Kaspersky update doesn't fix it, I will check with them before coming back here.

Helpful?

more options

That was very good work. Well Done.

Helpful?

more options

Réiteach Roghnaithe

Updated KIS 2021 to version 21.2.16.590 and my YouTube sign in is all working correctly again.

Problem solved!

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.