Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Fire Fox Add-On Shortcuts

  • 13 freagra
  • 1 leis an bhfadhb seo
  • 73 views
  • Freagra is déanaí ó steve285

more options

I'd like to start by saying that this has happened after several previous updates and i have now turned off automatic updates to help thwart this issue. Firefox updated yesterday and my add-ons that previously appeared in the menu bar on the top right were gone, as were the add-ons themselves as far as i can tell. I installed the add-ons along with a few new ones, but they don't appear in the menu bar. I went to manage add-ons, all but one are showing that they do not have short cuts, and the one that does, i don't seem to have an option to add the short cut to the menu bar.

If they have to be hidden, that will be very inconvenient, but more importantly, i'm not sure how to even use them as i essentially have no interface with the short cuts at this point. Does anyone know how i can fix this?

Do i need to revert back to an older version of Firefox? I'm on a mac using 10.14.6 Mojave.

Thanks,

Steve

All Replies (13)

more options

Hi Steve, during your update, did Firefox mention performing a Refresh, a "Tune-up", or creating a new profile? These are indications that could lead to losing your add-ons.

So the first thing, which I think you already checked, is to check the Extensions section of the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

Your installed extensions should appear next, and then the heading "Recommended Extensions". So this is where you can review and manage extension.

Assuming that your extensions are listed here -- either because they continued through an update or you reinstalled them -- the next issue many users encounter is that they are using private windows, but their extensions are not enabled to run in private windows. Check for the purple shield icon next to each extension title. If it's missing, you can click the title to view the Details panel and scroll down to the section where you can allow the extension to run in private windows.

Was that an issue?

Next, the toolbar layout sometimes becomes corrupted. You can try using the "Restore Defaults" button at the bottom of the Customize panel to reset the toolbar layout. See: Customize Firefox controls, buttons and toolbars.

That should return the extension buttons to the box for dragging/dropping.

Any progress so far?

more options

Yesterday i had problems even starting Firefox. I would click on the icon and it would act like it was starting and immediately shutdown. It's not my main browser, so i was able to deal without it, but then i clicked on it today and it fired up. I'm not sure if it performed a tuneup or created a new file. I didn't see anything alluding to either of those, but i don't usually look at those pages that pop up after updates.

I read somewhere about the extensions not working on private windows, but i couldn't figure out how to turn the private window option off and on.

I've included a couple of screen shots of the add-ons manager. I don't see any purple shields anywhere, but perhaps i'm not looking in the correct location.

I'll try the tool bar reset after posting.

more options

Hi Steve, "Extension Shortcuts" refers to keyboard shortcuts, not buttons, so let's set that aside for the time being.

Is your Firefox set up to use private windows? This would usually be indicated on the Preferences page, Privacy & Security panel, History section, by either:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history +
    [x] Always use private browsing mode

If you have either of those, you definitely need to enable the extensions to run in private windows.

more options

So it looks like i have it set to never remember history. Do the extension need it to remember in order for them to work? I'm not sure i have a way of enabling them to do so otherwise.

more options

steve285 said

So it looks like i have it set to never remember history. Do the extension need it to remember in order for them to work? I'm not sure i have a way of enabling them to do so otherwise.

That is automatic private browsing. To allow an extension to run in private windows, go back to the Add-ons page, click the extension title to display the Details panel, scroll down and set the permission here:

more options

Note that there is an extensions.allowPrivateBrowsingByDefault pref on the about:config page that you can set to true to enable extensions by default in PB mode.

See also:

more options

Sorry for the break. Had to step out for my daughter's piano recital.

And, thank you for showing me where that setting is. I figured there had to be a place to do that, but couldn't find it and i wasn't sure if the update changed maybe eliminated the option.

Despite setting them all to enabled, I still seem to have the issue of not being able to use them.

more options

Extensions can also add items to a context menu, so there are more ways apart from a shortcut and a toolbar button.

Maybe you can list your extensions, then we might be able to tell how they work. You can also check the screenshot images on their Add-ons webpage.

more options

I do believe they are listed in the photos above.

more options

Is this what you were alluding to?

more options

Well, i just restarted Firefox and went into the customize menu page and there are the menu icons for the add-ons!

more options

Wow. Maybe a file was locked and Firefox couldn't function correctly in that situation? These intermittent things are so hard to troubleshoot. Hopefully it will stay fixed.

more options

Yes, i hope so. Thank you all for your help.