Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The top line of my browser used to have file edit view etc but although the Menu Bar is ticked it is not visible.

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 13 views
  • Freagra is déanaí ó Emmo

more options

I have trawled the net but all of the answers are out of date by ten years in some cases. I have viewed it in full screen and without but the Menu Bar is still not visible.

Réiteach roghnaithe

Thanks I did restore default and added both toolbars and that solved the problem. Thanks for your help.

Read this answer in context 👍 0

All Replies (6)

more options

Hi Emmo, any difference if you launch a new window (Ctrl+n)? Just trying to rule out the scenario of a popup window stripped of extra bars.

Can you see the menu bar in Customize mode, or is it invisible there, too, even after being turned on? See: Customize Firefox controls, buttons and toolbars.

You mentioned full screen, and that may have two interpretations:

(1) Browser full screen (F11) or website full screen (usually there's a button) will roll up the entire toolbar area. You usually need to exit these modes to see the menu bar.

(2) Maximized window (the middle of the three standard buttons toggles between maximized and resizable). The bar should appear, unless it's a limited-feature popup window.

Helpful?

more options

Ctrl+N does give me the Menu Toolbar and the minimise, maximise buttons. From log on I can't see the menu bar in Customize mode, even after being turned on? Nor the minimise, maximise buttons. F11 will lose all the top toolbars and momentarily the minimise, maximise buttons reappear.

Helpful?

more options

Do you think the issue might be that Firefox is positioned too high, so the title bar is off the screen to the top? To move a window down in that situation, you can use this old-fashioned method:

Press Alt+Spacebar to display the window control menu.

If Move is grayed, then this method isn't applicable because the window is maximized.

Click Move or press the M key

Then start pressing the down arrow key until the top of the window comes into view

To end the Move, press the Enter key

Hopefully Firefox will remember this new position.


If that doesn't work or isn't applicable, the settings file that stores window positions and dimensions might have become corrupted with nonsensical values. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows File Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > Exit
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then right-click > Rename on xulstore.json to something like xulstoreOLD.json.

Start Firefox back up again. Turn the Menu Bar (and if desired, the Bookmarks Toolbar) back on. For example, either:

  • right-click (on Mac Ctrl+click) a blank spot on the tab bar (or the "+" button)
  • (menu bar) View > Toolbars
    On Windows, tap the Alt key to activate the menu bar temporarily.
  • in Customize mode > Toolbars button (see: Customize Firefox controls, buttons and toolbars)

Does Firefox behave more normally?

Helpful?

more options

I'm not sure whether the Ctrl+N did the trick or the Windows update but the Menu Toolbar is back thanks. The only thing I see that is still missing is the + to the right of tabs to open a new tab. Ctrl+T sorts that.

Helpful?

more options

Sounds good.

If you open the Customize screen, you may find the + New Tab button among the available buttons in the box of unused icons. Or you might spot it on a different bar where it doesn't belong. Either way, you could drag it back to its proper spot. If all else fails, the "Restore Defaults" button at the bottom of the Customize screen should revert to the "factory layout" for the toolbars.

Helpful?

more options

Réiteach Roghnaithe

Thanks I did restore default and added both toolbars and that solved the problem. Thanks for your help.

Helpful?

Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.