Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox tab icon no longer spinning :(

more options

Hi, I am using FF v80.0.1 on ubuntu 18.04.

I noticed that whenever a tab is loading there is now a static (non-spinning) icon. Previously it was spinning. I want it to spin.

In changelog for 80.0 it says:

> For users with reduced motion settings, we’ve reduced a number of animations such as tab loading to reduce motion for users with migraines and epilepsy.

Is there a way to disable this feature?

Hi, I am using FF v80.0.1 on ubuntu 18.04. I noticed that whenever a tab is loading there is now a static (non-spinning) icon. Previously it was spinning. I want it to spin. In changelog for 80.0 it says: > For users with reduced motion settings, we’ve reduced a number of animations such as tab loading to reduce motion for users with migraines and epilepsy. Is there a way to disable this feature?

Réiteach roghnaithe

visgean said

Hi, I dont have the ui.prefersReducedMotion in key in about:config :(

No one has it by default. Step 3 is where you add that preference.

Read this answer in context 👍 1

All Replies (7)

more options
more options

I think we need this https://www.userchrome.org

https://support.mozilla.org/en-US/questions/1176586

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Athraithe ag Chris Ilias ar

more options

https://support.mozilla.org/en-US/questions/1176586

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Athraithe ag Chris Ilias ar

more options

Hi visgean, if you do not want reduced animations in Firefox, it is possible to override your system-level animation preference with a manually created Firefox preference. You can try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste the new preference name

ui.prefersReducedMotion

If this preference was already created and shows a value of 1, skip to step (4).

(3) On the bar with the preference name, click the radio button next to Number and click the + button to add the preference. Then Firefox should display the new value.

(4) Set the value to 0 (double-click to edit if necessary) and click the blue checkmark button or press Enter to save the change.

That should bring back the ping-ponging dots. Does it work on yours?


If by spinning you meant the old circling-arrow icon, and you are comfortable with userChrome.css hacks, see:

https://www.reddit.com/r/FirefoxCSS/comments/igxwgn/replace_hourglass_icon_with_circle/g35339i/

more options

Hi, I dont have the ui.prefersReducedMotion in key in about:config :(

more options

If ui.prefersReducedMotion doesn't exist on the about:config page then you can try to create a new Number pref and set its value to '0' (zero) although I assume that if the pref is missing Firefox would assume that animations aren't blocked unless your OS has this feature enabled.

It is possible that Firefox from the repositories behaves differently than Firefox from the Mozilla server. You can try Firefox from the Mozilla server to see if that makes a difference.

more options

Réiteach Roghnaithe

visgean said

Hi, I dont have the ui.prefersReducedMotion in key in about:config :(

No one has it by default. Step 3 is where you add that preference.