Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

ICloud Login is not saved in Firefox

  • 3 fhreagra
  • 2 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó Dustin

more options

When I launch contacts in Windows 10 it takes me to my iCloud login screen in Firefox. When I sign in there is an option to Keep me Signed In and I select it. I can then log into my iCloud account after I enter a code supplied by apple. The only problem is I have to enter the code each and every time I log into iCloud even after I selected the option to keep me signed in. Firefox does not remember any passwords for any of my account logins. Is there a setting I need to change?

All Replies (3)

more options

Hey McRob, iCloud has a couple settings when you login and logout to be aware of.

1) Two-factor authentication. If this is enabled, as it sounds like it is based on your description of entering a code, that will likely remain unless you specifically select "Trust" on the "Trust this browser?" Pop-up after logging in.

2) Sign out When you sign out of iCloud you will get an option to Sign Out, Cancel, or Trust and Sign Out. Make sure you select "Trust and Sign Out". I believe this would help prevent that code during login also.

All that said, I seem to have the same problem you have when I tried to test this for you. Firefox does not prompt for a password save during the login process. Even if I go into Firefox settings and use Create New Login, and save the information into Firefox myself, it will not auto-fill. You can however do a copy/paste from the password manager as a workaround but I know that creates many more steps.

Can anyone else confirm this for us?

more options

Dustin

Thanks for your reply. I do have Two-factor authentication enabled in iCloud I guess. I did select "Trust this browser" and I still have the same issue with Firefox. It will not allow login without entering a code.

Just for a test I tried using my Microsoft Edge browser doing exactly the same process as Firefox. It worked correctly and now at least I have an option to check my contacts without having to enter my iCloud code every time.

I did get Firefox to prompt me for my new login accounts again. I found an option to save new logins in Firefox account settings. At least that works now.

The only thing that I can think of why iCloud will not work with Firefox is that I have a plugin called 1Password installed in Firefox. Maybe that is interfering with how iCloud Trust the browser.

I guess I will have to start using Microsoft Edge more.

more options

That's great you got prompts working! I have a similar situation with having LastPass as a plugin. But even disabling that did not help with the auto-fill. (Although LastPass did try to help me with an auto-fill).

It might be worth checking this setting when you get a moment: Options -> Privacy & Security -> Scroll down to Cookies and Site Data and make sure "Delete cookies and site data when Firefox is closed" is unchecked.

Another possibility for why iCloud thinks you need to re-authenticate could be if you are using some sort of network relocation such as a VPN. But that is a complete guess on my part.

I think having someone else more intimate with the way Firefox discovers text/password fields for auto-fill would be able to answer both our question at this point. I found this question and while it is different it does hint at some possibilities.

https://support.mozilla.org/questions/1292763