Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox is not opening correctly

  • 7 bhfreagra
  • 2 leis an bhfadhb seo
  • Freagra is déanaí ó Alex_Stoyanov

more options

Hi today I opened my linux installation and Firefox is only getting a window with the text:

             <toolbarbutton id="UITourTooltipClose" class="close-icon"

I tried to run from the console with the --MOZ_LOG_FILE flag and the generated file has absolutely no text in it.

Some information about my system: kernel: Linux localhost.localdomain 5.7.7-1-default #1 SMP Wed Jul 1 19:03:27 UTC 2020 (cba119b) x86_64 x86_64 x86_64 GNU/Linux

OS: openSUSE 20200715

DE: KDE 5.72.0 / Plasma 5.19.3

Version: 78.0.2-1.1 (according to zypper info MozillaFirefox command)

Attached screenshots

Athraithe ag Gresthol ar

Réiteach roghnaithe

Are you currently using a version from the repositories of your Linux distribution?
Try the Firefox version from the official Mozilla server:

Read this answer in context 👍 1

All Replies (7)

more options

Réiteach Roghnaithe

Are you currently using a version from the repositories of your Linux distribution?
Try the Firefox version from the official Mozilla server:

more options

We had another user with this issue that is using OpenSUSE, so maybe there is a problem with this update. In that case clearing the profile in the ~/.cache location worked.

  • /questions/1295425 Thank you for breaking Firefox? - No more browser window, just a weird error (openSUSE Tumbleweed)
more options

I have exactly the same problem. Clearing ~/.cache did not help.

more options

Same Problem here:

Operating System: openSUSE Tumbleweed 20200721 KDE Plasma Version: 5.19.3 KDE Frameworks Version: 5.72.0 Qt Version: 5.15.0 Kernel Version: 5.7.9-1-default OS Type: 64-bit Processors: 4 × Intel® Core™2 Quad CPU Q9400 @ 2.66GHz Memory: 7.6 GiB of RAM Graphics Processor: GeForce GT 610/PCIe/SSE2

Firefox installed from tumbleweed-repo: Mozilla Firefox Web Browser, Version 78.0.2-2.2 (195,7 MiB)

Edit: Firefox binary (78.0.2, 64-Bit) downloaded from mozilla-webpage runs fine, maybe a Tumbleweed-Problem?

Athraithe ag peter.huyoff ar

more options

Exactly the same problem for me: OS: openSUSE Tumbleweed 20200726 64-bit KDE-Plasma-Version: 5.19.3 KDE-Frameworks-Version: 5.72.0 Qt-Version: 5.15.0 Kernel-Version: 5.7.9-1-default

Firefox version 78.0.2-2.3 from tumbleweed-repo

Weird thing is: If I create a new profile everything works. If I use safe-mode with old profile, everything works. In safe-mode I also disabled every extension, theme and plugin, but this did not work. Clearing ~/.cache didnt work either.

The official download is already version 79, repo doesnt seem to have switched yet to v79.

more options

openSUSE and Mozilla bug references:

It seems addonStartup.json.lz4 in the Firefox profile is not updated as required automatically. Deleting this file is reported to fix the issue. (Please keep a backup.) also explains how to modify the file w/o removing it to fix it.

more options


I was having the same or a similar problem before on plasma, and I was confused as to what was causing it. I never really found out, but the problem was as follows:

When I start a new window of Firefox while another one is running, the window would flash as if it would open, and then immediately close every time. If I closed all windows or killed all Firefox processes, I could open Firefox normally and restore all of my sessions. Additionally, I couldn't open the "customize" page from the drop-down menu, as the tab would open and then immediately close and be replaced by 2 new-tab tabs.

I thought this was caused by the same problem, but I noticed one thing which made even less sense. If I set my theme to light (I was using the official dark theme) the customize page would work. After a lot of guessing and checking, I found that both issues were being caused by an add-on. Basically, step one should be going through your add-ons and finding if the problem is caused by one of them. I am not sure if the original post had this issue, but I decided to add the solution that worked for me in case anyone else had this problem.

Athraithe ag Alex_Stoyanov ar