Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

cannot open FireFox

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • Freagra is déanaí ó YoadS

more options

Good day to you all, I just opened up my computer, tried to load Mozilla, without any option to do so. I tried to go to the shortcut, only to let me know it the file firefox.exe cannot be found. I uninstalled and re-installed twice without any success. what to do?

All Replies (6)

more options

hello yoadS,

sorry to head your problem, follow the steps and instruction easily resolved your problem:

Visit this Firefox download page in any browser, such as Microsoft Internet Explorer. Click the Download Now button. The Firefox Installer that downloads will automatically offer you the best available version of Firefox for your computer.

  • If you use Microsoft Internet Explorer, a notification bar will appear at the bottom of the page with the options to run the installer or save the file to your computer. Click Run to start the process.
  • In other browsers, you may need to first save the Firefox installer to your computer, then open the file you downloaded.

3. The User Account Control dialog may open, to ask you to allow the Firefox Installer to make changes to your computer. If this dialog appears, click Yes to start the installation.

4. Wait for Firefox to finish installing:

Note: The Firefox Installer may contain an Update or Re-install button and an option to restore default settings and remove add-ons, if a very outdated Firefox version or very old profile data is detected. Clear the checkbox to keep the old data and click Update or Re-install to start the installation.

for more information visit given link :


I hope resolved your problem then reply back to me and mark solution.

Thank you asked Question in Mozilla support,

regards , Arman

more options

thank you, but sorry- this did not solved my problem. I still can't get access to Firefox

more options


Please try this one.

I have killed firefox using the processes tab in taskmanager, and have successfully uninstalled it. I am reinstalling it now, hopefully that works.

more options

there's no installed version. it did not worked.

more options

Réiteach Roghnaithe

more options

thank you! I moved installation to PFx86 and that worked great.