Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Remove "Search with google" and "Search with amazom.co.uk" from the address bar drop down list

  • 15 freagra
  • 3 leis an bhfadhb seo
  • 1049 views
  • Freagra is déanaí ó jscher2000

more options

In version 75 when I click in the address bar, a list of my most common sites appears, but at the TOP of this list are search with google and also amazon.co.uk. These are options I do not want to see, just "my" web sites. How can I remove these two items from the drop down list? Thanks.

Réiteach roghnaithe

Thanks, that worked.

Read this answer in context 👍 0

All Replies (15)

more options

hi, the entries in the address bar dropdown menu are drawn from the top sites on your new tab page since firefox 75. you can easily adjust those: https://support.mozilla.org/en-US/kb/customize-new-tab-page#w_customize-your-top-sites

more options

Réiteach Roghnaithe

Thanks, that worked.

more options

siroctopusuk said

Thanks, that worked.

Hello siroctopusuk,

Would you be so kind as to mark Philipp's post as Chosen Solution ?

It's the "Solved the problem" button to the right of his post.

Thank you inadvance !

more options

I have the same problem with the address bar dropdown menu. For some reason "Search with Google" has been pinned up there after my last update. No triple dots to select.

I do not use google usage at all, no youtube, no Gmail, no other Alphabet Inc crap.

________________ Found a solution. Go to settings -> Search -> And remove google from the search engine alternatives. Don't just uncheck; Purge it. PURGE! (Remove)

Athraithe ag adam.jonsson ar

more options

Hi adam.jonsson, that works, but I think it wastes a slot on your Top Sites list (only 8 sites are listed).

As I'm sure you recall, Firefox 75 introduced a new behavior to the address bar: when the focus (cursor) moves into the bar, a list of your first 8 Top Sites from the Firefox Home / new tab page would drop down automatically.

The preference to disable the automatic opening changed name and now there's a checkbox on the Options/Preferences page. If you want to keep an automatic opening list, you can clean it up on the Firefox Home / new tab page. Here are some tips on that.

Get Rid of the Automatic Opening List

There is a new checkbox for that on the Options page, under Privacy & Security, Address Bar:

Show the classic Frequently Visited URLs List

When you type a space into the bar, Firefox will show the frequently visited URLs list as a match for that. Anything else I suggest will give you a slightly different list.

You can clean up the Top Sites list Firefox uses automatically. Firefox should fill up the list with frequently visited URLs after you clear out unwanted items, although this might take a little time to accumulate. Here's how:

Manual Cleanup Method

(1) At least temporarily, you need to turn the Top Sites section of the Firefox Home / news tab page back on: Hide or display content in New Tab

(2) Open about:newtab or about:home to display the Top Sites list. You can remove unwanted "Top Sites" by hovering your mouse over them, clicking the menu button that appears, and using either unpin (to let the site float back into a frequency-based order) or dismiss if you never want to see it. More info: Customize the New Tab page.

Flush Pinned Tabs Method

If you have never customized the list and want to clear it, you can try this approach I saw suggested on Reddit:

(A) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(B) In the search box in the page, type or paste newt and pause while the list is filtered

(C) On the row for the browser.newtabpage.pinned preference, click the trash can icon at the right end to empty it. (Or you can double-click the value to display an editing field, delete the contents, then press Enter or click the blue check mark button to save the change.)

More info on about:config: Configuration Editor for Firefox.

more options

I recently updated to FF 79.0 and it messed up one of my profiles.

Previously, on all my profiles, I “Restored Classic Address Bar” as mentioned in another thread.

But after updating to FF 79.0, profile #2 added a “Search Amazon” & a “Search Google” to the drop down list in the address bar. Problem is you click on the Google entry & the address bar displays “@Google“, and that does not work. And neither does “@Amazon“.

I went into the Top Sites & unpinned both of those which got rid of them. After doing that, the normal Google.com appeared at the top of the drop down list. All is good on profile #2.

On profile #1, after doing the “Restored Classic Address Bar” some time ago, Google.com never showed up on the drop down list. I had to tap the Space Bar in order for it to show up in the drop down list.

Why did Google now show up in profile #2 but not in profile #1?

In profile #1 I added Google to the Top Site list and it doesn’t show up, even when I display 4 rows of thumbnails. I use Google a lot & yet some of the thumbnails that are displayed are for sites I’ve only looked at a few times a long time ago.

How do I get Google to show up in Top Sites in profile #1?

Thanks

more options

Mike109 said

In profile #1 I added Google to the Top Site list and it doesn’t show up, even when I display 4 rows of thumbnails. I use Google a lot & yet some of the thumbnails that are displayed are for sites I’ve only looked at a few times a long time ago.

Hi Mike109, if you drag that Google tile into your first 8 top sites -- you might need to pin it -- it definitely should appear in the drop-down. Does the list just skip over it?

more options

jscher2000 said

Mike109 said

In profile #1 I added Google to the Top Site list and it doesn’t show up, even when I display 4 rows of thumbnails. I use Google a lot & yet some of the thumbnails that are displayed are for sites I’ve only looked at a few times a long time ago.
Hi Mike109, if you drag that Google tile into your first 8 top sites -- you might need to pin it -- it definitely should appear in the drop-down. Does the list just skip over it?

Now that I read your post again, if you can't see Google on the new tab page, there might be a different problem.

If the identical Google URL was ever dismissed from the Top Sites section of the new tab page it might be on the block list. The block list is difficult to edit because the URLs are encoded, but one option is to clear the entire block list and see whether that works. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste blocked and pause while the list is filtered

Near the top of the list should be the browser.newtabpage.blocked preference.

If you want to back up the current list:

Double-click the browser.newtabpage.blocked preference to display an editing field and select the current value. Copy/paste the value to some other place like a new document in a text editor. You can press the Esc key when you're done.

To clear the list:

You can click the trash can icon at the right end of the bar.

More info on about:config: Configuration Editor for Firefox.

more options

I don't recall ever blocking anything.

I proceeded to save a copy & then delete that blocked string as you suggested. That made no difference.

Of the 4 profiles on the PC only #1 had the " browser.newtabpage.blocked" listed. It appears I don't need the blocked information that it contained so I'll just keep it deleted for now.

I took one of the Top Site thumbnails & changed it's URL to https://google.com. This gave me a new thumbnail with the big "G" logo, but it kept the old title which I expected. However the old thumbnail image & old title were also displayed. IOW 2 different images with the same title. Then I changed the title on the Google thumbnail to "Google". Now one of the first 8 Top Sites and the dropdown menu both contain Google. Problem solved, just don't know what was causing it.

When I click on the FF address bar & then tap the space key to bring up the alternate dropdown menu, where does it get it's information from? The list is similar to the Top Sites list but not identical.

Thanks again

more options

The space bar displays the frequently visited URLs list that used to be displayed by the little icon in the address bar.

more options

Most of my Top Sites are also frequently visited. In fact 9 out of the first 10 Top Sites are also on the list that the space bar displays.

On another profile that my wife uses the two listings look very different.

What puts a site on the Top Site list if it's not frequently visited? Could it be that it's been recently visited?

more options

Hi Mike109, Firefox uses an algorithm called "frecency" which balances frequency and recency. The "spacebar" list has some additional secret sauce; typing a ^ in the address bar should show the pure frecency-based list.

more options

Thanks again for your helpful information.

more options

Can someone please just answer the initial question. It simply cannot be that hard.

How do I get rid of these two pinned websites from my address bar. I have looked all through options. Right-clicking on them does nothing. It's really winding me up.

more options

monkeymarquis said

How do I get rid of these two pinned websites from my address bar. I have looked all through options. Right-clicking on them does nothing. It's really winding me up.

It is not complicated, but you cannot do it directly on the drop-down. Those are pinned to the Top Sites section of the Firefox Home / new tab page. That is where you go to unpin them.

See: Customize the New Tab page and/or this earlier reply