Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

How to get FF developers to be able to make an extension the Home Page?

  • 14 freagra
  • 1 leis an bhfadhb seo
  • 9 views
  • Freagra is déanaí ó cor-el

more options

I use an extension "BookmarksHome" that I want to be the Homepage. Would like to see this feature in future update of FF. It is a matter of economy of keystrokes, Some programmers get it but some do not. For me, it's the less keyboarding the better. Especially when I don't use my glasses when typing. ;-)

All Replies (14)

more options

Hi clc1, please ignore the spam message with an unofficial third party support number.

Does the extension have an option to appear as the home page as well as the new tab page? I don't think so, but it mentioned new tabs on its config page:

If it doesn't have a home page option, you can do it yourself:

(1) Open the Options page, change to the Home panel, and switch to using Custom URLs. This should open a blank space for the URL.

This article might help with the details on getting there: How to set the home page.

Now... don't close this tab, we'll come back to it.

(2) In a new tab, load the BookmarksHome page using its toolbar button.

(3) Click in the address bar of the BookmarksHome page and copy (Ctrl+c or right-click > Copy) the URL

(4) Return to the tab with the Options page and paste in the URL. Press Tab to leave the URL field and signal Firefox that you are done with the edit.

(5) Test with a new window (Ctrl+n) -- did it work?

more options

nexojol124 said

[Spam link removed by moderator. Please do not quote spam posts, thanks.]

@ nexojol124  :

You have been reported. Your posts will be removed and your account closed.

Athraithe ag Chris Ilias ar

more options

Had tried that already. FF just isn't seeing that as a valid url for some reason. It just defers to a blank new page.

more options

Hmm, I wonder why? The author also provided a shortcut URL for the page. Does this work in the Custom URLs field:

ext+bkmh:home

more options

No. It doesn't hold. Going back into about:config and it defaults back to about:home and reverts to a new page, not to a private browsing page. Am I changing the wrong value?

more options

How does it look on the Options page? In the attached, I pasted the weird URL in as an example, but I can't test it because I don't have the extension.

more options

Tried that also but it still doesn't work.

more options

Does Firefox say it can't find the page, or what happens?

more options

"Going back into about:config and it defaults back to about:home and reverts to a new page, not to a private browsing page."

I notice in the config utility: startup.homepage_override_url It is editable. Maybe need to change this?

more options

Does the Options page Home panel indicate that an extension is managing the home page?

Is the problem specific to private windows?

(In regular windows, Firefox lets me set and use a moz-extension:// URL as the Custom URL for my home page through the Options page.)

The startup.homepage_override_url preference is usually used for temporary purposes. You can try using it, but it may be replaced after the next update.

more options

No. It keeps defaulting back to FF Home.

Doesn't seem to matter whether the tab is private or not. Let me check....

more options

OK. It doesn't work with private browsing tabs. Does with reg tabs.

So, FF developers need to make it work with private browsing tabs! Pass it on to whomever.

Thanx for your time & help.

more options

McCoy said

nexojol124 said
[Spam link removed by moderator. Please do not quote spam posts, thanks.]

@ nexojol124  :

You have been reported. Your posts will be removed and your account closed.

I assumed that my post, directed at the scammer, would have been removed as well. Should have been.

more options

You would normally drag the tab with the extension's page to the toolbar Home button to set this page as the homepage. I tested this with the better history extension and that worked for me.