X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Fóram Tacaíochta

FF 74 lost my bookmarks toolbar, they are vertical on the left, at the top if shiftkey and start FF

Postáilte

The update today to 74 lost all my customized, userchrome.css stuff and the row of bookmarks that used to be at the top now go down the left size, or right side if I want, but I want it at the top. Userchrome does not seem to recognized either as I put what I had kept, back in the a chrome folder in the profile folder.

The update today to 74 lost all my customized, userchrome.css stuff and the row of bookmarks that used to be at the top now go down the left size, or right side if I want, but I want it at the top. Userchrome does not seem to recognized either as I put what I had kept, back in the a chrome folder in the profile folder.
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

Tuilleadh Eolais

RobertJ
  • Top 10 Contributor
152 réiteach 1549 freagra

Hi carversmith, Firefox's Safe Mode (shiftkey and start FF) ignores userchrome.css files.

You can remove the userchrome.css file and launch Firefox. Your bookmarks toolbar will return to the normal top position.

Hi carversmith, Firefox's Safe Mode (shiftkey and start FF) ignores userchrome.css files. You can remove the userchrome.css file and launch Firefox. Your bookmarks toolbar will return to the normal top position.
An bhfuil an freagra seo cabhrach? 1
Luaigh

Úinéir na ceiste

But is this a permanent restriction? No userchrome.css anymore? Me personally, I like multiple icons only, no words saying CNN or such things, and grouped by function on my top tool bar. Thanks Carver

But is this a permanent restriction? No userchrome.css anymore? Me personally, I like multiple icons only, no words saying CNN or such things, and grouped by function on my top tool bar. Thanks Carver
An bhfuil an freagra seo cabhrach? 0
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17846 réiteach 161524 freagra

What code are you using in userChrome.css and for what features ?

What code are you using in userChrome.css and for what features ?
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

This code was running before 74. Thanks

*********************
/* Multi-Row Bookmarks Toolbar Firefox 66+ */

#PersonalToolbar {
  min-height: unset !important;
  max-height: unset !important;
/* text-align: center !important; */
}

#PersonalToolbar #PlacesToolbarItems {
  overflow-x: visible !important;
  overflow-y: visible !important;
  display: inline-block !important;
}

#PlacesToolbarItems > .bookmark-item > .toolbarbutton-icon[label]:not([label=""]) {
  /* Reduce padding on individual bookmarks to fit rows closer together */
  margin-inline-end: 0px !important;
}
***********************************
For Firefox 66PLUS is ABOVE
For Firefox 57 to 65:
/* Multi-Row Bookmarks Toolbar */
#PersonalToolbar {
/* Provide room for up to 4 rows at 26px */
max-height: 104px !important;
}
#PlacesToolbarItems > box {
display: inline-block !important;
}
#PersonalToolbar #PlacesToolbarItems {
/* Override hiding */
overflow-x: visible !important;
overflow-y: visible !important;
/* Add a little cushion */
padding-bottom: 1px;
}
#PersonalToolbar #PlacesToolbarItems .bookmark-item {
/* Reduce padding on individual bookmarks to fit rows closer together */
padding-top: 1px !important;
padding-bottom: 1px !important;
}

Step 3 (optional): If you prefer to autohide the bookmarks toolbar, additionally add this code in the file userChrome.css and save the file:
/* Auto-hide bookmarks toolbar */
PersonalToolbar {

visibility: collapse !important;
position: fixed;
width: 100%;
border-bottom: 1px solid #A8A8A8 !important;

}
navigator-toolbox:hover > #PersonalToolbar {

visibility: visible !important;

}
This code was running before 74. Thanks <pre><nowiki>********************* /* Multi-Row Bookmarks Toolbar Firefox 66+ */ #PersonalToolbar { min-height: unset !important; max-height: unset !important; /* text-align: center !important; */ } #PersonalToolbar #PlacesToolbarItems { overflow-x: visible !important; overflow-y: visible !important; display: inline-block !important; } #PlacesToolbarItems > .bookmark-item > .toolbarbutton-icon[label]:not([label=""]) { /* Reduce padding on individual bookmarks to fit rows closer together */ margin-inline-end: 0px !important; } *********************************** For Firefox 66PLUS is ABOVE For Firefox 57 to 65: /* Multi-Row Bookmarks Toolbar */ #PersonalToolbar { /* Provide room for up to 4 rows at 26px */ max-height: 104px !important; } #PlacesToolbarItems > box { display: inline-block !important; } #PersonalToolbar #PlacesToolbarItems { /* Override hiding */ overflow-x: visible !important; overflow-y: visible !important; /* Add a little cushion */ padding-bottom: 1px; } #PersonalToolbar #PlacesToolbarItems .bookmark-item { /* Reduce padding on individual bookmarks to fit rows closer together */ padding-top: 1px !important; padding-bottom: 1px !important; } Step 3 (optional): If you prefer to autohide the bookmarks toolbar, additionally add this code in the file userChrome.css and save the file: /* Auto-hide bookmarks toolbar */ PersonalToolbar { visibility: collapse !important; position: fixed; width: 100%; border-bottom: 1px solid #A8A8A8 !important; } navigator-toolbox:hover > #PersonalToolbar { visibility: visible !important; }</nowiki></pre>

Athraithe ag cor-el ar

An bhfuil an freagra seo cabhrach? 0
Luaigh
BobDRAD 0 réiteach 2 freagra

I also had a chrome/userChrome.css file which when removed solved my issue.

I also had a chrome/userChrome.css file which when removed solved my issue.

Athraithe ag BobDRAD ar

An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8950 réiteach 73359 freagra

If you want new rules for a multi-row bookmarks toolbar in Firefox 74, you could look at:

https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css

If you want new rules for a multi-row bookmarks toolbar in Firefox 74, you could look at: https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17846 réiteach 161524 freagra

You need new code for the multi-row Bookmarks Toolbar.

See:

New CSS code here:

You need new code for the multi-row Bookmarks Toolbar. See: *[[/questions/1281704]] How to get a multirow bookmarks toolbar in Firefox 74? *https://www.reddit.com/r/firefox/comments/fgozre/multiple_bookmark_toolbar_rows_in_ff_74/ New CSS code here: *https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css
An bhfuil an freagra seo cabhrach?
Luaigh
Horse.Sense 1 réiteach 6 freagra

Have now tried both codes recommended to recover multi-row bookmarks on the toolbar, with no change.

Steps: Type %appdata% to open Mozilla Profile folder. Double-click to open userChrome.CSS (which opens in Dreamweaver CS3). Delete existing code - then copy and paste one of the new recommended codes above into Dreamweaver. Save new code in Dreamweaver. Firefox Mulit-row Bookmarks Toolbar should be fixed.

To test the logic, I just took all code out of userChrome.CSS, saved it - and there's still no change to Firefox.

Do I understand the process correctly? If not, please show me the error of my ways...

Thank you.

Have now tried both codes recommended to recover multi-row bookmarks on the toolbar, with no change. Steps: Type %appdata% to open Mozilla Profile folder. Double-click to open userChrome.CSS (which opens in Dreamweaver CS3). Delete existing code - then copy and paste one of the new recommended codes above into Dreamweaver. Save new code in Dreamweaver. Firefox Mulit-row Bookmarks Toolbar should be fixed. To test the logic, I just took all code out of userChrome.CSS, saved it - and there's still no change to Firefox. Do I understand the process correctly? If not, please show me the error of my ways... Thank you.

Athraithe ag Horse.Sense ar

An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8950 réiteach 73359 freagra

Hi Horse.Sense, was your existing code breaking the bar or being ignored?

Let's assume it was breaking the bar.

Did you try this code: https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css

Hi Horse.Sense, was your existing code breaking the bar or being ignored? Let's assume it was breaking the bar. Did you try this code: https://github.com/MrOtherGuy/firefox-csshacks/blob/master/chrome/multi-row_bookmarks.css
An bhfuil an freagra seo cabhrach?
Luaigh
Horse.Sense 1 réiteach 6 freagra

Hello jscher2000.

If that's the code mentioned in other posts, I've already tried it. Have tried 3 so far, with no success. Also took all code out of the userChrome.CSS - and nothing changes.

Don't know the correct terminology, but what happens is all bookmarks that used to be horizontal in the toolbar, are now vertical along the left margin (all the way down to the bottom of the page and beyond) - and the rest of the screen is blank. Cannot click it, cannot see any open websites.

It seems the bookmarks menu somehow shifted from 'side to side', to 'up and down' - and are using the entire width of the screen as spacing for the bookmarks list.

At this point, unless it's an easy fix - I'm happy to go back to only one row of bookmarks in the toolbar, with the rest available via drop-down. I've wasted far too much time on this. Right now, I hate Mozilla!

Thanks for your help.

Hello jscher2000. If that's the code mentioned in other posts, I've already tried it. Have tried 3 so far, with no success. Also took all code out of the userChrome.CSS - and nothing changes. Don't know the correct terminology, but what happens is all bookmarks that used to be horizontal in the toolbar, are now vertical along the left margin (all the way down to the bottom of the page and beyond) - and the rest of the screen is blank. Cannot click it, cannot see any open websites. It seems the bookmarks menu somehow shifted from 'side to side', to 'up and down' - and are using the entire width of the screen as spacing for the bookmarks list. At this point, unless it's an easy fix - I'm happy to go back to only one row of bookmarks in the toolbar, with the rest available via drop-down. I've wasted far too much time on this. Right now, I hate Mozilla! Thanks for your help.

Athraithe ag Horse.Sense ar

An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8950 réiteach 73359 freagra

Freagra Cabhrach

Horse.Sense said

Also took all code out of the userChrome.CSS - and nothing changes.

I think you may be editing the wrong file. To find the file for your currently active Firefox profile, try using this method:

Open your current Firefox settings (AKA Firefox profile) folder from inside Firefox using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows/File Explorer.

Find and double-click into the chrome folder. What you find here would be the active userChrome.css file.

''Horse.Sense [[#answer-1300006|said]]'' <blockquote>Also took all code out of the userChrome.CSS - and nothing changes.</blockquote> I think you may be editing the wrong file. To find the file for your currently active Firefox profile, try using this method: Open your current Firefox settings (AKA Firefox profile) folder from inside Firefox using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Enter In the first table on the page, on the Profile Folder row, click the "Open Folder" button. This should launch a new window listing various files and folders in Windows/File Explorer. Find and double-click into the '''chrome''' folder. What you find here would be the active userChrome.css file.
An bhfuil an freagra seo cabhrach? 1
Luaigh
Horse.Sense 1 réiteach 6 freagra

Yup - Exact same place I was before, just a different way to get there. (Thanks for teaching me where to find the road less traveled...)

Opened it up anyway (hoping for a better result) and it's all the same story, different hour. Opened the chrome folder and it's empty - just as I left it earlier - but bookmarks problem still exists.

Any help to get the bookmarks back to the old way - one row with drop-down menu - would be fine. Not my favorite method, but I'm out of patience for this project and stupid freakin' Firefox. (Would rather not do any sort of full reset, as I've got a lot of other custom features and add-ons going.)

Thank you!

Yup - Exact same place I was before, just a different way to get there. (Thanks for teaching me where to find the road less traveled...) Opened it up anyway (hoping for a better result) and it's all the same story, different hour. Opened the chrome folder and it's empty - just as I left it earlier - but bookmarks problem still exists. Any help to get the bookmarks back to the old way - one row with drop-down menu - would be fine. Not my favorite method, but I'm out of patience for this project and stupid freakin' Firefox. (Would rather not do any sort of full reset, as I've got a lot of other custom features and add-ons going.) Thank you!
An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8950 réiteach 73359 freagra

Freagra Cabhrach

Horse.Sense said

Opened the chrome folder and it's empty - just as I left it earlier - but bookmarks problem still exists.

Firefox only reads the userChrome.css file at startup. Have you been restarting Firefox between changes to test?

''Horse.Sense [[#answer-1300016|said]]'' <blockquote>Opened the chrome folder and it's empty - just as I left it earlier - but bookmarks problem still exists. </blockquote> Firefox only reads the userChrome.css file at startup. Have you been restarting Firefox between changes to test?
An bhfuil an freagra seo cabhrach? 1
Luaigh
Horse.Sense 1 réiteach 6 freagra

No - I was opening a new Firefox, since there were so many tabs already opened while trying to research and solve the problem. Re-pasted the code, just totally closed FF and reopened - and voila - problem solved.

Thank you so much jscher2000 - You're a gentleman among e-contributors!

(But I'm still mad at Mozilla, for wasting our time...)

Have yourself a terrific rest of the week! :)

No - I was opening a new Firefox, since there were so many tabs already opened while trying to research and solve the problem. Re-pasted the code, just totally closed FF and reopened - and voila - problem solved. Thank you so much jscher2000 - You're a gentleman among e-contributors! (But I'm still mad at Mozilla, for wasting our time...) Have yourself a terrific rest of the week! :)
An bhfuil an freagra seo cabhrach?
Luaigh
BobDRAD 0 réiteach 2 freagra

I would try removing the file entirely, rather than just removing the content. That's what worked for me. Good luck!

I would try removing the file entirely, rather than just removing the content. That's what worked for me. Good luck!
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.