Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

How to stop getting Yahoo search results and Default Search engine in Firefox preferences

  • 34 freagra
  • 5 leis an bhfadhb seo
  • 330 views
  • Freagra is déanaí ó jscher2000

more options

I delete Default Browser and all other search engines except Google. I then get Google search results for a bit but then later on I start getting a Yahoo panel at top of browser page. Go into Preferences and it shows under Search Engines a Browser Default. Can't get Firefox to stop going back to Browser Default which seems to be Yahoo. Any help appreciated. Thank you

All Replies (20)

more options

I think "Browser Default" is injected by an add-on or by external security software.

First, change back to your preferred search engine and delete that unwanted one from the box of One-Click Search Engines on that same panel (Preferences > Search).

Next, take a close look at an extension as a possible culprit. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search or privacy, looks suspicious or you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Helpful?

more options

At this time, I'm at the same point I usually get to after removing the Default Browser under the One-Click Search Engines.

I did not find anything suspect in the 4 extensions.

So now I'll wait to see when the Yahoo search banner appears at the top of the page and hopefully return here with more info.

Thanks much.

Helpful?

more options

OP back.

Just now there was a banner at the top of the search results page with Yahoo on the right of it. That prompted me to look at my Firefox preferences.

The Browser Default search engine is back in my list of search engines in preferences.

I now assume that for Firefox, Browser Default means Yahoo.

Strange that I can't get Firefox to just stay with only Google all the time.

Any other tips appreciated.

Thanks much.

Helpful?

more options

normharris3 said

I now assume that for Firefox, Browser Default means Yahoo.

That name is just to deceive you. The default search engine of Firefox in most of the world is Google; it is not Yahoo anywhere.

Did this change after updating to Firefox 73, or restarting your system, or after any other event?

What are your extensions at this point?

Helpful?

more options

If it is not, then Yahoo is somehow sneaking in. Perhaps I click on a link that uses Yahoo but I don't remember this ever happening when I'm using Safari.

I haven't upgraded to 73.0. It hasn't reminded me to do so.

No special actions that I know of precedes the appearance of the Yahoo search bar.

Extensions:

1Password Adobe Acrobat Evernote Web Clipper NoScript

Thanks for your help, jscher2000. I appreciate but absolutely please no need to spend any more time on this. I'll just keep removing when Yahoo appears.

Helpful?

more options

Firefox 73 is just starting to trickle out today, so no rush.

I'm concerned that you have malware which really should be removed. Do you want to check with this well-regarded tool (free trial or lower functionality free version):

https://www.malwarebytes.com/mac/

Also, your search engine can be hijacked using a settings file in this folder:

/Applications/Firefox.app/Contents/Resources/defaults/pref

A file named channel-prefs.js is normal here. Any other file in this folder is suspicious if you do not remember creating it yourself. Remove any such files to a neutral location for further analysis at your leisure.

Helpful?

more options

How does that malware tool compare to ClamXAV which I've used off and on? Off right now.

I'm unable to follow that address path. Are you sure?

Thanks again.

Helpful?

more options

normharris3 said

How does that malware tool compare to ClamXAV which I've used off and on? Off right now.

I've never heard of using Clam on Mac, so I have no idea.

I'm unable to follow that address path. Are you sure?

Yes, or you can find it through a web search, for example:

https://duckduckgo.com/?q=inurl%3Amalwarebytes+%22mac%22&ia=web

Helpful?

more options

This is the path I couldn't follow. Sorry if not clear.

/Applications/Firefox.app/Contents/Resources/defaults/pref

I'll call it a day after these steps you've provided.

Thanks for your help. I appreciate your time on this.

Helpful?

more options

Sounds as though Applications might be listed in the Finder sidebar, or you can use Go to Folder as described in the following article:

https://support.apple.com/guide/mac-help/go-directly-to-a-specific-folder-on-mac-mchlp1236/10.14/mac/10.14

Helpful?

more options

/Applications/Firefox.app takes one to the app. The app does not have any folders

Helpful?

more options

Hmm, maybe there's a special way to view the contents. I have to defer to a Mac user.

Helpful?

more options

I have the most recent Firefox Updates, and have been having problems ever since. Load a page, try to click on anything, it says extension is slowing it down. Never did before, and I only have 4 extensions. Also, I keep getting the Yahoo Safe Search Browser link in my default browser. I have had to start keeping my Preferences open all the time, and to go back ever couple of hours to delete it.

iMac 21.5" 2011.. This is the first time I have ever had this much trouble getting rid of that browser. Last time I had to get rid of it was something like 3 years ago. I have AdBlocker so I am not getting it from unwanted ads.

Has anyone figured out how to get this to stop yet? Please!

Helpful?

more options

Hi Vyncent, web pages cannot change your search engine without action. The problem has to be coming from one of your 4 extensions or external malware on your computer.

Can you live without any of those extensions for the next 24 hours? You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then cast a critical eye over the list on the right side. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything you can live without for 24 hours? Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove).

Any improvement?

Helpful?

more options

15th April 2020 Hello, I am running Windows10 and since Firefox auto updated on 9th April 2020 I am obtaining 'Yahoo' search results from a 'Google' search? Google Maps is also inoperable, as "Server error. Please try again later" is displayed in the middle bottom of the screen. I have used both 'Malwarebytes' and 'CCleaner' and my installed 'Bullguard', all the latest versions to date, to no avail. My Firefox is set to use 'Google' as the default search engine and I have cleared all alternative search engines from my 'One click' search engine selection. The http addresses are as follows: 'Google' search:https://www.google.co.uk/ This is the resulting http: https://uk.search.yahoo.com/yhs/search?hspart=dcola&hsimp=yhs-017&type=gsp_lovelytabff_20_16_ssg68¶m1=1¶m2=cat%3Dweb%26sesid%3Ddbecd57a7b1ea3c387ee8926a929368d%26ip%3D109.180.102.135%26b%3DFirefox%26bv%3D75.0%26os%3DWindows-10%26os_ver%3D10.0%26pa%3Dgencoll22%26sid%3Dc6abd4a457090ad100b934416d26e713%26abid%3D%26abg%3D%26a%3Dgsp_lovelytabff_20_16_ssg68%26sdk_ver%3D%26cd%3D%26cr%3D%26f%3D%26uref%3D&p=%22William%20Henry%20Thirkell%22 If I use the "Go backwards" button (top left of screen), I then view this http in the address bar window: https://privor.best/s.php?q=%22William%20Henry%20Thirkell%22&f=https%3A%2F%2Fsearchingwalls.com%2F%3Fa%3Dgsp_lovelytabff_20_16_ssg68%26q%3D%2522William%2BHenry%2BThirkell%2522 A reply in simple 'step by step' instructions would be appreciated as differentiating between the Firefox menu, '3 bar' symbol in top right of the screen or the Windows10 'Settings' is fundamental and I am no 'expert'! ;¬) Thank you for your patience and time.

Helpful?

more options

Answer to my own question! :¬) Firefox 'Add-ons Manager'/'Extensions'/ Manage your extensions 'Privor' V2 updated 14th April 2020 is in the window and enabled. Slide the slider to disable the 'Privor' extension. I will be reporting this via the 'Report' feature associated with the extension and 'Removing' it from the installation. I hope this helps others. Good health, themoudie

Helpful?

more options

Hi katabiller, I wonder where that came from. Probably not something you installed intentionally; perhaps it was injected by some other free software you installed recently? The Windows "Add/Remove Programs" list should have an option somewhere to sort by date so you can review what's come on board in recent weeks that might have had unwanted bundled items.

Helpful?

more options

Aye jscher2000, thank you for your quick response. I am afraid that much of this sort of 'Auto' updating is a mystery to me. I try to minimise it unless I really need/understand it. "Bloatware!" I shall have a wee look in Windows "Add/Remove Programs" and see what I can see. However, knowing my capabilities, I could remove something 'vital'! Good health.

Helpful?

more options

Glad that you found a solution, however, it doesn't help me! I am so tired of deleting that bloody default. I am on an iMac 2.5" 2011, OS 10.13.6! I have checked my extensions, even the ones I disabled, and I still get this problem. Anyone with a Mac know what to do to resolve this? Please?

Helpful?

more options

Hi Vyncent, what are your specific symptoms? For example:

Could you check whether your Firefox has any "Policies" in effect? To review those, type or paste about:policies in the address bar and press Enter to load that. By default, it will say "The Enterprise Policies service is inactive." If you are not in a managed (business) environment, any policies being applied should be considered suspicious.

Helpful?

  1. 1
  2. 2
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.