Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Repositioning the X on the tab

  • 7 bhfreagra
  • 1 leis an bhfadhb seo
  • 3 views
  • Freagra is déanaí ó cor-el

more options

Update to FF72.01 Running userChrome to keep Tabs on bottom

1...Tabs appear larger and the text for the titles is sitting below the page 2...Close Tab X appears right after any text, 3...if Multiple tabs open, Close Tab X doesn't appear on some Tabs as well as Titles

Should be a quick fix right?, with the amount of people wanting tabs on bottom, a simple check box should be made available to do this, if the user wants

I adjusted the userChrome.css as per some of the answers posed to similar questions, but no change present

Attached screenshots

All Replies (7)

more options

Can you post your current userChrome.css or possibly upload the file and post a link ?

See also the CSS code in this article:

more options

current userChrome.css copied from a link provided through the FF forum

/* TABS: on bottom */
#navigator-toolbox toolbar:not(#nav-bar):not(#toolbar-menubar) {-moz-box-ordinal-group:10}
#TabsToolbar {-moz-box-ordinal-group:1000!important}

#TabsToolbar {
 position: absolute !important; 
 bottom: 0 !important;
 width: 100vw !important;
 display: block !important;
}

#tabbrowser-tabs {
  top: 300 !important;
  width: 100vw !important;
}
#main-window:not([chromehidden*="toolbar"]) #navigator-toolbox {
	padding-bottom: calc(1px + var(--tab-min-height_tnot)) !important;
}

/* TABS: height */
:root {
 --tab-toolbar-navbar-overlap: 0px !important;
 --tab-min-height: 33px !important; /* adjust to suit your needs */
 --tab-min-height_tnot: 32px;
}
:root #tabbrowser-tabs {
 --tab-min-height: 33px !important; /* needs to be the same as above under :root */
 --tab-min-width: 80px !important;
}

#TabsToolbar {
	height: var(--tab-min-height) !important;
	margin-bottom: 1px !important;
	box-shadow: ThreeDShadow 0 -1px inset, -moz-dialog 0 1px !important;
	background-color: var(--toolbar-bgcolor) !important;
}
/* hide windows-controls */
#TabsToolbar #window-controls {display:none!important;}

/* move caption buttons to right of Tab bar */
#main-window[tabsintitlebar]:not([inFullscreen="true"]) #toolbar-menubar[autohide="true"] ~ #TabsToolbar .titlebar-buttonbox-container {
	position: fixed !important;
	right: 0 !important;
	top: calc(6px + var(--tab-min-height)) !important;
	display: block !important;
	visibility: visible !important;
}
#toolbar-menubar[autohide="true"] ~ #TabsToolbar {padding-right: 100px !important;}

Athraithe ag mrg1 ar

more options

Try the solution code I posted inn this thread.

more options

No change whatsoever.... My tabs on the bottom isn't the issue, it's the way the tabs are now displayed, or hidden, ...so can I adjust those through the css file or not..

Going to have to learn to like one of the other browsers I suppose, as you are updating firefox almost as much as Microsoft updates windows... and breaking the same things...

This shouldn't be a difficult thing to accomplish something changed between 71 and 72.0.1 Maybe throw a couple test cycles through the mix... if you're leaning against the css changes, then great, enough people have mentioned, to make the tabs thing an option to move with a checkbox

If you come up with a fix, and one that actually works, post complete solution in this thread, and by that, assume some of us have no idea and want steps

For the time being, Firefox is pushing us to other browsers

more options

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Thanks....sorry for the delay No change, but go ahead and mark this ticket closed for now I reverted back to 71, and turned off updates, and I am back to normal I will wait until the next release and try that Go ahead and close the ticket

more options

I think that this would only happen if the tab label text isn't clipped, but it moved down causing the text to be moved down.

Didn't Firefox Safe Mode had any effect?


You can still try to create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

If that still doesn't help then try a clean reinstall and remove the Firefox program folder and install a freshly downloaded Firefox version.