X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

URL to Saved Logins Manager

Postáilte

The URL I used to use to get to password manager chrome://passwordmgrcontent/passwordManager.xul no longer works. Is there a similar URL that can be used in FF 66?

(I know that in later versions of FF there is a hamburger menu item for this)


A little bit more info:

Just tried it on FF69 Windows and it does work, but it does not work on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS

The URL I used to use to get to password manager chrome://passwordmgrcontent/passwordManager.xul no longer works. Is there a similar URL that can be used in FF 66? (I know that in later versions of FF there is a hamburger menu item for this) A little bit more info: Just tried it on FF69 Windows and it does work, but it does not work on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS

Athraithe ag JackPollack ar

Luaigh

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:66.0) Gecko/20100101 Firefox/66.0

Tuilleadh Eolais

McCoy
  • Top 10 Contributor
590 réiteach 5639 freagra

JackPollack said

chrome://passwordmgrcontent/passwordManager.xul no longer works.

That URL doesn't work, as you left out a forward slash ....

This URL does work :

chrome://passwordmgr/content/passwordManager.xul

''JackPollack [[#question-1275993|said]]'' <blockquote> chrome://passwordmgrcontent/passwordManager.xul no longer works. </blockquote> That URL doesn't work, as you left out a forward slash .... This URL ''does'' work : chrome://passwordmgr/content/passwordManager.xul
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

The missing forward slash was a typo. Still doesnt work for me on FF 66 as you posted.

The missing forward slash was a typo. Still doesnt work for me on FF 66 as you posted.
An bhfuil an freagra seo cabhrach?
Luaigh
McCoy
  • Top 10 Contributor
590 réiteach 5639 freagra

JackPollack said

The missing forward slash was a typo.
Still doesnt work for me on FF 66 as you posted.

As I am not on Fx 66, I can't check it out.

Sorry - hopefully someone else can.

(needless to say that it works for me and others on Fx 71)

''JackPollack [[#answer-1276683|said]]'' <blockquote> The missing forward slash was a typo. <BR> Still doesnt work for me on FF 66 as you posted. </blockquote> As I am not on Fx 66, I can't check it out. Sorry - hopefully someone else can. (needless to say that it works for me and others on Fx 71)
An bhfuil an freagra seo cabhrach?
Luaigh

Freagra Cabhrach

A little bit more info:

Just tried it on FF69 Windows and it does work, but it does not work on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS

A little bit more info: Just tried it on FF69 Windows and it '''does work,''' but it '''does not work''' on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS

Athraithe ag JackPollack ar

An bhfuil an freagra seo cabhrach? 1
Luaigh
McCoy
  • Top 10 Contributor
590 réiteach 5639 freagra

JackPollack said

A little bit more info: Just tried it on FF69 Windows and it does work, but it does not work on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS

I can't check neither the Firefox version you're using, nor your OS, as I am on Windows (and like I mentioned before, with Fx 71).

Let's hope someone else will come to your rescue ....

''JackPollack [[#answer-1276703|said]]'' <blockquote> A little bit more info: Just tried it on FF69 Windows and it '''does work,''' but it '''does not work''' on FF66 Mac (which is where I need to use it). Not sure if it is the FF version or the OS </blockquote> I can't check neither the Firefox version you're using, nor your OS, as I am on Windows (and like I mentioned before, with Fx 71). Let's hope someone else will come to your rescue ....
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17774 réiteach 160767 freagra

The chrome URI works for me in Firefox ESR (45 and 52 and 60) and should work in Firefox 72 and lower (Firefox 73 needs passwordManager.xhtml).

  • chrome://passwordmgr/content/passwordManager.xul

What happens if you try to open this chrome URI via the location bar (not the search bar)?

The chrome URI works for me in Firefox ESR (45 and 52 and 60) and should work in Firefox 72 and lower (Firefox 73 needs passwordManager.xhtml). *chrome://passwordmgr/content/passwordManager.xul What happens if you try to open this chrome URI via the location bar (not the search bar)?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

cor-el said

What happens if you try to open this chrome URI via the location bar (not the search bar)?

I assume you are talking about Preferences - Add Search bar in tool bar (as opposed to use address bar for searches and navigation)

Just tried that, same problem, Doesn't work

''cor-el [[#answer-1276756|said]]'' <blockquote> What happens if you try to open this chrome URI via the location bar (not the search bar)? </blockquote> I assume you are talking about Preferences - Add Search bar in tool bar (as opposed to use address bar for searches and navigation) Just tried that, same problem, Doesn't work
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17774 réiteach 160767 freagra

You didn't answer my question about loading the chrome:// URI. Do you get an error page ?

Is the Firefox Password Manager enabled ?

  • Options/Preferences -> Privacy & Security: Logins and Passwords: "Ask to save logins and passwords for websites"
You didn't answer my question about loading the chrome:// URI. Do you get an error page ? Is the Firefox Password Manager enabled ? *Options/Preferences -> Privacy & Security: Logins and Passwords: "Ask to save logins and passwords for websites"
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

yes, PW manager is enabled and populated.

When I paste into the address bar "chrome://passwordmgr/content/passwordManager.xul " I dont get an error. the bouncing ball in the tab just goes back and forth and never times out

yes, PW manager is enabled and populated. When I paste into the address bar "chrome://passwordmgr/content/passwordManager.xul " I dont get an error. the bouncing ball in the tab just goes back and forth and never times out
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17774 réiteach 160767 freagra

This is a builtin page and should open immediately.

Does Firefox Lockwise work properly ?

  • Options/Preferences -> Privacy & Security: Logins and Passwords: "Saved Logins" -> "Show Passwords"
This is a builtin page and should open immediately. Does Firefox Lockwise work properly ? *Options/Preferences -> Privacy & Security: Logins and Passwords: "Saved Logins" -> "Show Passwords"
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

yes, standard way to open saved login works.

I have tried the URL way on 3 macs all running FF66 and the the URL does not open the saved logins

yes, standard way to open saved login works. I have tried the URL way on 3 macs all running FF66 and the the URL does not open the saved logins
An bhfuil an freagra seo cabhrach?
Luaigh
the-edmeister
  • Top 25 Contributor
  • Moderator
5425 réiteach 40502 freagra

How can Lockwise work in Firefox 66? as cor-el asked about Lockwise wasn't a part of Firefox until Firefox 71.

JackPollack said

... I have tried the URL way on 3 macs all running FF66 and the the URL does not open the saved logins

Did that work when Firefox 66 was the newest Release version? like March, April, & May 2019 Or has that become an issue for you more recently?

How can Lockwise work in Firefox 66? ''as cor-el asked about'' ''Lockwise wasn't a part of Firefox until Firefox 71.'' ''JackPollack [[#answer-1276888|said]]'' <blockquote> ... I have tried the URL way on 3 macs all running FF66 and the the URL does not open the saved logins </blockquote> Did that work when Firefox 66 was the newest Release version? ''like March, April, & May 2019'' Or has that become an issue for you more recently?
An bhfuil an freagra seo cabhrach?
Luaigh
McCoy
  • Top 10 Contributor
590 réiteach 5639 freagra

JackPollack said

The URL I used to use to get to password manager chrome://passwordmgr/content/passwordManager.xul no longer works.
Is there a similar URL that can be used in FF 66?

Maybe type in the address bar about:logins (press Enter) and then bookmark it ?

''JackPollack [[#question-1275993|said]]'' <blockquote> The URL I used to use to get to password manager chrome://passwordmgr/content/passwordManager.xul no longer works.<BR> Is there a similar URL that can be used in FF 66? </blockquote> Maybe type in the address bar '''about:logins''' (press Enter) and then bookmark it ?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

about:logins just gives me "Hmm. That address doesn't look right"

about:config, about:preferences#privacy, etc DO WORK

(I just tried all suggestions under a new clean profile and still nothing working)

about:logins just gives me "Hmm. That address doesn't look right" about:config, about:preferences#privacy, etc DO WORK (I just tried all suggestions under a new clean profile and still nothing working)
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

the-edmeister said

Did that work when Firefox 66 was the newest Release version? like March, April, & May 2019 Or has that become an issue for you more recently?

I hadn't tried it with FF66 Mac prior to a few days ago, but used to use the URL on previous Windows versions of FF

''the-edmeister [[#answer-1276893|said]]'' <blockquote> Did that work when Firefox 66 was the newest Release version? ''like March, April, & May 2019'' Or has that become an issue for you more recently? </blockquote> I hadn't tried it with FF66 Mac prior to a few days ago, but used to use the URL on previous Windows versions of FF
An bhfuil an freagra seo cabhrach?
Luaigh
McCoy
  • Top 10 Contributor
590 réiteach 5639 freagra

JackPollack said

about:logins just gives me "Hmm. That address doesn't look right" about:config, about:preferences#privacy, etc DO WORK

Since you mention "about:config" - just to make sure, would you try this :

Type in the address bar about:config and press Enter (ignore the warning, should you get one)

Type in the seach bar signon.management.page.enabled

Make sure its value is set to true.

Should you have to change the value, then close and restart Firefox.

''JackPollack [[#answer-1276965|said]]'' <blockquote> about:logins just gives me "Hmm. That address doesn't look right" about:config, about:preferences#privacy, etc DO WORK </blockquote> Since you mention "about:config" - just to make sure, would you try this : Type in the address bar '''about:config''' and press Enter (ignore the warning, should you get one) Type in the seach bar '''signon.management.page.enabled''' Make sure its value is set to '''true'''. Should you have to change the value, then close and restart Firefox.
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17774 réiteach 160767 freagra

about:logins (Lockwise) doesn't work in Firefox 66 (builtin Lockwise got added in Firefox 70 or in 67-69 via an extension). The builtin Password Manager in Firefox 66 should use the same chrome URI like you posted and you should be able to open this page in a tab and possibly enter the master password when requested.

Are there any policies active? In Firefox 63+ you can check the about:policies#active page to see whether policies are active.

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
about:logins (Lockwise) doesn't work in Firefox 66 (builtin Lockwise got added in Firefox 70 or in 67-69 via an extension). The builtin Password Manager in Firefox 66 should use the same chrome URI like you posted and you should be able to open this page in a tab and possibly enter the master password when requested. Are there any policies active? In Firefox 63+ you can check the <b>about:policies#active</b> page to see whether policies are active. Start Firefox in <u>Safe Mode</u> to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if <u>hardware acceleration</u> is causing the problem. *switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes *do NOT click the "Refresh Firefox" button on the Safe Mode start window *https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

One of the Policy settings (DisableTelemetry: True) is what is breaking it. When I remove it the URI functions as expected.

I dont suppose that there is any way to keep this policy active and have the password manager URI work

One of the Policy settings (DisableTelemetry: True) is what is breaking it. When I remove it the URI functions as expected. I dont suppose that there is any way to keep this policy active and have the password manager URI work
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17774 réiteach 160767 freagra

Freagra Cabhrach

I took a look at Bugzilla and this appears to be a reported bug that got fixed in Firefox 69/70 release and in 68 ESR. When some about pages are blocked (in this case about:telemetry) then all chrome URIs are blocked.

You will have to disable this policy for now or update Firefox if you want to use a chrome:// URI.

  • Bug 1558866 - Change about page blocking to block specific Chrome URLs

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

I took a look at Bugzilla and this appears to be a reported bug that got fixed in Firefox 69/70 release and in 68 ESR. When some about pages are blocked (in this case about:telemetry) then all chrome URIs are blocked. You will have to disable this policy for now or update Firefox if you want to use a chrome:// URI. *[https://bugzilla.mozilla.org/show_bug.cgi?id=1558866 Bug 1558866] - Change about page blocking to block specific Chrome URLs (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
An bhfuil an freagra seo cabhrach? 1
Luaigh

Úinéir na ceiste

Need to keep FF66 for compatibility with a specific important site, and I am not a big fan of sending telemetry. Guess I will have to scrap this mini project for now.

THANKS YOU EVERYONE FOR YOUR HELP!

Need to keep FF66 for compatibility with a specific important site, and I am not a big fan of sending telemetry. Guess I will have to scrap this mini project for now. THANKS YOU EVERYONE FOR YOUR HELP!
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.