Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Videos won't play in Facebook

  • 4 fhreagra
  • 1 leis an bhfadhb seo
  • 253 views
  • Freagra is déanaí ó Michel

more options

I recently upgraded my Windows 7 laptop to Windows 10. Now in Facebook, videos won't play. I am using the latest Firefox and Flash player. The picture for the video shows up, but when I press play, it turns to a blur and won't play. I restarted Firefox in safe mode and the videos play normally, so it is an add-on causing the issue. I have disable each add-on, but can't seem to find the culprit. Maybe iI am not fully disabling them?

This raises another question...do I still need Flash Player at all? Do browsers now have other ways to play the videos?

Thanks in advance

Réiteach roghnaithe

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 👍 1

All Replies (4)

more options

I just uninstalled Flash and tried to use Firefox without it with no luck...also cleared the cache and facebook cookie...no luck. Also reinstalled Flash with no luck. Also uninstalled and reinstalled Firefox with no luck.

Athraithe ag sdodell ar

more options

Réiteach Roghnaithe

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.


If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
more options

Thanks Cor-el...this has virtually solved the issue! Only one video out of about 30 didn't play after I changed the setting.

more options

I had this issue too. After lots of research I've found the solution. Actually, Firefox has nothing to do with that problem. You mus open Facebook, go to Options/settings and in the left panel scroll until "VIDEOS" click on it. Than in the right panel "UNCHECK" H.D. video quality (by default) and Choose: "STANDARD QUALITY ONLY" .Voilà. All videos are playing perfectly.