X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Somethign in my profile is preventing some add-ons from loading correctly

Postáilte

I can install all the add-ons i want, but some of them don't load correctly or can't be used at all. I believe it has something to do with my profile or my about:config settings. I know this because I downloaded Firefox Nightly and installed one of the add-ons that was not working correctly and it worked fine. Then I copied my profile from Firefox over to Firefox Nightly and the same problem was replicated.

Currently I have found four add-ons that do not load correctly: Fast QR Code Generator, Forecastfox, FoxClocks, uBlock Original

The problem I'm getting is that for the add-ons I either just get the icon and that's it or in settings, only half the settings are loaded and I can't save any modifications made.

Name: Firefox Version: 70.0.1 Build ID: 20191030021342 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0 OS: Windows_NT 6.1

I can install all the add-ons i want, but some of them don't load correctly or can't be used at all. I believe it has something to do with my profile or my about:config settings. I know this because I downloaded Firefox Nightly and installed one of the add-ons that was not working correctly and it worked fine. Then I copied my profile from Firefox over to Firefox Nightly and the same problem was replicated. Currently I have found four add-ons that do not load correctly: Fast QR Code Generator, Forecastfox, FoxClocks, uBlock Original The problem I'm getting is that for the add-ons I either just get the icon and that's it or in settings, only half the settings are loaded and I can't save any modifications made. Name: Firefox Version: 70.0.1 Build ID: 20191030021342 Update Channel: release User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0 OS: Windows_NT 6.1
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

Tuilleadh Eolais

FredMcD
  • Top 10 Contributor
4306 réiteach 60420 freagra

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

This did nothing but get rid off all my add-ons. The first and only add-on I added was uBlock Original and I still had the same problem.

For the uBlock Original add-on the problem is that it does not block anything because only half the setting get loaded and nothing I change in the settings gets saved.

Is there another solution?

This did nothing but get rid off all my add-ons. The first and only add-on I added was uBlock Original and I still had the same problem. For the uBlock Original add-on the problem is that it does not block anything because only half the setting get loaded and nothing I change in the settings gets saved. Is there another solution?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Now since I deleted all the files that store the extensions registry. Most or all of my add-ons don't seem to work at all...

I think what I have to do is start a new profile and sync everything but options and add-ons. Will report back if this works or not...

Now since I deleted all the files that store the extensions registry. Most or all of my add-ons don't seem to work at all... I think what I have to do is start a new profile and sync everything but options and add-ons. Will report back if this works or not...
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

This is a time consuming workaround, but it worked. I finally broke down and created a new profile. I synced everything but the options and add-ons. Then i added all my Add-ons and set up Firefox like I wanted. This seemed to work.

I still don't know what the original problem was and would still like to know in-case it happens again.

This is a time consuming workaround, but it worked. I finally broke down and created a new profile. I synced everything but the options and add-ons. Then i added all my Add-ons and set up Firefox like I wanted. This seemed to work. I still don't know what the original problem was and would still like to know in-case it happens again.
An bhfuil an freagra seo cabhrach?
Luaigh
FredMcD
  • Top 10 Contributor
4306 réiteach 60420 freagra

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

That was very good work. Well Done. Please flag your last post as '''Solved Problem''' as this can help others with similar problems.
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.