X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Wrong choice being selected on right click context menu

Postáilte

I am on FF 70.0.1 (64-bit) and Ubuntu 18.04.3 LTS.

Whenever i right click and scroll through the context menu, the pointer always seems to be lagging or leading the highlighted item, depending on whether i am moving up on down.

And sometimes, the click action seems to be selecting the wrong item, usually one index above or below the actual item i clicked.

This same behaviour is repeatable while scrolling using the keyboard up/down keys as well. Unlike the mouse, this keyboard enter key always selects the wrong item, one index below or above the actual highlighted item depending on whether i am moving up or down.

The only extension enabled right now is "Firefox Multi-Account Containers"

Screenshots attached.

I am on FF 70.0.1 (64-bit) and Ubuntu 18.04.3 LTS. Whenever i right click and scroll through the context menu, the pointer always seems to be lagging or leading the highlighted item, depending on whether i am moving up on down. And sometimes, the click action seems to be selecting the wrong item, usually one index above or below the actual item i clicked. This same behaviour is repeatable while scrolling using the keyboard up/down keys as well. Unlike the mouse, this keyboard enter key always selects the wrong item, one index below or above the actual highlighted item depending on whether i am moving up or down. The only extension enabled right now is "Firefox Multi-Account Containers" Screenshots attached.
Attached screenshots

Réiteach roghnaithe

I have figured out the issue, it was related to turning on Cairo XRender acceleration. I have now re-enabled acceleration and the issue is not appearing. Probably because earlier i had both xrender & skia enabled at the same time.

Now only 'Skia' acceleration is enabled and Xrender has been disabled.

gfx.canvas.azure.backends=skia gfx.xrender.enabled=false

Read this answer in context 0
Luaigh

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:70.0) Gecko/20100101 Firefox/70.0

Tuilleadh Eolais

cor-el
  • Top 10 Contributor
  • Moderator
17578 réiteach 159013 freagra

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting for changes to take effect.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

You can check layout.css.devPixelsPerPx that controls global zoom on the about:config page in case this is causing the problem.

You can try to disable hardware acceleration in Firefox. *Options/Preferences -> General: Performance<br>remove checkmark: [ ] "Use recommended performance settings"<br>remove checkmark: [ ] "Use hardware acceleration when available" *https://support.mozilla.org/en-US/kb/performance-settings Close and restart Firefox after modifying the setting for changes to take effect. *https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems You can check if there is an update for your graphics display driver and check for hardware acceleration related issues. *https://support.mozilla.org/en-US/kb/upgrade-graphics-drivers-use-hardware-acceleration You can check <b>layout.css.devPixelsPerPx</b> that controls global zoom on the <b>about:config</b> page in case this is causing the problem.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Yes, disabling all hardware acceleration fixed it.

I had to reset the "about:config" parameters which i had changed earlier to enable hardware acceleration

Any idea why this is happening?

Is this an Nvidia issue? I am on NVIDIA Proprietry Driver Version: 390.116. This is the latest driver available on Ubuntu repository.

I tried tinkering with "layout.css.devPixelsPerPx" and changed it's value from -1 to 1, but it did not have any effect, the issue persisted.

(My display is at 96 dpi. Command 'xdpyinfo' shows 96x96 dots and 1080p)

These are the parameters which i reset back to original values

webgl.force-enabled webgl.msaa-force gfx.xrender.enabled gfx.canvas.azure.backends = skia,cairo layers.acceleration.force-enabled

Yes, disabling all hardware acceleration fixed it. I had to reset the "about:config" parameters which i had changed earlier to enable hardware acceleration Any idea why this is happening? Is this an Nvidia issue? I am on NVIDIA Proprietry Driver Version: 390.116. This is the latest driver available on Ubuntu repository. I tried tinkering with "layout.css.devPixelsPerPx" and changed it's value from -1 to 1, but it did not have any effect, the issue persisted. (My display is at 96 dpi. Command 'xdpyinfo' shows 96x96 dots and 1080p) These are the parameters which i reset back to original values webgl.force-enabled webgl.msaa-force gfx.xrender.enabled gfx.canvas.azure.backends = skia,cairo layers.acceleration.force-enabled
An bhfuil an freagra seo cabhrach?
Luaigh

Réiteach Roghnaithe

I have figured out the issue, it was related to turning on Cairo XRender acceleration. I have now re-enabled acceleration and the issue is not appearing. Probably because earlier i had both xrender & skia enabled at the same time.

Now only 'Skia' acceleration is enabled and Xrender has been disabled.

gfx.canvas.azure.backends=skia gfx.xrender.enabled=false

I have figured out the issue, it was related to turning on Cairo XRender acceleration. I have now re-enabled acceleration and the issue is not appearing. Probably because earlier i had both xrender & skia enabled at the same time. Now only 'Skia' acceleration is enabled and Xrender has been disabled. gfx.canvas.azure.backends=skia gfx.xrender.enabled=false
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.