Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Cannot delete SSL from Cache

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • 122 views
  • Freagra is déanaí ó cor-el

more options

Hi - I recently deleted SSLs from two of my websites and whislt doing so took all necessary steps to forced HTTP not HTTPS. The sites: 15rueduvieilhopital.fr & thetallskinnylattephilosopher.com load in all browsers and on all devices ok EXCEPT FF on my desktop (v69.0.3 on Mac OS 10.14.6) which keeps looking for the SSl and, because it can't find one, generates a security warning. For the record this doesn't happen in a private browsing window in FF. It appears that FF is somehow caching the SSL. I have deleted 'Everything' from my history and quite and restarted FF but the probelm perists.

Can anyone tell me how to remove the SSLs from the cache?

Thanks Martin

Réiteach roghnaithe

One reason Firefox might prefer HTTPS is an add-on like HTTPS Everywhere. But let's set that aside.

Another possible reason is if the site sent Firefox a "Strict Transport Security" header, instructing Firefox never to visit the site using HTTP, only HTTPS. Firefox stores that information in your profile folder for a certain period of time. If the time has not elapsed, any effort to visit using HTTP will be overridden.

To clear the HSTS flag, you could edit the line for the site out of a file named SiteSecurityServiceState.txt (or simply remove that entire file). Of course, such changes should be made when Firefox is not running.

To easily locate your profile folder, see: Profiles - Where Firefox stores your bookmarks, passwords and other user data

Of course, if it's HSTS, then recent visitors to your site would have the same problem and probably have no idea what to do... so maybe you can turn SSL back on?

Read this answer in context 👍 1

All Replies (3)

more options

Both of the websites that you have posted are working fine on my end. Have you tried rebooting your computer? It could have something to do with the DNS cache. You can also just clean the DNS cache, but rebooting is the simpler option.

You may also have to try pressing Command + Shift + R to bypass any cache that Firefox might still have from your website.

Hope this helps.

more options

Réiteach Roghnaithe

One reason Firefox might prefer HTTPS is an add-on like HTTPS Everywhere. But let's set that aside.

Another possible reason is if the site sent Firefox a "Strict Transport Security" header, instructing Firefox never to visit the site using HTTP, only HTTPS. Firefox stores that information in your profile folder for a certain period of time. If the time has not elapsed, any effort to visit using HTTP will be overridden.

To clear the HSTS flag, you could edit the line for the site out of a file named SiteSecurityServiceState.txt (or simply remove that entire file). Of course, such changes should be made when Firefox is not running.

To easily locate your profile folder, see: Profiles - Where Firefox stores your bookmarks, passwords and other user data

Of course, if it's HSTS, then recent visitors to your site would have the same problem and probably have no idea what to do... so maybe you can turn SSL back on?

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.