Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Symbols do not show correctly

more options

All the symbols do not show normally as shown below.

Attached screenshots

Réiteach roghnaithe

Hi xy79507843, the little boxes indicate that a character specified by the page is missing from the font used for that element. This can occur when web font downloads are blocked, or when Firefox is set to disregard page style rules and use a standard set of fonts. Here are some steps to investigate:

Here are a couple things to check, the details follow:

(1) Font setting -- are pages allowed to specify fonts to use? (2) Is a setting or add-on blocking downloadable fonts?

For #1, go to the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2, some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts".

There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

Read this answer in context 👍 1

All Replies (10)

more options

Réiteach Roghnaithe

Hi xy79507843, the little boxes indicate that a character specified by the page is missing from the font used for that element. This can occur when web font downloads are blocked, or when Firefox is set to disregard page style rules and use a standard set of fonts. Here are some steps to investigate:

Here are a couple things to check, the details follow:

(1) Font setting -- are pages allowed to specify fonts to use? (2) Is a setting or add-on blocking downloadable fonts?

For #1, go to the Options page:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, scroll down to the "Fonts & Colors" section and click the "Advanced" button.

Then make sure the box is checked for "Allow pages to choose their own fonts, instead of your selections above":

Any difference (you would need to reload the problem page, Ctrl+r or the circling arrow button, to see any difference)?

For #2, some add-ons have a feature to globally block downloadable fonts unless you specially allow them. Do you run uBlock Origin or NoScript, for example? In uBlock Origin, the setting is called "Block remote fonts".

There's also a general setting to block downloadable fonts in about:config, if you think you might ever have changed that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste gfx.down and pause while the list is filtered

(3) If the gfx.downloadable_fonts.enabled preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

Was it any of those things?

more options

If you use uBlock Origin make sure not to "block remote fonts".

more options

Solved. Thanks!

more options

I have checked all the mentioned points, but this does not help: the symbol font is not displayed on web pages of other people. If I need a special character I can use Unicode notation or even UTF-8 code page for my web pages, however, I cannot influence on others' web pages (the Symbol font may be used multiple times there so Developer Tools cannot help).

more options

Firefox doesn't support the Symbol font. Only Unicode glyphs works properly in all modern browsers and in all cases unless custom fonts on servers that are on a public block list used by Firefox (e.g. disconnect.me). If people use content blocking extensions or make changes to browser settings then that is their problem.

more options

I have switched my AdBlocker Ultimate add-on off and reloaded the page but the page (http://numbers.computation.free.fr/Constants/Algorithms/nthdigit.html) still is displayed incorrectly. I opened the same page in Chrome and it is displayed ok...

I prefer to use Firefox, so I would like to use it and not switch between several browsers. I have no idea why Firefox still doesn't support the Symbol font.

more options

Note that page is from 2003 and during that time Unicode was less common. Firefox doesn't support fonts like the Symbol font that maps on the 8-bit ASCII plane (0x00-0xFF). I can't remember in what Firefox version you could make this work with editing some files (might have been possible in Firefox 3 or older versions).

more options

The question was that I need to see the correct view of a web-page made by other persons long ago. Back compatibility. If I make my web page I use Unicode notation or even Mathjax to prepare formulae or Eastern characters. I Mozilla Firefox developers consider this back compatibility feature obsolete and unnecessary, then users will be forced to use another browser for this particular case. It is inconvenient, but what is another solution? Maybe provide a web-version of Symbol font and use it in such cases.

more options

A web (woff) font won't work for case like this. This symbol font uses the same code point like normal ASCII text, only they replace the ASCII text with symbols. You would first have this font installed (this may not be obvious for other platforms) and then you need browser support to override the current font with the Symbol font for character that are present in the current font.

Some forum threads that date back nine years ago:

more options

So, it is a principled stand of Mozilla not to provide some tool/feature to fix the problem known for years and still actual. I think someone can write an add-on/plug-in to fix this.