Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

As of V.69 of Firefox when I type a URL into the address bar it defaults to searching on google for the site instead of history

  • 5 fhreagra
  • 1 leis an bhfadhb seo
  • 4 views
  • Freagra is déanaí ó rtbink

more options

In Firefox 69 when I type a URL into the address bar the first suggestion is always a google (or what ever search engine is selected) search instead of the history. How to I stop this behavior? I use a separate search field.

All Replies (5)

more options

Hi rtbink, In Options on the Search page, under Default Search Engine, deselect 'Show search suggestions ahead of browsing history in address bar results'.

Then, on the Privacy & Security page, under Address Bar, select Browsing History.

more options

I did as you suggested and it does not work. I'm using v.69, I've confirmed it one windows 10 and Mac.

If I type in "you" into the address bar the default option is a google search for "you" that has youtube as it's first hit. The history is the second option which is youtube. This defaults you to constantly falling into the search engine.

I deselected show search suggestions and it stopped in the search bar but continues after 3 characters in the address bar

more options

rtbink said

If I type in "you" into the address bar the default option is a google search for "you" that has youtube as it's first hit. The history is the second option which is youtube. This defaults you to constantly falling into the search engine.

Maybe autofill is disabled -- that's the feature that shows a site address in the address bar itself as you type. You could check here:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste URLB and pause while the list is filtered

(3) If the browser.urlbar.autoFill preference is bolded and "modified" or "user set" to false, double-click it to restore the default value of true

more options

Hi - thanks for the reply

But it didn't help.

Just to be clear. When I type into the address bar I always get a google search if I type 2 or more letters. If I "show history" that will show below the google search. In the Preferences/search I have "add search bar in tool bar" selected. I have "show search suggestions in address bar" turned off. In Preferences/Privacy and security I have "suggest history" turned on. It doesn't help.

This behavior started in V. 69 - so it is something new.

thanks for all your help

more options

Hi

Also, browser.urlbar.autoFill is set to true.