X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

How do I stop Multible firefox processes from running? They are using up all my memory.

Postáilte

Before to fix this problem I went into "about:config" and changed "browser.tabs.remote.autostart" setting to false and it fixed the problem. I went in and checked and it still says false but I have multiple processes. How do I stop them now? I can't use firefox if its going to keep using up all my memory and freezing up my pages.

Before to fix this problem I went into "about:config" and changed "browser.tabs.remote.autostart" setting to false and it fixed the problem. I went in and checked and it still says false but I have multiple processes. How do I stop them now? I can't use firefox if its going to keep using up all my memory and freezing up my pages.

Réiteach roghnaithe

Hi Dodi

Thanks for the screenshot. Something went wrong because you misunderstood. MOZ_FORCE_DISABLE_E10S=1 means that you need to create an environment variable with the name MOZ_FORCE_DISABLE_E10S and set its value to 1. You created a variable with the name Path and set its value to MOZ_FORCE_DISABLE_E10S=1 That explains why it didn't work.

Create a new environment variable:

name: MOZ_FORCE_DISABLE_E10S
value: 1

You can remove the 'Path' variable you created with value MOZ_FORCE_DISABLE_E10S=1

Read this answer in context 1
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Tuilleadh Eolais

McCoy
  • Top 10 Contributor
545 réiteach 5139 freagra

Hello Bnice2me (I will),

Firefox will no longer let users disable multi-process (e10s) on the "about:condig" page .....

Please see : https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/

And also : https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html

Have you seen my post in this thread where you also posted (?) :

https://support.mozilla.org/en-US/questions/1265005

Hello Bnice2me (I will), Firefox will no longer let users disable multi-process (e10s) on the "about:condig" page ..... Please see : https://www.ghacks.net/2019/05/17/going-forward-multi-process-cant-be-turned-off-anymore-in-firefox/ And also : https://techdows.com/2019/05/mozilla-firefox-68-doesnt-allow-turning-off-e10s.html Have you seen my post in this thread where you also posted (?) : https://support.mozilla.org/en-US/questions/1265005
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Hi McCoy, I received your email and would like to change the command line but confused on exactly how to do it. Using the command prompt I don't know how to get into installation directory and do I type the quotation marks in the line or not.

Thank you Dodie

Hi McCoy, I received your email and would like to change the command line but confused on exactly how to do it. Using the command prompt I don't know how to get into installation directory and do I type the quotation marks in the line or not. Thank you Dodie
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17530 réiteach 158511 freagra

Easiest is to use the Windows Control Panel and create an environment variable to disable multi-process.

  • Control Panel -> System -> Advanced -> Environment variables
  • MOZ_FORCE_DISABLE_E10S=1

That way it also works if you click a link in an external application (email).

See also:

Easiest is to use the Windows Control Panel and create an environment variable to disable multi-process. *Control Panel -> System -> Advanced -> Environment variables *MOZ_FORCE_DISABLE_E10S=1 That way it also works if you click a link in an external application (email). See also: *https://www.computerhope.com/issues/ch000549.htm
An bhfuil an freagra seo cabhrach? 0
Luaigh

Úinéir na ceiste

I did as you suggested and then restarted my pc but there is still multiple firefox processes.

Dodi

I did as you suggested and then restarted my pc but there is still multiple firefox processes. Dodi
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17530 réiteach 158511 freagra

Can you attach a screenshot that shows the Environment Variables panel in the Windows Control Panel ?

Can you attach a screenshot that shows the Environment Variables panel in the Windows Control Panel ?
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

There you go.

Dodi

There you go. Dodi
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17530 réiteach 158511 freagra

Réiteach Roghnaithe

Hi Dodi

Thanks for the screenshot. Something went wrong because you misunderstood. MOZ_FORCE_DISABLE_E10S=1 means that you need to create an environment variable with the name MOZ_FORCE_DISABLE_E10S and set its value to 1. You created a variable with the name Path and set its value to MOZ_FORCE_DISABLE_E10S=1 That explains why it didn't work.

Create a new environment variable:

name: MOZ_FORCE_DISABLE_E10S
value: 1

You can remove the 'Path' variable you created with value MOZ_FORCE_DISABLE_E10S=1

Hi Dodi Thanks for the screenshot. Something went wrong because you misunderstood. MOZ_FORCE_DISABLE_E10S=1 means that you need to create an environment variable with the name MOZ_FORCE_DISABLE_E10S and set its value to 1. You created a variable with the name <b>Path</b> and set its value to <b>MOZ_FORCE_DISABLE_E10S=1</b> That explains why it didn't work. Create a new environment variable: name: <b>MOZ_FORCE_DISABLE_E10S</b> value: <b>1</b> You can remove the 'Path' variable you created with value MOZ_FORCE_DISABLE_E10S=1
An bhfuil an freagra seo cabhrach? 1
Luaigh

Úinéir na ceiste

Thank you so much my browser is running fast again and no crashes.

Respectfully Dodi

Thank you so much my browser is running fast again and no crashes. Respectfully Dodi
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.