X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Personal web page functions have stopped working

Postáilte

First, my problem is occurring on personal web page projects I work on. Every file is saved on and accessed from my local hard drive. My projects involve two frames...left frame is table of contents, right frame is the "main frame". I hide the table of contents until the mouse goes over to a certain part of the screen...when this happens, the contents frame "pops out". When the mouse leaves the contents frame, the frame hides itself again. Since the last Firefox update, (July 18 2019, I believe), the pop-out / hide functions aren't working. The frames still load in, but they won't pop out or hide when they're supposed to. They stay at whatever size I resize the frame to. In addition to this, my personal project pages are no longer loading in the fonts they are supposed to. Everything seems to be defaulting to the system (or Firefox) standard.

More Information: The pop-out / hide functions only seemed to ever work with Firefox. I never could get it to work with Opera / Chrome / IE. This is the main reason I stuck with Firefox for so long.

Is this an error that is going to be fixed, or a byproduct of a change that's been made that I'm just going to have to live with? I can provide more information if needed.

First, my problem is occurring on personal web page projects I work on. Every file is saved on and accessed from my local hard drive. My projects involve two frames...left frame is table of contents, right frame is the "main frame". I hide the table of contents until the mouse goes over to a certain part of the screen...when this happens, the contents frame "pops out". When the mouse leaves the contents frame, the frame hides itself again. Since the last Firefox update, (July 18 2019, I believe), the pop-out / hide functions aren't working. The frames still load in, but they won't pop out or hide when they're supposed to. They stay at whatever size I resize the frame to. In addition to this, my personal project pages are no longer loading in the fonts they are supposed to. Everything seems to be defaulting to the system (or Firefox) standard. More Information: The pop-out / hide functions only seemed to ever work with Firefox. I never could get it to work with Opera / Chrome / IE. This is the main reason I stuck with Firefox for so long. Is this an error that is going to be fixed, or a byproduct of a change that's been made that I'm just going to have to live with? I can provide more information if needed.
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Tuilleadh Eolais

Úinéir na ceiste

Further Information: I seem to have tracked down at least part of this problem. The following line of code is no longer executing for some reason:

var contentsContainer = parent.document.getElementById('Contents_Container');

Further Information: I seem to have tracked down at least part of this problem. The following line of code is no longer executing for some reason: var contentsContainer = parent.document.getElementById('Contents_Container');
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17348 réiteach 156820 freagra

Freagra Cabhrach

You can see CORS errors when you use the file:// protocol to access local files via XMLHttpRequest, Fetch APIs, Web Fonts (@font-face), and WebGL textures, and XSL stylesheets.

You can see CORS errors when you use the file:// protocol to access local files via XMLHttpRequest, Fetch APIs, Web Fonts (@font-face), and WebGL textures, and XSL stylesheets. *https://developer.mozilla.org/en/Web/HTTP/CORS/Errors/CORSRequestNotHttp *https://www.mozilla.org/en-US/security/advisories/mfsa2019-21/#CVE-2019-11730
An bhfuil an freagra seo cabhrach? 1
Luaigh

Úinéir na ceiste

Thank you! Going into about:config and setting privacy.file_unique_origin to false seems to have set everything back to normal!

Thank you! Going into about:config and setting privacy.file_unique_origin to false seems to have set everything back to normal!
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.