Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dúnadh an snáithe seo agus cuireadh sa chartlann é. Cuir ceist nua má tá cabhair uait.

Why will toolbars not hide in full screen mode?

  • 13 freagra
  • 4 leis an bhfadhb seo
  • 3577 views
  • Freagra is déanaí ó Chris Ilias

more options

I'm using Firefox 68.0.1 on macOS Mojave 10.14.5. When I go full screen, the tabs and address bar remain at the top of the screen. I can't make them go away. I've tried:

- Installing plugins (I tried a couple) - Disabling Add-ons (Safe mode) - Resetting Firefox - Disabling hardware acceleration (and restart browser) - Using different techniques to go full screen (Cmd+Shift+F, Cmd+Ctrl+F, Zoom menu) - Scrolling or clicking in the canvas to ensure focus

No matter what, the tab bar and address bar remain on the screen (see attached screenshot). I've also attached my browser config (filtered on "full"). Is there any way to get a full-screen experience in Firefox?

Attached screenshots

Réiteach roghnaithe

There is a userChrome.css script that will remove the toolbar from full screen mode for Firefox on macOS.

  1. Go to Help > Troubleshooting Information, then click on Show in Finder. That will open Finder in your Firefox profile.
  2. Quit Firefox.
  3. Create a folder in your profile folder called chrome
  4. Open a text editor, like TextEdit (in Plain Text mode!), and paste the following code:
    #navigator-toolbox[inFullscreen] {
        position: relative;
        z-index: 1;
        height: 3px;
        margin-bottom: -3px;
        opacity: 0;
        overflow: hidden;
    }
    
    #navigator-toolbox[inFullscreen]:hover {
        height: auto;
        margin-bottom: 0px;
        opacity: 1;
        overflow: show;
    }
    
    #content-deck[inFullscreen]{
        position:relative;
        z-index: 0;
    }
    
  5. Save the file in the chrome folder, and name it userChrome.css

If you ever want to revert that behaviour, just get rid of the code from the file.

Read this answer in context 👍 1

All Replies (13)

more options

Hello Jason,

Maybe you'd like to give this add-on a try :

https://addons.mozilla.org/en-US/firefox/addon/fullscreen_plus/

more options

I tried it, but no luck. I've updated my review from two years ago (https://addons.mozilla.org/en-US/firefox/addon/fullscreen_plus/reviews/972909/) to indicate that Ctrl+Shift+F has no effect with the plugin installed.

more options

See if maybe the Chosen Solution here will work for you (or another suggestion) :

https://support.mozilla.org/en-US/questions/1254683?mobile=0

more options

Still no luck. The Chosen Solution on that link leads to another question where the Chosen Solution is the add-on you suggested earlier.

I tried creating a clean profile, but the behavior is the same there.

I tried setting full-screen-api.allow-trusted-requests-only to false, but that had no effect (on standard full screen or ability to invoke full screen with ctrl+shift+f with the fullscreen-plus addon).

more options

See also:

  • Bug 1403085 - Use native fullscreen on macOS (behind full-screen-api.macos-native-full-screen pref)

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Asking you to see if that Chosen Solution would work for you wasn't one of my brightest moments (my apologies).


See this really old bug report :

https://bugzilla.mozilla.org/show_bug.cgi?id=774677

And then this one :

https://bugzilla.mozilla.org/show_bug.cgi?id=740148

If you want to, you could vote to show your interest for that bug report :

https://bugzilla.mozilla.org/page.cgi?id=voting.html

If you have any additional information to add, you can post a comment, but keep it to the point and concise. If you have no additional information but have the same problem : posting "I have the exact same problem" would suffice (and maybe post a link to your thread).

See the section Commenting, especially #4

more options

Réiteach Roghnaithe

There is a userChrome.css script that will remove the toolbar from full screen mode for Firefox on macOS.

  1. Go to Help > Troubleshooting Information, then click on Show in Finder. That will open Finder in your Firefox profile.
  2. Quit Firefox.
  3. Create a folder in your profile folder called chrome
  4. Open a text editor, like TextEdit (in Plain Text mode!), and paste the following code:
    #navigator-toolbox[inFullscreen] {
        position: relative;
        z-index: 1;
        height: 3px;
        margin-bottom: -3px;
        opacity: 0;
        overflow: hidden;
    }
    
    #navigator-toolbox[inFullscreen]:hover {
        height: auto;
        margin-bottom: 0px;
        opacity: 1;
        overflow: show;
    }
    
    #content-deck[inFullscreen]{
        position:relative;
        z-index: 0;
    }
    
  5. Save the file in the chrome folder, and name it userChrome.css

If you ever want to revert that behaviour, just get rid of the code from the file.

Athraithe ag Chris Ilias ar

more options
more options

Thanks for all the tips. I ended up grabbing the CSS linked from the open ticket (https://bugzilla.mozilla.org/show_bug.cgi?id=740148#c93) (thanks McCoy) and using the advice from Chris Ilias, linked that content to the chrome/userChrome.css file in my profile. Now in fullscreen the bars tuck away and resume nicely. That's what I need to run my presentation next week. Thanks to everybody for the help.

more options

That is about this code in case that pastebin web page will disappear:

:root[inFullscreen] #navigator-toolbox {
	z-index: 1;
	margin-top: calc(-40px - var(--tab-min-height));
}
:root[inFullscreen] #navigator-toolbox::after {
	visibility: hidden;
}
:root[sizemode="fullscreen"][inFullscreen] #navigator-toolbox,
:root[sizemode="fullscreen"][inFullscreen] #navigator-toolbox::after {
	transition: all .2s ease .5s !important;
}
:root[inFullscreen] #navigator-toolbox:focus-within,
:root[inFullscreen] #navigator-toolbox:hover {
	transition-delay: 0s !important;
	margin-top: 0;
}
:root[inFullscreen] #navigator-toolbox:focus-within::after,
:root[inFullscreen] #navigator-toolbox:hover::after {
	transition-delay: 0s !important;
	visibility: visible;
}
:root[inFullscreen] #content-deck {
	position: fixed;
	z-index: 0;
	top: 0;
	width: 100%;
	height: 100%;
}
:root[inFullscreen] #content-deck > #browser {
	width: 100%;
	height: 100%;
}
more options

I tried the code on Linux and added some important flags and adjusted the margin-top (I have the Bookmarks Toolbar visible) and have the navigator-toolbox sliding in. You probably will have to adjust the 'margin-top: calc()' value to make the toolbar fully hide and still be able to make it slide down.


@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul");

:root[inFullscreen] {
  --navbar-height: 40px;
  --personaltoolbar-height: 26px;
}

:root[inFullscreen] #nav-bar {
  height: var(--navbar-height) !important;
  min-height: var(---navbar-height) !important;
  visibility: visible !important;
}

:root[inFullscreen] #PersonalToolbar {
  height: var(--personaltoolbar-height) !important;
  min-height: var(--personaltoolbar-height) !important;
  max-height: none !important;
  visibility: visible !important;
}

:root[inFullscreen] #navigator-toolbox {
  margin-top: calc(0px - var(--navbar-height) - var(--personaltoolbar-height) - var(--tab-min-height)) !important;
  z-index: 1;
}

:root[inFullscreen] #navigator-toolbox::after {
	visibility: hidden !important;
}
:root[sizemode="fullscreen"][inFullscreen] #navigator-toolbox,
:root[sizemode="fullscreen"][inFullscreen] #navigator-toolbox::after {
	transition: all .2s ease .5s !important;
}
:root[inFullscreen] #navigator-toolbox:focus-within,
:root[inFullscreen] #navigator-toolbox:hover {
	transition-delay: 0s !important;
	margin-top: 0 !important;
}
:root[inFullscreen] #navigator-toolbox:focus-within::after,
:root[inFullscreen] #navigator-toolbox:hover::after {
	transition-delay: 0s !important;
	visibility: visible !important;
}
:root[inFullscreen] #content-deck {
        display: block !important;
	position: fixed !important;
	z-index: 0 !important;
	top: 0 !important;
	width: 100% !important;
	height: 100% !important;
}
:root[inFullscreen] #content-deck > #browser {
	width: 100% !important;
	height: 100% !important;
}

Athraithe ag cor-el ar

more options

This is ridiculously complicated, and and I never had this problem till tonight! In Safari, you just hit View, and click on "hide toolbars when in full screen", not all this stuff that no one would know! What is FF thinking?

Athraithe ag StevenCee ar

more options

Hi StevenCee, This thread was marked as the solution by the person who asked the original question (Jason R. Coombs). Your issue may have similar symptoms, but it is likely a different cause/solution, especially if it just started yesterday. Could you please post your question using the following link: https://support.mozilla.org/en-US/questions/new That way, volunteers can get more details about your setup.

Because this thread is solved and more people might start using it for their own questions, I'm going to lock it.