X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Adobe downloading file - ask what to do every time

Postáilte

I've seen this question asked before but the solution given did not work for me. Every time I go to download a .pdf, Firefox will ask 'what do you want firefox to do?'. I have selected 'open with adobe reader (default)', and have the 'do this every time' box checked. It will then open the file to view on the screen. If I close it and click the same download button, it ask the question again, totally ignoring the 'every time' checked box. These files are standard Adobe .pdf and should be recognizable by Firefox every single time, but it acts like its never seen the file type before. I've tried a couple of different solutions but nothing works. Any ideas?

I've seen this question asked before but the solution given did not work for me. Every time I go to download a .pdf, Firefox will ask 'what do you want firefox to do?'. I have selected 'open with adobe reader (default)', and have the 'do this every time' box checked. It will then open the file to view on the screen. If I close it and click the same download button, it ask the question again, totally ignoring the 'every time' checked box. These files are standard Adobe .pdf and should be recognizable by Firefox every single time, but it acts like its never seen the file type before. I've tried a couple of different solutions but nothing works. Any ideas?
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

Tuilleadh Eolais

jscher2000
  • Top 10 Contributor
8498 réiteach 69426 freagra

Hi Unajet, if you double-check the Options page, has Firefox saved the Open in Acrobat setting there? This article will get you to that setting: How to disable the built-in PDF viewer and use another viewer.

I've seen this question asked before but the solution given did not work for me. ... I've tried a couple of different solutions but nothing works.

What else did you try?


Do you notice this problem on a particular website, or does it happen with all PDFs from everywhere? Some websites do not send the PDF-specific Content-Type header (application/pdf) and then Firefox doesn't treat them like PDFs but instead like a generic kind of binary file. I created an add-on to work around that issue (when a file has a .pdf extension, it corrects the content-type):

https://addons.mozilla.org/firefox/addon/content-type-fixer/

I suggest keeping it turned off, and turning it on when you get to a site with that problem.

Hi Unajet, if you double-check the Options page, has Firefox saved the Open in Acrobat setting there? This article will get you to that setting: [[How to disable the built-in PDF viewer and use another viewer]]. <blockquote> I've seen this question asked before but the solution given did not work for me. ... I've tried a couple of different solutions but nothing works. </blockquote> What else did you try? ---- Do you notice this problem on a particular website, or does it happen with all PDFs from everywhere? Some websites do not send the PDF-specific Content-Type header (application/pdf) and then Firefox doesn't treat them like PDFs but instead like a generic kind of binary file. I created an add-on to work around that issue (when a file has a .pdf extension, it corrects the content-type): https://addons.mozilla.org/firefox/addon/content-type-fixer/ I suggest keeping it turned off, and turning it on when you get to a site with that problem.
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Yes, Adobe is already set up as the default .pdf program. I also found a solution where you delete a certain file that has your preferences so that you start over. It didn't work. All of the .pdf's that I'm trying to open are being sent over in Gmail using Firefox browser. They are invoices from different companies, but are all .pdf's.

Yes, Adobe is already set up as the default .pdf program. I also found a solution where you delete a certain file that has your preferences so that you start over. It didn't work. All of the .pdf's that I'm trying to open are being sent over in Gmail using Firefox browser. They are invoices from different companies, but are all .pdf's.
An bhfuil an freagra seo cabhrach?
Luaigh
jscher2000
  • Top 10 Contributor
8498 réiteach 69426 freagra

Hmm, are they opening from the Gmail "attachments" domain, which I think is the usercontent one, or from Google Drive?

Either way, you could try my extension to see whether that resolves it.

Hmm, are they opening from the Gmail "attachments" domain, which I think is the usercontent one, or from Google Drive? Either way, you could try my extension to see whether that resolves it.
An bhfuil an freagra seo cabhrach?
Luaigh
My_Cheese_Is_Slippin'
  • Top 25 Contributor
18 réiteach 250 freagra

Hi Unajet, In Options -> General page do you have Downloads set to Save files to...

And Applications set to Preview in Firefox

Hi Unajet, In Options -> General page do you have Downloads set to Save files to... And Applications set to Preview in Firefox
An bhfuil an freagra seo cabhrach?
Luaigh

Úinéir na ceiste

Yes, I have used both 'preview in firefox' and 'adobe' but not matter which one is listed, when I click 'download' on the actual file, it still wants to know every single time my choice.

Yes, I have used both 'preview in firefox' and 'adobe' but not matter which one is listed, when I click 'download' on the actual file, it still wants to know every single time my choice.
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.