Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

No websites will load in Firefox, but will in other browsers

  • 9 bhfreagra
  • 2 leis an bhfadhb seo
  • 248 views
  • Freagra is déanaí ó bliznezz

more options

Using Ubuntu 18.04, 4.15.0-33-generic GNU/Linux, and Mozilla Firefox 67.0. Other browsers work fine, so it is not an internet connectivity issue. Firefox uses no proxy, and has IPv6 disabled. It cannot open a local server like 192.168.1.4, so it is not a DNS resolution issue. If I run it from CLI, I get the following:

Sandbox: seccomp sandbox violation: pid 25975, tid 25983, syscall 53, args 1 1 0 139885284952128 0 139884708835328. [Child 25975, Socket Thread] WARNING: Unable to create pipe named "25975.45.480528193" in server mode error(Function not implemented).: file /build/firefox-xkwMhH/firefox-67.0+build2/ipc/chromium/src/chrome/common/ipc_channel_posix.cc, line 210

Happens after a recent update, so may go back to earlier version.

Réiteach roghnaithe

Try to create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 👍 0

All Replies (9)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Yeah, I already saw that page, but did not find any information that was useful for linux. There is no information about any other ports that might need to be opened up, for example. I don't know where there is any such "list of trusted or recognized programs" in linux.

more options

FredMcD, your reply is more suited for Firefox on Windows and not Linux.

Seems like it may be a issue with the package build from Ubuntu and not the official build of Firefox for Linux from say www.mozilla.org/firefox/all

This poster /questions/1259828 had this issue with Ubuntu build but not with Mozilla build of Firefox.

more options

Réiteach Roghnaithe

Try to create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

I believe I have the same problem. I couldn't post a reply here without posting a separate question, so for completeness' sake here's my instance: https://support.mozilla.org/en-US/questions/1259874.

I have found that Firefox will load web pages in safe mode, strangely. Disabling extensions, themes, userChrome.css and JavaScript manually does not fix the issue. Makes me wonder what else is different about safe mode that makes it work.

Edit:

cor-el said

Try to create a new profile to test if your current profile is causing the problem.

A new profile worked for me, I'll see if I can find out what's corrupted.

Athraithe ag Nomen_Latinum ar

more options

How very strange. I created a new user profile and copied all files and folders from the old profile into it. It worked like a charm. I assumed there must just be something missing from the old profile, so I then copied all files and folders from the new profile back into the old profile. It still doesn't work. The two profile folders are now exactly identical. This is a fine workaround but I'm really curious as to what's causing the original problem.

more options

Thanks @Nomen_Latinum for the info and @cor-el for the suggestion. Indeed, creating the new profile and transferring bookmarks, etc to the new profile worked. I did not go as far as Nomen_Latinum for debugging, but those results are indeed strange.

more options

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.


Could have been a corrupt file that was removed.


Back up and restore information in Firefox profiles.{web link} I use an add-on that makes backups of my user profile, Just In Case. Unfortunately, it is not compatible with the current Firefox.

Every now and then, open the profile folder and create a copy of the current profile as is to another location on your hard drive. This way you will have a backup.

If you do this each day, you will not lose much data. This should be done with Firefox Closed.

Note: In case you need to restore from these backups, you may need to overwrite old or corrupted files.

more options

recived this problem when switched about:config security.sandbox.content.level value from 4 to 1

due fixing some css and font issues: https://support.mozilla.org/en-US/questions/1188968