Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

I deliberately do NOT run current version (I'm on 51) to avoid interference with my choices. Now half of my add-ons are disabled. How to I remove this "feature"

  • 12 freagra
  • 2 leis an bhfadhb seo
  • 59 views
  • Freagra is déanaí ó RichardHill

more options

I run v51.0.1 DELIBERATELY because you keep making changes that I canNOT undo! Today half my ad-ons that I have been using for YEARS became disabled. I don't care WHO thinks they are "old" or "unsafe" - THIS is why I have stayed on v51 so I can work with what I need instead of what you THINK I need. I need the config parameters to turn OFF ANY and ALL of your "protections" that I do not need You have 15 versions of defective software now, you had 14 until you screwed with mine. A "feature" without an OFF switch is a defect and I want this defect corrected. I do NOT want to update to 65 - I lose too many features I want to keep and the add-ons I want to keep will not work in v57+ - Hence I stayed at v51. --Kindly tell me how to repair my now-defective browser and then please tell your developers, as politely as you choose, to STOP ADDING DEFECTS! A "feature" without an OFF switch is a defect.

Thank you Richard Hill

Réiteach roghnaithe

Richard, you and I are in the same situation. Take a look at my similar post:

https://support.mozilla.org/en-US/questions/1258482

By the way, someone posted to yo regarding turning on "Studies". Ignore that advice. We don't have that option.

See my post for other options.

Read this answer in context 👍 1

All Replies (12)

more options

Late on Friday May 3rd, we became aware of an issue with Firefox that prevented existing and new add-ons from running or being installed. We are very sorry for the inconvenience caused to people who use Firefox. See Add-ons disabled or fail to install on Firefox for more information.

We rolled-out a fix for release, beta and nightly users on Desktop. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, we are using the Studies system. You can check if you have studies enabled as follows:

  1. Click the menu Fx57Menu button at the top right of the Firefox window.
  2. Click on Options (Windows) or Preferences (Mac and Linux).
  3. Select the Privacy & Security panel and scroll down to the Firefox Data Collection and Use section.
  4. The box next to Allow Firefox to install and run studies should be checked.
    • If the box is not checked, click it to check mark the setting.
      Fx61DataCollection-Studies

You can disable studies again, if you wish, after your add-ons have been re-enabled. See About Studies for more information.

Please do not delete your add-ons as an attempt to fix. You will lose any data related to the add-on. Disabled add-ons will not lose any data.

There are a number of work-arounds being discussed in the community. These are not recommended as they may conflict with fixes we are deploying. We’ll let you know when further updates are available that we recommend, and appreciate your patience.

We are still working on a fix for Firefox for Android. We’ll continue to provide updates on our blog post.

more options

Sorry that you are having that problem with Firefox 51.0.1 and add-ons being disabled, but with that old of a version it may be some time before a fix is ready if that happens at all.

more options

"Firefox Data Collection and Use section" is not present in my version. And yes - as I stated, I DELIBERATELY stayed at this version so you couldn't screw it up! How can you roll out defects to versions you do not support ? I repeat - A "feature" with no OFF-switch is a defect. Please tell me how, if I re-install 51 I can avoid any more defect-castings? I turned OFF updates to avoid just this kind of stupid thing - and what good did it do me? You STILL "updated" me without my permission or desire.

Just tell me how to undo this stupidity and what config setting(s) I need to enable to prevent ANY more "roll outs" or "updates" on this "old" and "non supported" version - which btw works PERFECTLY until your eager beavers screwed it up.

VERY disappointed: I expect this kind of behavior from M$ and Google but I thought the Mozilla group was beyond this sort of stupidity ..... Very Dissapointed. And can't work now. Thank you SOOOOO much.

more options

Hi Richard, as far as I can tell, you did not get an update. Your post says 51.0.1, which is ancient now.

What happened to your Firefox was what happened to all versions of Firefox. A critical certificate expired, and the first time after midnight May 4th UTC that your Firefox went to re-verify extensions, it declared most or all of them to be unverifiable.

The fix for all versions of Firefox is to install an updated certificate. The question is how users of old versions of Firefox will get that. Do you want suggestions for unsupported workarounds, like: https://support.mozilla.org/questions/1258165#answer-1218833

more options

Réiteach Roghnaithe

Richard, you and I are in the same situation. Take a look at my similar post:

https://support.mozilla.org/en-US/questions/1258482

By the way, someone posted to yo regarding turning on "Studies". Ignore that advice. We don't have that option.

See my post for other options.

more options

Go to about:config

Search for xpinstall.signatures.require

Double click it to set to false.

Wait a few seconds. Your add-on's should come back to life.


My issue was somewhat resolved using

xpinstall.signatures.require = true and setting it to false.

However, now that the disabled add-on's are re-enabled, each of them is highlighted in yellow with an unsupported notification.

more options

OnThePike said

Go to about:config Search for xpinstall.signatures.require Double click it to set to false.

Regular releases do not honor

xpinstall.signatures.require => false

That is for ESR releases and Developer/Nightly releases.

Also, this introduces the risk of rogue updates, so you should consider also disabling extension auto-updates with this setting so you'll have the opportunity to inspect and reject any questionable extension updates:

extensions.update.autoUpdateDefault => false

With that setting, when an update is detected, a new category will appear on the Add-ons page listing available updates.

more options

You posted with a weird user agent. You write that you are using Firefox 51.0.1, but the user agent shows rv:48 and Firefox/61.0

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:48.0) Gecko/20100101 Firefox/61.0
more options

OnThePIke - you are the MAN! Installing the new intermidiate cert fixed my problems. All of my add-ons are not working and my extensions are 'live". Now in v51.0.1 changing this property "xpinstall.signatures.require" did nothing for me and jsher2000 has it right. Crawling around in the back end I see where this idiotic cert is placed - and I have to again ask WHY? WHY would a CLIENT have a mandatory cert; that we don't have access to change or ever are told about??

If Mozilla wants us to upgrade then STOP PUTTING DEFECTS IN THE PRODUCT!. A "feature" or "improvement" or "protection" that we are not told about, cannot turn off, cannot BLOCK from install is a DEFECT!

I left Chrome for this exact behavior. STOP IT!

OnThePIke - thank you. I am now able to work and have my extensions function again. Props!

more options

RichardHill said

Now in v51.0.1 changing this property "xpinstall.signatures.require" did nothing for me and jsher2000 has it right. If Mozilla wants us to upgrade then STOP PUTTING DEFECTS IN THE PRODUCT!. A "feature" or "improvement" or "protection" that we are not told about, cannot turn off, cannot BLOCK from install is a DEFECT!

The Preference that OnThePike posted about does not work on versions that are on release channel.

I would say the rather old Firefox 51.0.1 you have has actual defects compared to the current Release and more so if you add all of the vulnerabilities that have been fixed in newer versions since but not in 51.0.1

if you want to use such a old version then Fx 52.9.0esr would be much more secure.

Just because you do not like something does not make it a bug or defect.

Athraithe ag James ar

more options

Please read my post instead of reading INTO my post. I did not define a defect as something I don't like: I defined a defect as any feature addition or "protection" that does not have an OFF switch. So anyone who likes it can leave it and anyone who does not - can turn it off As for 51.0.1 - I have NO issues with it - I have NO problems and until yesterday, I am working perfectly. As to "vulnerabilities" - I will just say this: Trust no one you don't know for downloads and stay off the porn sites - My router does all of the protection I need. Most of the "vulnerabilities" that M$ uses to justify their constant rewrites and downloads of garbage require "loose" routing configs or user error/stupidity - take your choice I CHOSE to stay at 51 so that I would NOT be subject to forced defects. And I will repeat in the hopes that you will read what I write: A feature without an OFF switch is a defect, whether I like it or not .. I am just as annoyed with a great feature that cannot be turned off as I am with the forced protection that just limits what i can do and see and work with

Richard

more options

Oh - and OnThePike - I have a typo in my last congrats to you: "All of my add-ons are not working and my extensions are 'live" SHOULD READ AS "All of my add-ons are now working and my extensions are 'live".

Thanks again