X
Tap here to go to the mobile version of the site.

Fóram Tacaíochta

Firefox disabled my add-ons WHY WHY WHY !!!!

Postáilte

Just had to rewrite this post because this site inadvertently refreshed screen and lost my content!

I used Firefox 56.0.2 because I NEED to use legacy add-ons that ensure security and safety, these add-ons have no alternative in Quantum and no update. All of my other Add-ons have versions that support this edition of Firefox.

TODAY three of my important Firefox add-on were DISABLED BY FIREFOX, with no warning or caution and without my authority.

The updates were

LASTPASS UBLOCK ORIGIN GHOSTERY

I think it is extremely unlikely that these three companies unilaterally and randomly all decided to stop using the add-ons on the SAME DAY. I might have left those companies reviews expressing my concern by now that they have been disabled I can’t leave a review. So there is this fake positive picture painted of reviews on Mozilla site.

So I can only presume that it was MOZILLA FIREFOX that FORCED this on me, pitting my loyalty of one set of add-ons with another.

I am DISGUSTED by this behaviour from Mozilla, oh yes I am sure they will want to blame the add-on providers but it will be under their suggestion, rules or whatever.

I still can’t update the legacy add-ons (which still work) nor is there any alternative in Quantum.

I was quite happy in my time shell using add-ons I trusted and relied upon, that are secure in their own right, SO WHY IS MOZILLA MESSING WITH ME.

I can guess the responses will be just go ahead an upgrade Firefox, but WHY SHOULD I BE FORCED KICKING AND SCREAMING into a version of Firefox that does not meet my needs.

The bigger question is WHY WOULD I TRUST MOZILLA FIREFOX when they can mess with my productivity and give me this problem at their whim when I can choose Opera, Chrome in all of it’s variants and not have this kind of problem. They may be as bad but they have not hurt me already.

So before I go I have to ask this community if they can help me.

1. Is there a fork of the old firefox that allows the install of legacy versions of add-on, i.e. one that does not have Mozilla poking it’s nose in? 2. Is there a setting in About Config that may enable me to override this disabling of the above add-ons?

I have not listed the legacy add-ons that still work because they are clearly not the problem and I am sure that there are many thousands of users that have different legacy add-ons that face this same problem.

It was bad enough that EVERY time I used firefox I got these “your version of firefox is critically out of date” nagware messages and that even after closing them I got more nagging when I scrolled done.

It is MY computer, MY risk, MY choice, if I can’t TRUST Mozilla to let me work in peace then I really do not think I can risk using a later version of Firefox.

If anyone has any constructive advice THAT ANSWERS MY QUESTIONS ABOVE to get this working again I would appreciate it.

Just had to rewrite this post because this site inadvertently refreshed screen and lost my content! I used Firefox 56.0.2 because I NEED to use legacy add-ons that ensure security and safety, these add-ons have no alternative in Quantum and no update. All of my other Add-ons have versions that support this edition of Firefox. TODAY three of my important Firefox add-on were DISABLED BY FIREFOX, with no warning or caution and without my authority. The updates were LASTPASS UBLOCK ORIGIN GHOSTERY I think it is extremely unlikely that these three companies unilaterally and randomly all decided to stop using the add-ons on the SAME DAY. I might have left those companies reviews expressing my concern by now that they have been disabled I can’t leave a review. So there is this fake positive picture painted of reviews on Mozilla site. So I can only presume that it was MOZILLA FIREFOX that FORCED this on me, pitting my loyalty of one set of add-ons with another. I am DISGUSTED by this behaviour from Mozilla, oh yes I am sure they will want to blame the add-on providers but it will be under their suggestion, rules or whatever. I still can’t update the legacy add-ons (which still work) nor is there any alternative in Quantum. I was quite happy in my time shell using add-ons I trusted and relied upon, that are secure in their own right, SO WHY IS MOZILLA MESSING WITH ME. I can guess the responses will be just go ahead an upgrade Firefox, but WHY SHOULD I BE FORCED KICKING AND SCREAMING into a version of Firefox that does not meet my needs. The bigger question is WHY WOULD I TRUST MOZILLA FIREFOX when they can mess with my productivity and give me this problem at their whim when I can choose Opera, Chrome in all of it’s variants and not have this kind of problem. They may be as bad but they have not hurt me already. So before I go I have to ask this community if they can help me. 1. Is there a fork of the old firefox that allows the install of legacy versions of add-on, i.e. one that does not have Mozilla poking it’s nose in? 2. Is there a setting in About Config that may enable me to override this disabling of the above add-ons? I have not listed the legacy add-ons that still work because they are clearly not the problem and I am sure that there are many thousands of users that have different legacy add-ons that face this same problem. It was bad enough that EVERY time I used firefox I got these “your version of firefox is critically out of date” nagware messages and that even after closing them I got more nagging when I scrolled done. It is MY computer, MY risk, MY choice, if I can’t TRUST Mozilla to let me work in peace then I really do not think I can risk using a later version of Firefox. If anyone has any constructive advice THAT ANSWERS MY QUESTIONS ABOVE to get this working again I would appreciate it.
Luaigh

Tuilleadh mionsonraí faoin chóras

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Tuilleadh Eolais

goodwitch 10 réiteach 117 freagra

FirefoxUser72345 said

Thank you for an extremely helpful post. I am also going to look into waterfall, if I can get my add-ons working it may be a helpful way to stay in the past without all the damn nagware I get from Mozilla. If it all works perfectly I would then install Quantum and test it for certain work while I wait for add-ons to be used. If we were in a bar I would buy you a few beers. I installed the XPI file (Normandy) from earlier in thread above but it did not work, but maybe it helped that fix work. I did not even need to complete all of the functions, I did the following 1. Save the block including the BEGIN & END lines in a text file with the extension .pem (I saved mine as icfix.pem) 2. Then import the certifcate into firefox into firefox via: a. "Options", b. "Privacy & Security", c. down to "Certifcates" d. View Certifcates e. Select "Authorities" f. Import g. Select the PEM file h. Tick the checkboxes, then OK I only ticked the 3rd box for software developers. While I was copying the test to paste into Jconsole thing my plugins suddenly activated on the toolbar. I appreciate this may not be the official fix but it gets me working, if an official fix comes out for 56 I will delete and re-install after removing the certificate. then apply the official fix.

I had to restart Firefox after applying the fix to re-enable Classic Theme Restorer, all the other add-ons started working right away. It is wonderful to have the restart link under the File options once again.

Not sure what nagware you mean - I managed to get it all to stop by setting the following to False in about:config. Got all these from posts in this forum by mods so it is safe to do.

app.update.enabled app.update.auto app.update.service.enabled app.update.disable_button.showUpdateHistory extensions.shield-recipe-client.enabled extensions.shield-recipe-client.first_run

Also in - tools - options - advanced - update - set to never check for updates and unchecked - use a background service to install updates

Don't remember which one it was I changed the last time, but it stopped the green downward pointing arrow on the hamburger icon from showing up and opening the nag to update to the latest version twice a day.

Had to stop that as one day I was sending a bookmark to a folder and the update nag popped up just as I clicked on the folder and got clicked instead. Split second pop up at the wrong time! As soon as I noticed the huge update had fully downloaded I closed Firefox. Then using IE Googled to find out where that file was stored on my computer. Deleted it and the folder it was in and have not been bothered by the twice daily nags to update to the latest version since. Peace at last.

About those beers - save them for yourself when you finally manage to work nag free - that is worth a huge celebration.

''FirefoxUser72345 [[#answer-1220364|said]]'' <blockquote> Thank you for an extremely helpful post. I am also going to look into waterfall, if I can get my add-ons working it may be a helpful way to stay in the past without all the damn nagware I get from Mozilla. If it all works perfectly I would then install Quantum and test it for certain work while I wait for add-ons to be used. If we were in a bar I would buy you a few beers. I installed the XPI file (Normandy) from earlier in thread above but it did not work, but maybe it helped that fix work. I did not even need to complete all of the functions, I did the following 1. Save the block including the BEGIN & END lines in a text file with the extension .pem (I saved mine as icfix.pem) 2. Then import the certifcate into firefox into firefox via: a. "Options", b. "Privacy & Security", c. down to "Certifcates" d. View Certifcates e. Select "Authorities" f. Import g. Select the PEM file h. Tick the checkboxes, then OK I only ticked the 3rd box for software developers. While I was copying the test to paste into Jconsole thing my plugins suddenly activated on the toolbar. I appreciate this may not be the official fix but it gets me working, if an official fix comes out for 56 I will delete and re-install after removing the certificate. then apply the official fix. </blockquote> I had to restart Firefox after applying the fix to re-enable Classic Theme Restorer, all the other add-ons started working right away. It is wonderful to have the restart link under the File options once again. Not sure what nagware you mean - I managed to get it all to stop by setting the following to False in about:config. Got all these from posts in this forum by mods so it is safe to do. app.update.enabled app.update.auto app.update.service.enabled app.update.disable_button.showUpdateHistory extensions.shield-recipe-client.enabled extensions.shield-recipe-client.first_run Also in - tools - options - advanced - update - set to never check for updates and unchecked - use a background service to install updates Don't remember which one it was I changed the last time, but it stopped the green downward pointing arrow on the hamburger icon from showing up and opening the nag to update to the latest version twice a day. Had to stop that as one day I was sending a bookmark to a folder and the update nag popped up just as I clicked on the folder and got clicked instead. Split second pop up at the wrong time! As soon as I noticed the huge update had fully downloaded I closed Firefox. Then using IE Googled to find out where that file was stored on my computer. Deleted it and the folder it was in and have not been bothered by the twice daily nags to update to the latest version since. Peace at last. About those beers - save them for yourself when you finally manage to work nag free - that is worth a huge celebration.
An bhfuil an freagra seo cabhrach?
Luaigh
Pj 42 réiteach 869 freagra

FirefoxUser72345 said

I used Firefox 56.0.2 because I NEED to use legacy add-ons that ensure security and safety, these add-ons have no alternative in Quantum and no update. All of my other Add-ons have versions that support this edition of Firefox. TODAY three of my important Firefox add-on were DISABLED BY FIREFOX, with no warning or caution ...


Additional Info: From Mozilla Blog:


Updates – Last Updated: 19:28 EDT May 8 2019

We’ve released Firefox 66.0.5 for Desktop and Android, and Firefox ESR 60.6.3, which include the permanent fix for re-enabling add-ons that were disabled starting on May 3rd. The initial, temporary fix that was deployed May 4th through the Studies system is replaced by these updates, and we recommend updating as soon as possible. Users who enabled Studies to receive the temporary fix, and have updated to the permanent fix, can now disable Studies if they desire.

For users who cannot update to the latest version of Firefox or Firefox ESR, we plan to distribute an update that automatically applies the fix to versions 52 through 60. This fix will also be available as a user-installable extension. For anyone still experiencing issues in versions 61 through 65, we plan to distribute a fix through a user-installable extension. These extensions will not require users to enable Studies, and we’ll provide an update when they are available.



"Updates – Last Updated: 11:51 EDT May 8 2019

Firefox 66.0.5 has been released, and we recommend that people update to that version if they continue to experience problems with extensions being disabled. You’ll get an update notification within 24 hours, or you can initiate an update manually.
An update to ESR 60.6.3 is also available as of May 8th. We’re continuing to work on a fix for older versions of Firefox, and will update this post and on social media as we have more information."



~Pj

''FirefoxUser72345 [[#question-1258357|said]]'' <blockquote> I used Firefox 56.0.2 because I NEED to use legacy add-ons that ensure security and safety, these add-ons have no alternative in Quantum and no update. All of my other Add-ons have versions that support this edition of Firefox. TODAY three of my important Firefox add-on were DISABLED BY FIREFOX, with no warning or caution ... </blockquote> Additional Info: '''[https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/ From Mozilla Blog]''': Updates – Last Updated: 19:28 EDT May 8 2019 <B>We’ve released Firefox 66.0.5 for Desktop and Android, and Firefox ESR 60.6.3, which include the permanent fix for re-enabling add-ons that were disabled starting on May 3rd. The initial, temporary fix that was deployed May 4th through the Studies system is replaced by these updates, and we recommend updating as soon as possible. Users who enabled Studies to receive the temporary fix, and have updated to the permanent fix, can now disable Studies if they desire.<Br><Br> For users who cannot update to the latest version of Firefox or Firefox ESR, we plan to distribute an update that automatically applies the fix to versions 52 through 60. This fix will also be available as a user-installable extension. For anyone still experiencing issues in versions 61 through 65, we plan to distribute a fix through a user-installable extension. These extensions will not require users to enable Studies, and we’ll provide an update when they are available.</B> <Hr> "Updates – Last Updated: 11:51 EDT May 8 2019 <B>Firefox 66.0.5 has been released, and we recommend that people update to that version if they continue to experience problems with extensions being disabled. You’ll get an update notification within 24 hours, or you can initiate an update manually. <Br> An update to ESR 60.6.3 is also available as of May 8th. We’re continuing to work on a fix for older versions of Firefox, and will update this post and on social media as we have more information." </B><Br><Br><Br> ~Pj
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.