Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Dúnadh an snáithe seo agus cuireadh sa chartlann é. Cuir ceist nua má tá cabhair uait.

all my addons just got disabled

  • 28 freagra
  • 5 leis an bhfadhb seo
  • 148 views
  • Freagra is déanaí ó nigeld

more options

all my addons just got disabled

[Profanity removed by moderator. Please read Mozilla Support rules and guidelines, thanks.]

Athraithe ag Chris Ilias ar

All Replies (20)

more options

I don't think forum volunteers yet know the cause or remedy for this problem. However, know that dozens of people are reporting the same thing in recent hours, so it may be due to a rolling update gone wrong.

more options

Just some additional details, I'm using FF 52 on Windows 7 Pro.

And please, give us a resolution. If you're going to say "this was done for your own good", please include a download link for Chrome.

more options

Sorry, the Add-ons team is working on a fix for this. A critical certificate expired (which obviously should not happen). Official updates are expected to be posted here:

https://discourse.mozilla.org/t/certificate-issue-causing-add-ons-to-be-disabled-or-fail-to-install/39047

Currently, the only workaround is to set your system clock back (for example, if your date is May 3, set to May 2; if your date is May 4, set to May 3). You might have to reinstall extensions after that, or maybe Firefox will detect the difference at your next shut down/restart. Changing the date may have other consequences, so this option isn't ideal.

more options

AARRGGHHH said

Just some additional details, I'm using FF 52 on Windows 7 Pro. And please, give us a resolution. If you're going to say "this was done for your own good", please include a download link for Chrome.

This must be global (As in all versions)? I was using the ESR release 60.6.1 but all addons got disabled. I won't be using Firefox at all until this gets fixed. though, I really don't want to have to change browsers

Athraithe ag Tanyac ar

more options

Tanyac said

This must be global (As in all versions)? I was using the ESR release 60.6.1 but all addons got disabled.

Yes, a critical certificate expired somewhere in the Add-ons infrastructure. All versions of Firefox are affected.

more options

Just an FYI, date reset did not work here. :(

more options

AARRGGHHH said

Just an FYI, date reset did not work here. :(

Thanks for checking that. What if you next trigger an extension update on the Add-ons page? Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then on the right side, find a button with an icon of a gear / sprocket / wheel on it. Click that, then "Check for Updates". Any action?

more options

I don't see any with a gear, sprocket, or wheel, I'm guessing none need an update. I tried turning update off and back on for a couple individual add-ons, but no luck.

BTW, some are now working. Examples:

Active Stop Button Colorful Tabs Image Context Menu

Others (many) are quite dead

Flash Video Downloader Google Reverse Image Search Image Downloader

Not really seeing any rhyme or reason as to what works and what doesn't, I would guess the certificate to which it links.

Oh the humanity ... But in all seriousness, it is quite frustrating to have only a semi-conscious browser.

Athraithe ag AARRGGHHH ar

more options

Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

  1. Go to [=] > Options > Privacy & Security.
  2. Make sure Allow Firefox to install and run studies is check marked.

I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

They are working on a general fix that doesn't need to rely on this and will keep you updated.

more options

I lost all of my addons overnight. Here's the list:

YouTube Adblock uBlock Origin TrackMeNot Smart Referer Privacy Possum Privacy Badger Norton Safe Web HTTPS Everywhere Google Analytics Blocker Decentraleyes CanvasBlocker

more options

I do believe that you've lost your minds; does anyone test these "improvements" before you do a wholesale slaughter of your user base?

Try not to be so "helpful"...

more options

Hi TheSageCottage and roflz, this wasn't intentional. A critical certificate expired (which obviously should not happen), preventing many extensions from being used, updated, or installed.

Over the next few hours, your Firefox should automatically get a patch for this problem through the "studies" feature. For most users, studies are automatically enabled, but you can check on the Options/Preferences page as follows:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type stud and Firefox should filter to the "Firefox Data Collection and Use" section. Here, make sure you have a check in the box for "Allow Firefox to install and run studies". (First screenshot attached.) If you prefer to turn it back off after the patch comes through, that's fine.

So far, I have received two studies related to this, which you can see if you click the View Firefox studies link next to the above preference (or paste about:studies into the address bar and press Enter to load it). (Second screenshot attached.)

If you receive the patches and your extensions remain disabled, check whether they now show an Enable button.

more options

roflz said

I do believe that you've lost your minds; does anyone test these "improvements" before you do a wholesale slaughter of your user base? Try not to be so "helpful"...

Well said. They're getting like Microsoft. Each release contains more "helpful" features that make it worse than the previous.

more options

Chris Ilias said

Mozilla has rolled-out a fix for this...

This is exactly what I was afraid would happen. I use FF 52.0.2 64-bit. It has no "Studies" option. Thus, the fix is useless to those of us with older browsers. AND NO, I AM NOT UPGRADING.

I've been reluctantly expecting "we did it for your own good" aka "STFU and swallow". And that is exactly what I will hear if you wont fix it for older browsers.

more options

See:

more options

The "fix" of enabling Studies does not work for me - it was already enabled. The "fix" of changing the date also does not work. Can someone please tell me why some users have found the patch to work and others haven't? My browser was working fine yesterday and the day beefore but disabled the extensions/add ons this morning. When will there be a fix to this please?

more options

nigeld said

When will there be a fix to this please?

Hello nigeld,

Would you please read this :

https://blog.mozilla.org/addons/2019/05/04/update-regarding-add-ons-in-firefox/

(sorry for the inconvenience; this annoying issue was caused by an unforeseen technical problem …..)

more options

Thank you McCoy - I had already read that - I was hoping for a more up to date situation report. I must be one of the people who have studies enabled, all the patches in place and have got the bug that is being worked on. The funny thing is that my problem only started this morning, my PC has been fine for both yesterday and the day before.

more options

Install this "hot-fix" extension to get the fix that Mozilla has done.

It just worked form me with Firefox 66.0.3 .

more options

I looked at that and got the message, "Firefox prevented this site from asking you to install software on your computer" (or something similar.....)

I also have 66.0.3

  1. 1
  2. 2