X
Tap here to go to the mobile version of the site.
An updated version of Firefox is available to address the issues with Add-ons disabled or fail to install on Firefox. You can download the update for your OS here: https://www.mozilla.org/firefox/new/ For Known Issues and Workarounds, please check out the update at https://support.mozilla.org/kb/add-ons-disabled-or-fail-to-install-firefox

Fóram Tacaíochta

Stopping Autoplay audio fails on follow-on video

Postáilte

The "Block websites from automatically playing sound" is great, but it fails if the stream of video is more than 1 deep.

See this site as an example: https://www.wfla.com/news/hillsborough-county/hillsborough-homeowner-shoots-intruder-suspects-on-the-run/1949904348

The first video plays silently. But subsequent videos play with sound active. (I'm not 100% sure it was the 2nd video, because the tab was open in the background while I was looking at email. A few minutes, not hours.) I don't think this works as intended.

Note: these are mostly news sites, and if I use something like Google that doesn't open everything in a new window, I can mute the tab in question. Bing News opens everything in new tabs.

I like this feature. I would prefer that the video not autoplay at all, but muted is better than nothing. I would like this feature a lot more if it worked.

The "Block websites from automatically playing sound" is great, but it fails if the stream of video is more than 1 deep. See this site as an example: https://www.wfla.com/news/hillsborough-county/hillsborough-homeowner-shoots-intruder-suspects-on-the-run/1949904348 The first video plays silently. But subsequent videos play with sound active. (I'm not 100% sure it was the 2nd video, because the tab was open in the background while I was looking at email. A few minutes, not hours.) I don't think this works as intended. Note: these are mostly news sites, and if I use something like Google that doesn't open everything in a new window, I can mute the tab in question. Bing News opens everything in new tabs. I like this feature. I would prefer that the video not autoplay at all, but muted is better than nothing. I would like this feature a lot more if it worked.
Attached screenshots
Luaigh

Tuilleadh mionsonraí faoin chóras

Breiseáin Shuiteáilte

  • Shockwave Flash 32.0 r0 (Ask to run)

uBlock Origin Privacy Badger https everywhere Cookie AutoDelete (deletes cookies 21 seconds after I close a tab)

Feidhmchlár

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:66.0) Gecko/20100101 Firefox/66.0

Tuilleadh Eolais

FitAintBrkDntFxIt 0 réiteach 5 freagra

I don't know if this info will help, but I discovered by sheer accident that the same setting affected videos on YouTube now.

About the end of March, I posted in the YouTube community that the Autoplay button was suddenly missing - I always turn autoplay off. If you happen not to be familiar with it, you can leave it on and just let YT throw whatever vid at you that comes up, or you can stop YT from automatically playing the next up vid.

Two or three days after the Autoplay button went missing, I starting having to manually start every YT vid I wanted to watch. I dealt with that for about two weeks, until one day I was in Settings and spotted the checkmark in "Block websites from automatically playing sound." I guess at some point in the past I might have chosen this setting, as I know that quite often I found I had to manually turn sound on on various websites, but it never affected YouTube. I removed the checkmark and YT vids returned to playing automatically.

I had trouble updating/upgrading FF the end of December. At the end of January I downloaded the latest FF, but did not install it until about 01 April. This coincides with when I had to begin manually starting videos in YouTube. I was on version 66.0.2 before reading your post. FF has been bugging me lately to update/upgrade to 66.0.3, so after reading your post I allowed the update. I then went into settings and put the checkmark back in "Block websites from automatcally playing sound," and when I went to YouTube to play a vid, the vid played automatically.

If you are not on version 66.0.3, perhaps updating/upgrading will fix the issue you are currently experiencing. I know the two scenarios differ...but it might be worth a try. And for what it's worth, updating/upgrading is not always my first choice or "go to" solution. But in this case.... ??

I don't know if this info will help, but I discovered by sheer accident that the same setting affected videos on YouTube now. About the end of March, I posted in the YouTube community that the Autoplay button was suddenly missing - I always turn autoplay off. If you happen not to be familiar with it, you can leave it on and just let YT throw whatever vid at you that comes up, or you can stop YT from automatically playing the next up vid. Two or three days after the Autoplay button went missing, I starting having to manually start every YT vid I wanted to watch. I dealt with that for about two weeks, until one day I was in Settings and spotted the checkmark in "Block websites from automatically playing sound." I guess at some point in the past I might have chosen this setting, as I know that quite often I found I had to manually turn sound on on various websites, but it never affected YouTube. I removed the checkmark and YT vids returned to playing automatically. I had trouble updating/upgrading FF the end of December. At the end of January I downloaded the latest FF, but did not install it until about 01 April. This coincides with when I had to begin manually starting videos in YouTube. I was on version 66.0.2 before reading your post. FF has been bugging me lately to update/upgrade to 66.0.3, so after reading your post I allowed the update. I then went into settings and put the checkmark back in "Block websites from automatcally playing sound," and when I went to YouTube to play a vid, the vid played automatically. If you are not on version 66.0.3, perhaps updating/upgrading will fix the issue you are currently experiencing. I know the two scenarios differ...but it might be worth a try. And for what it's worth, updating/upgrading is not always my first choice or "go to" solution. But in this case.... ??
An bhfuil an freagra seo cabhrach?
Luaigh
FitAintBrkDntFxIt 0 réiteach 5 freagra

Okay, my friend. I had to step away from my PC and in my absence, Windows 10 decided it had had enough, and promptly [apparently] crashed. Not the first time. But that's another story.

After getting booted back up, I returned to YouTube where I wanted to look for a tutorial-like vid. I had to manually start the video... so my attempt to help above is not just worthless, but absolutely worthless. I've had to go back into settings and once again remove the checkmark from "Block websites from automatically playing sound." Not sure how the two (audio vs video play) are related, but for whatever reason, in these latest versions of FF... they are.

My apologies.

Okay, my friend. I had to step away from my PC and in my absence, Windows 10 decided it had had enough, and promptly [apparently] crashed. Not the first time. But that's another story. After getting booted back up, I returned to YouTube where I wanted to look for a tutorial-like vid. I had to manually start the video... so my attempt to help above is not just worthless, but absolutely worthless. I've had to go back into settings and once again remove the checkmark from "Block websites from automatically playing '''sound.'''" Not sure how the two (audio vs video play) are related, but for whatever reason, in these latest versions of FF... they are. My apologies.
An bhfuil an freagra seo cabhrach?
Luaigh
cor-el
  • Top 10 Contributor
  • Moderator
17085 réiteach 154305 freagra

You can look at these prefs on the about:config page to see if these values work for you.

  • media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt]
  • media.autoplay.allow-muted = false
  • media.autoplay.enabled.user-gestures-needed = false

For user-gestures-needed you can try false and true to see what works for you.

You can look at this extension.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

You can look at these prefs on the about:config page to see if these values work for you. *media.autoplay.default = 1 [0=Allowed, 1=Blocked, 2=Prompt] *media.autoplay.allow-muted = false *media.autoplay.enabled.user-gestures-needed = false For user-gestures-needed you can try false and true to see what works for you. You can look at this extension. *Disable HTML5 Autoplay https://addons.mozilla.org/firefox/addon/disable-autoplay/ You can open the <b>about:config</b> page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue. *http://kb.mozillazine.org/about:config
An bhfuil an freagra seo cabhrach?
Luaigh
Cuir ceist

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.