Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Picture-in-picture

  • 9 bhfreagra
  • 2 leis an bhfadhb seo
  • 481 views
  • Freagra is déanaí ó McCoy

more options

Problem on screenshot. How to DISABLE or REMOVE this picture-in-picture??? Sorry if this is not Firefox update.

Réiteach roghnaithe

ArcherX said

Yeah, thanks, I tried to disable all those options but no luck.

Hello ArcherX,

Probably a rhetorical question, but after you changed the values of those prefs, did you then close and restart Firefox in order for the change(s) to take effect  ?

Read this answer in context 👍 1

All Replies (9)

more options

Screenshot here. It didn't uploaded in first try.

more options

Nightly! So fun! Note that I do not have Nightly, so I can't test this myself.

Try these preferences and see what combination does what you want, or whether we need to look for some others:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste pict and pause while the list is filtered

I think this is for the toggle control:

(3) Double-click the media.videocontrols.picture-in-picture.video-toggle.enabled preference to switch the value from true to false

I think this is for all PIP functionality:

(4) Double-click the media.videocontrols.picture-in-picture.enabled preference to switch the value from true to false

more options

Apparently PiP is only enabled on Windows.

#if defined(NIGHTLY_BUILD) && defined(XP_WIN)
pref("media.videocontrols.picture-in-picture.enabled", true);
pref("media.videocontrols.picture-in-picture.video-toggle.enabled", true);
#else
pref("media.videocontrols.picture-in-picture.enabled", false);
pref("media.videocontrols.picture-in-picture.video-toggle.enabled", false);
#endif
pref("media.videocontrols.picture-in-picture.video-toggle.flyout-enabled", false);
pref("media.videocontrols.picture-in-picture.video-toggle.flyout-wait-ms", 5000);
more options

Yeah, thanks, I tried to disable all those options but no luck.

more options

Réiteach Roghnaithe

ArcherX said

Yeah, thanks, I tried to disable all those options but no luck.

Hello ArcherX,

Probably a rhetorical question, but after you changed the values of those prefs, did you then close and restart Firefox in order for the change(s) to take effect  ?

more options

McCoy said

ArcherX said
Yeah, thanks, I tried to disable all those options but no luck.

Hello ArcherX,

Probably a rhetorical question, but after you changed the values of those prefs, did you then close and restart Firefox in order for the change(s) to take effect  ?

Closed... cleared cache and restarted - now it's working, thanks!

more options

ArcherX said

Closed... cleared cache and restarted - now it's working, thanks!

Well done - have a nice weekend  !

more options

jscher2000 said

Nightly! So fun! Note that I do not have Nightly, so I can't test this myself. Try these preferences and see what combination does what you want, or whether we need to look for some others: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk. (2) In the search box above the list, type or paste pict and pause while the list is filtered I think this is for the toggle control: (3) Double-click the media.videocontrols.picture-in-picture.video-toggle.enabled preference to switch the value from true to false I think this is for all PIP functionality: (4) Double-click the media.videocontrols.picture-in-picture.enabled preference to switch the value from true to false

i have 67.0.1 and this PiP is enabled. checking about:config doesn't show "'media.videocontrols.picture-in-picture.enabled".

how to disable PiP then?

more options

@ badbanana :

I just posted in your own thread :

https://support.mozilla.org/en-US/questions/1261415