Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Kaspersky now gone after I uninstalled and re-installed Firefox

  • 6 fhreagra
  • 1 leis an bhfadhb seo
  • 63 views
  • Freagra is déanaí ó airider

more options

I have been using Firefox Quantum 66.0.2 (64 bit) with Kaspersky for years but today Firefox kept having problems so I uninstalled and then re-installed it. Now the KIS URL Advisors show up when I do a Google search using Firefox, but it does not show up at the top of Firefox, where the Ad Blocker still does

Before I uninstalled Firefox today, Kaspersky WAS showing as an enabled add-on, but now is not on the Firefox list of allowed add-ons. I tried adding Kaspersky Protection directly from the download file, and then again from a NEWLY downloaded file, but both times Firefox wrote that the file was "corrupted". BOTH new and old?

Even System Restore to several earlier dates now won't show Kaspersky Protection in Firefox!

But it is still in Chrome, which is only used as an emergency backup, as I use Firefox as my browser!

Please help ....


attachements:

1. KIS URL Advisor icon used to be to the right of the History clock icon in Firefox (up till a few hours ago!)

2. KIS URL Advisor icon is STILL working in Chrome!

3. KIS URL Advisor icon is working and showing in Firefox Google search!

Attached screenshots

All Replies (6)

more options

Could you check whether it is among the available icons on the Customize tab? This article will get you to that page:

Customize Firefox controls, buttons and toolbars

If it's not there, could you check the extension's Options in case something needs to be turned on there. Pull up the Add-ons page using either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions.

Then find that extension on the right side and click its Options button. Anything?

more options

You might also check with Kaspersky support. I'm having difficulty tracking this down on their site.

more options

Thanks, but of course I checked ALL of that many hours ago. Kaspersky IS working through Firefox when I use Firefox for Google searches, And of course it is working in Chrome.

I happen to like Firefox but now I don't trust it. The problem lies with Firefox, NIOT Kapspersky, or maybe the Chrome programmers are just smarter and more diligent!

more options

I think it is extremely SIGNIFICANT that Firefox claims that the Kaspsesky file is "corrupted". Chrome doesn't think so and neither does Goggle (the software in each must be slightly different, as one is a browser and the other a search engine()

more options

If the Kaspersky extension is not installed, but you have Kaspersky markers in your Google results, that may be a result of using the HTTPS scanning feature in Kaspersky.

Is there a feature within Kaspersky to set up browsers? That may be a better way to install the extension than via download.

Also, if you haven't restarted Windows since you reinstalled Firefox, you might want to try that, to completing any deferred updates and allow Kaspersky to do its startup check for new software.

more options

Thank you for your thoughtful help and suggestions .....

However it is now FIXED! Re-installed KIS 19

Either it was in fact corrupted as indicated or in the interim made compatible by Kaspersky with new Firefox version

Athraithe ag airider ar