Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Application window misrendered on macOS Mojave

  • 3 fhreagra
  • 1 leis an bhfadhb seo
  • Freagra is déanaí ó Mozziztance

more options

Hi. I'll try to keep this brief.

After reverting a macOS defaults command back to standard ( defaults write -g NSRequiresAquaSystemAppearance -bool No ) so that I can use the normal Mojave dark mode instead of the pre-Mojave dark mode, Firefox started displaying blank, light mode styled, context menus.

I tried all the recommended troubleshooting steps and eventually deleted all traces of Firefox, including Application Support and org.mozilla preference files. I then re-installed Firefox via a fresh download. However, the entire application is unusable, as if the OS is just not rendering the application properly.

I've uploaded a short video to demonstrate:

Firefox works normally in a new user account I created just to test it so there is something user space level going on but I'd like to know what it could be and maybe a Moz developer would find it useful to know as well.

All Replies (3)

more options

I tried that on Window 10 but don't see that box your showing so what addons do you have installed?

more options

It's a very peculiar issue that is only occurring under a single user account on my Mac.

The issue was not resolved even when doing a full reset of Mozilla, deleting all of its data and re-installing it.

I've since migrated my data into another user account but for now that broken account is still there in case a developer would like for me to run any tests that might be useful to them.

more options


The problem is triggered by the hybrid dark mode hack or rather in how Firefox appears to be handling its presence.

The way online stories say to disable the hack is to revert it by using the command:

defaults write -g NSRequiresAquaSystemAppearance -bool No

One commentor, however, discovered that the solution was to delete the key entirely:

defaults delete -g NSRequiresAquaSystemAppearance

I've confirmed in my broken user account that deleting the key successfully repaired Firefox.