Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

There are no page margin settings in Page Setup when printing

  • 5 fhreagra
  • 1 leis an bhfadhb seo
  • 69 views
  • Freagra is déanaí ó jscher2000

more options

I am using Ubuntu 18.04 LTS 32 Bit. It came with a per-installed Firefox browser which updated itself to version 66. When I want to print something the page setup button does not provide options to set the page margins. Hence the margins are permanently set to one inch on all sides. I sometimes need to print documents which need extremely small margins, e.g., 0.2 inches on all sides. The only options available in the Page Setup dialogue box are: Format For, Paper Size, and Orientation. On the other hand, clicking the Print button provides several tabs, including one named 'Page Setup', but this one does not provide margin settings either. Another tab here named 'Options' provides the options to leave the header and footer blank but no options of setting the margins. Any help would be welcome. Thank you.

All Replies (5)

more options

That is based off the printer installed software that the browser takes it queues for print formatting.

more options

I'm always surprised by the ways that printing is different between Windows, Mac, and Linux.

On Windows, there are two tabs in the Page Setup dialog (screenshot attached). Your Firefox doesn't have that second tab? What I don't know is whether that is common to Linux builds or could be specific to the one included with your distribution. (Those are sometimes customized.)

If all else fails, you can set margins manually this way:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful or accepting the risk.

(2) In the search box above the list, type or paste print_mar and pause while the list is filtered

(3) Double-click the print.printer_printername.print_margin_bottom preference to display a dialog where you can edit the bottom margin width, then click OK (example screenshot attached).

Then repeat with the left, right, and top margins.

As a U.S. user, my margins are in inches, but in other locales, the margins might be in millimeters. I wouldn't worry about the extra digits.

Athraithe ag jscher2000 ar

more options

File -> Print (Ctrl+P) should have an Options tab where you can set the margins.

more options

jscher2000 [[#answer-1208464| Thank you jscher2000 for your help. I did go to about:config and there were page margin settings there which I modified. There were just four margin settings there for the fours sides. They did not include the (quote) 'print.printer_printername.print_margin_bottom' setting'. More bugs are showing up as I type this reply. For example, (a) clicking the italics button above this editor does not change the text to italics but instead begins inserting inverted commas. (b) I cannot upload files in emails. But, coming back to this discussion, no, there is no second tab in the Page Setup window. In fact, it is doesn't even look like the image you have uploaded.

more options

Yes, your Firefox is definitely different from the Windows version.

Did the about:config change work? Did it stick?

On this board, you italicize text by putting two ' before it and two ' after it. Bold uses three ' before and three ' after. Use the Preview Reply button to confirm that the codes will work.

Please start a new thread about the email attachment problem.