Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

youtube not loading in firefox 65

  • 19 freagra
  • 1 leis an bhfadhb seo
  • 23 views
  • Freagra is déanaí ó sortmyit

more options

Hi

All other borowsers load youtube but not firefox it hangs on loading youtube on red like above at quarter fill and the buffering ring keeps en-circling like a shark. It has occured since update to Firefox version 65.0.2 on 64bit. Please fix this and kindly get back to me. I checked my router, dns, ethernet adapter etc. and all my pc's have this issue since this version of firefox came out. I am throughly fed up. Please get back to me asap. I am not a noob and have exhausted all possible troubleshooting steps. Refreshed firefox, reinstalled it after removing it with proper scrubbing software, checked the about:config everything I can possibly think of and even scoured the forums. I just spent 4 hours of my life trying to fix this and even did a previous windows backup restore to no avail.

Réiteach roghnaithe

Hi thanks for all your suggestions and help, I was incredibly frustrated on this hence my emotions were a bit out of order. I feel I should not have doubted your competency. The issue seems to have been resolved on the latest stable release. Bye problem is solved as far as I can see.

Read this answer in context 👍 0

All Replies (19)

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

Hi

As. said I am not a noob, used ccleaner + ccenhancer and cleaned cookies and rest, refreshed firefox, ran safe mode (addons disabled), disabled hardware aceleration gpu, restored old profile from backup when youtube was working, tried using recomended performance and tried chaingng from default to 7/ threads and many more. Still no joy so Firefox issue under the hood problem fix the issue and get back to me please.

more options

Does it make any difference whether you are logged into your Google account? As a test, you can launch a YouTube video link in a private window where you should not be logged in.

more options

Nope still have problems. See image attached.

more options

Hmm, the red line just stalls out...

What is the red toolbar icon with the 3 white dots?

Could you try this extension (unfortunately, I don't think it supports Dark mode): https://addons.mozilla.org/firefox/addon/youtube-classic/

more options

Hi again its lastpass addon the red one with 3 dots, & already tried the classic version of youtube with the addon you sent. It keeps reloading the youtube website every second before I can click any video, another headache so I had ended up removing the youtube classic addon. Before you say I had also removed the youtube dark addon and tested it.

more options

sortmyit said

... already tried the classic version of youtube with the addon you sent. It keeps reloading the youtube website every second before I can click any video, another headache so I had ended up removing the youtube classic addon.

Hmm, there was a problem like that with the YouTube High Definition extension, but I haven't heard of any reports of incessant reloading with Classic.

more options

Hi been busy, sorry for late reply. Don't have youtube high defenition extention installed. Checked DNS settings as well and no change.

more options

Youtube still has delays and gets stuck. There is a white bar on top of firefox showing `non responding` for a few seconds untill it continues loading again.

more options

Installed Firefox Nightly 67.0.a1, it automatically engaged with new profile. Synced with my firefox account by signing in which was previously being used on the stable build which was the one with problems i.e. 65.0.2 Firefox. Nightly downloaded and synced with addons etc.

On nightly youtube works splendidly and as supposed with or without addons and with or without sync. Therefore not an addon problem here.

Then I took the nightly profile and dropped it on the Firefox stable and stable still had problems with youtube. So ruling out everything else seem to be a problem with firefox stable buld code and nothing else. Fresh install of Firefox Stable build has the same problem so does refresh as I mentioned before. Please fix it I am sure others have the same problem.

more options

Hi sortmyit, Firefox 66 is due out March 19th, so perhaps you'll have better luck then. If you want to test it now, you can install the Developer Edition, which should coexist alongside regular Firefox, using a separate profile.

https://www.mozilla.org/firefox/developer/all/

more options

Ahhrrrr!!!!. I am frustrated the developer version also has the problem only the nightly has the problem resolved. Do something anything

more options

Could you experiment with renaming one of the exe files:

  • C:\Program Files\Mozilla Firefox\firefox.exe
  • C:\Program Files\Firefox Developer Edition\firefox.exe
    (I can't remember if this is the default folder name or a name I created?)

Change the name to firefox1.exe and see whether that changes anything.

more options

Nope fed up already, fix it when next one is out and no need to get back to me.

more options

Just to be clear, support forum volunteers do not "fix" Firefox, and more information would be needed to determine why YouTube is not working on your Firefox. But anyway, feel free to post again if it doesn't work after the next update.

more options

Oh I see, so you are a volunteer, no wonder heavy technical troubleshooting steps weren’t suggested

more options

sortmyit said

Oh I see, so you are a volunteer, no wonder heavy technical troubleshooting steps weren’t suggested

My suggestions vary depending on what the poster already tried, and their tolerance for experimentation. If you want to compare the Web Console on release vs. Nightly to see whether there are different messages when you load YouTube on the two browsers, that might yield something.

You can open the Web Console in the lower part of the tab using either:

  • "3-bar" menu button > Web Developer > Web Console
  • (menu bar) Tools > Web Developer > Web Console
  • (Windows) Ctrl+Shift+k

Then load YouTube in the upper part of the tab and watch for error or security messages. (The lines with blue triangles indicating a style rule warning generally are not significant unless you suspect a style rule problem.)

more options
more options

Réiteach Roghnaithe

Hi thanks for all your suggestions and help, I was incredibly frustrated on this hence my emotions were a bit out of order. I feel I should not have doubted your competency. The issue seems to have been resolved on the latest stable release. Bye problem is solved as far as I can see.