Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

Firefox crashing at startup - mac

  • 12 freagra
  • 1 leis an bhfadhb seo
  • Freagra is déanaí ó FlyverLars

more options

Whenever i open firefox it immediately crashed. This also happens in safe mode. Heres the crash report detail:

AdapterDeviceID: 0x5926 AdapterVendorID: 0x8086 BuildID: 20181203164059 ContentSandboxCapable: 1 ContentSandboxLevel: 3 CrashTime: 1546650225 DOMIPCEnabled: 1 FramePoisonBase: 9223372036600930304 FramePoisonSize: 4096 InstallTime: 1546649593 MozCrashReason: MOZ_CRASH(Using observer service off the main thread!) Notes: AdapterVendorID: 0x8086, AdapterDeviceID: 0x5926FP(D00-L1000-W00000000-T010) WR? WR- OMTP? OMTP+1 GL Layers? GL Context? GL Context+ GL Layers+ ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384} ProductName: Firefox ReleaseChannel: esr SafeMode: 0 SecondsSinceLastCrash: 283 StartupCrash: 0 StartupTime: 1546650224 TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20181203164059","version":"60.4.0","vendor":"Mozilla","platformVersion":"60.4.0","xpcomAbi":"x86_64-gcc3","updaterAvailable":true},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":8192,"virtualMaxMB":null,"cpu":{"count":4,"cores":2,"vendor":"GenuineIntel","family":6,"model":142,"stepping":9,"l2cacheKB":256,"l3cacheKB":4096,"speedMHz":2300,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1","hasSSE4_2","hasAVX","hasAVX2","hasAES"]},"os":{"name":"Darwin","version":"18.2.0","locale":"en-DK"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"ContentBackend":"Skia","adapters":[{"description":null,"vendorID":"0x8086","deviceID":"0x5926","subsysID":null,"RAM":null,"driver":null,"driverVersion":null,"driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":1680,"screenHeight":1050,"scale":2}],"features":{"compositor":"none","gpuProcess":{"status":"unused"}}},"appleModelId":"MacBookPro14,1"},"settings":{"blocklistEnabled":true,"e10sEnabled":true,"e10sMultiProcesses":4,"telemetryEnabled":false,"locale":"en-US","update":{"channel":"esr","enabled":true,"autoDownload":true},"userPrefs":{"":false},"sandbox":{"effectiveContentProcessLevel":3},"addonCompatibilityCheckEnabled":true,"isDefaultBrowser":null},"profile":{}} TextureUsage: 70778880 ThreadIdNameMapping: 7:"Gecko_IOThread",8:"Timer",9:"Socket Thread",10:"JS Watchdog",16:"BGReadURLs",17:"Hang Monitor",18:"Cache2 I/O",19:"Cookie",20:"StreamTrans #1",21:"GMPThread",22:"Compositor",23:"VRListener",24:"ImgDecoder #1",25:"ImageIO",26:"IPDL Background",28:"ImageBridgeChild",31:"DOM Worker",36:"ProcessHangMon", Throttleable: 1 UptimeTS: 1.10311746 Vendor: Mozilla Version: 60.4.0 useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.

All Replies (12)

more options

I should probably add that i have tried reinstalling, removing all files related to firefox (that i could find), restarting the computer, and installing the alpha version.

more options

If you can't get Firefox to open, you will have to do this the hard way. Open the file browser/explorer on your computer. Note: You may have to enable Show Hidden Folders / Files. Enter this in the address bar;

Windows: %APPDATA%\Mozilla\Firefox\Crash Reports\submitted Win 7/Vista: C:\Users\<username>\AppData\Roaming\Mozilla\Firefox\Crash Reports\submitted Win XP/2000: C:\Documents and Settings\<username>\Application Data\Mozilla\Firefox\Crash Reports\submitted

Mac OS: /Users/<username>/Library/Application Support/Firefox/Crash Reports/submitted Linux: /home/<username>/.mozilla/firefox/Crash Reports/submitted

The crash report is several pages of data. We need the report numbers to see the whole report.

Copy the most recent 5-7 File Names in the folder. Post the information in the reply box.

more options

Crash ID: bp-5c4303a8-e9a1-4279-8c96-bdf090190105 Crash ID: bp-6c32301c-b4f0-45d0-9f93-7f6bb0190105 Crash ID: bp-34feb7c8-eb1e-4bfa-be82-b69020190105 Crash ID: bp-39c16419-47b9-4dcc-8384-c23350190105 Crash ID: bp-500121e9-716c-4b91-8a37-d21930190105

more options

Product Firefox Release Channel esr Version 60.4.0esr Build ID 20181203164059 OS OS X 10.14 OS Version 10.14.2 18C54

bp-5c4303a8-e9a1-4279-8c96-bdf090190105 bp-6c32301c-b4f0-45d0-9f93-7f6bb0190105 bp-34feb7c8-eb1e-4bfa-be82-b69020190105

Signature: nsObserverService::NotifyObservers

MOZ_CRASH Reason (Sanitized) MOZ_CRASH(Using observer service off the main thread!)


This is for Sumo's Related Bugs 1425898 RESOLVED FIXED Crash in nsObserverService::NotifyObservers

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

more options

No difference in safe mode; still crashes immediately.

more options

We have seen crashes reported caused by a fbplugin (Facebook photo uploader) in the "Internet Plug-Ins" folder, so you can check if you have this component.

more options

There's nothing in ~/Library/Internet Plug-Ins/

more options

And in the global Library folder?

  • /Library/Internet Plug-Ins
more options

There are some plugins in there, but no fbplugin. I've attached a photo of /Library/Internet Plug-Ins.

Athraithe ag FlyverLars ar

more options

OK, so there isn't a fbplugin.

You can check for issues caused by Firefox hardware acceleration.

Try to start Firefox in Safe Mode to see if that works.

  • Mac: hold down the Options key while starting Firefox
  • Windows: hold down the Shift key while starting Firefox

You can also check in Font Book for issues with fonts.

more options

Unfortunately safe mode doesn't work either. I'm not sure what you mean with Font Book issues, but i haven't changed any fonts and it worked not too long ago.