Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cuireadh an snáithe seo sa chartlann. Cuir ceist nua má tá cabhair uait.

All my sessions and settings on websites are not saved

  • 11 freagra
  • 2 leis an bhfadhb seo
  • 305 views
  • Freagra is déanaí ó FredMcD

more options

Hello! I've got a problem since a week in Firefox, all my sessions and settings on websites are not saved.

For exemple, when I want to use YouTube, I first get connected, then I turn on the dark mode. Until I close Firefox, it will save those settings, even in new tabs. But if I close and reopen Firefox, those settings are gone. I need to connect again on Youtube, and dark mode is no more activated.

Same issue on all websites except for those which were saved before the first time I saw the problem. But if I close my sessions on them, then it will be the same.

I tried to completely remove (program and userdata) Firefox and install it again, still the same. I tried to clear the cache, still the same. And I tried to reinitialize Firefox with its own function, still the same.

So I'm wondering if someone would help, because Firefox is my favorite browser and I can't get used to another.

Thanks, Tun.

PS : My english may be weird, I'm sorry for that.

Réiteach roghnaithe

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

Read this answer in context 👍 0

All Replies (11)

more options

What's your computer system and Firefox version?

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save

Note: Some software, like Advanced SystemCare with Surfing Protection, can protect files in the Firefox profile folder against changes. If you have such software then check the settings or uninstall this software.

more options

I'm using Firefox 64.0 on a Windows 10 Home 64 bit version.

I did not find the software called Advanced SystemCare on my computer. I don't think this could be the problem, I never heard about it.

more options

FredMcD said

Note: Some software, like Advanced SystemCare . . . .
more options

Hmmm ... How can I find them?

By the way, I followed your link and I did delete the prefs.js file as it was said, and it's still the same. Sad

Athraithe ag xTuningZz ar

more options

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh).

Jump around a few websites. Is the problem still there?

more options

Ok. It looks like it works when I'm in safe mode, I mean, I still need to get connected, then set the dark mode but if I restart Firefox using the safe mode thing, it will restart with those settings. But if I close it and reopen normally, they're gone. I can't really tell, it's strange.

Athraithe ag xTuningZz ar

more options

Réiteach Roghnaithe

https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes). If the problem goes away, that tells us one thing. If it does not, that tells us something else.


It could be the work of one of your add-ons, or it could be Hardware Acceleration. How to disable Hardware Acceleration {web link}

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Disable a few add-ons, then Restart Firefox.

Some added toolbar and anti-virus add-ons are known to cause Firefox issues. Disable All Of them.

If the problem continues, disable some more (restarting FF). Continue until the problem is gone. After, you know what group is causing the issue. Re-enable the last group ONE AT A TIME (restarting FF) until the problem returns.

Once you think you found the problem, disable that and re-enable all the others, then restart again. Let us know who the suspect is, detective.

more options

Ok, so I disabled all my addons and extensions and it was still the same. But I looked in the options, and I saw that in "privacy and security settings", the cookies was set to "keep them until I close Firefox". So I changed to "keep them until they expire". I did some test, and it's working, Firefox is now saving my sessions and preferences. I don't really understand how cookies work, but I guess it's important to keep them.

I also tried to re-enable all my addons and extensions, close my sessions, get connected again and it's still working.

So thanks a lot for your help! Your explanations was very accurate, so it was simple to follow your steps.

Tun.

more options

Hello xTuningZz,

Would you be so kind as to mark FredMcD's post (the one that "did it" for you) as Chosen Solution  ?

("Solved the problem" button to the right)

Thank you in advance  !

more options

Good work. Safe surfing.